On Sunday 11 December 2005 05:16, Manish Singh wrote:
> On Sat, Dec 10, 2005 at 10:10:50PM -0500, BandiPat wrote:
> > To Manish Singh:
> > SuSE and YaST2 work as well or better than any other file install
> > utility at solving dependencies.  Thing you fail to realize is that
> > -devel files are not dependencies.  The main files don't need the
> > -devel files to operate, nor does the system.  They are only needed
> > if the user intends to compile things.  The best thing to do when
> > installing any Linux is to just include -devel files or add them at
> > install time.
So either SuSE screwed up, which they have a history of doing
(glib-devel didn't depend on pkg-config for several releases, and I'm
not sure if it's fixed even now), or Myke used rpm --force (which I

If you look at Debian or Red Hat, libgimp2.0-dev or gimp-devel have a
dependency on libgtk2.0-dev or gtk2-devel, respectively, which of course
lets apt/yum/yast/etc. do resolve things properly.
> It sounds like you're the one who has failed to realize the -devel
> packages both can and do have dependencies.
> -Yosh
> _______________________________________________

Sure they (-devel files) have dependencies too and if they are found 
YaST2 solves them or alerts you to them.  All the things you mention, 
you assumed happened, so I'm going to assume you don't really know what 
you're talking about, if you're not running SuSE too.  Of course, if 
you like, you can use apt/yum/smart/ in SuSE too.  So, considering that 
SuSE gives you all those, are you just blaming yast2 or SuSE?  You seem 
to assume a lot here.

Gimp-user mailing list

Reply via email to