linux-integrity
Thread
Date
Earlier messages
Messages by Thread
[PATCH v5 0/7] tpm_crb: Add command and response buffer chunking support
Arun Menon
[PATCH v5 2/7] tpm_crb: Split start method into a separate header
Arun Menon
[PATCH v5 6/7] tpm_crb: Factor crb_send()/crb_recv() bodies into helpers
Arun Menon
Re: [PATCH v5 6/7] tpm_crb: Factor crb_send()/crb_recv() bodies into helpers
Jarkko Sakkinen
[PATCH v5 5/7] tpm: Increase TPM_BUFSIZE to 8KB for chunking support
Arun Menon
Re: [PATCH v5 5/7] tpm: Increase TPM_BUFSIZE to 8KB for chunking support
Jarkko Sakkinen
[PATCH v5 7/7] tpm_crb: Implement command and response chunking logic
Arun Menon
Re: [PATCH v5 7/7] tpm_crb: Implement command and response chunking logic
Jarkko Sakkinen
[PATCH v5 1/7] tpm_crb: Add register definitions of TPM CRB chunking fields
Arun Menon
[PATCH v5 3/7] tpm_crb: Add start_cmd parameter to tpm_crb_start wrapper
Arun Menon
[PATCH v5 4/7] tpm: tis_i2c: Use local 4KB buffer to limit memory usage
Arun Menon
Re: [PATCH v5 0/7] tpm_crb: Add command and response buffer chunking support
Jarkko Sakkinen
[PATCH v5] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v5] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
[PATCH v4] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v4] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v4] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v4] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
[RFC PATCH 00/14] Add macsmc support for Intel Macs, replacing applesmc
Atharva Tiwari
[RFC PATCH 04/14] iio/light: add new driver for macsmc
Atharva Tiwari
[RFC PATCH 12/14] hwmon/macsmc: add more types
Atharva Tiwari
[RFC PATCH 08/14] treewide: Add a flag to detect the Apple T2 chip
Atharva Tiwari
[RFC PATCH 01/14] treewide: Add backend for macsmc
Atharva Tiwari
[RFC PATCH 11/14] acpi: disable battery and adapter for x86 apple machines
Atharva Tiwari
[RFC PATCH 13/14] hwmon: add support for x86 macs in macsmc-hwmon
Atharva Tiwari
[RFC PATCH 02/14] platform/x86: add backend for macsmc in intel macs
Atharva Tiwari
Re: [RFC PATCH 02/14] platform/x86: add backend for macsmc in intel macs
Ilpo Järvinen
[RFC PATCH 09/14] treewide: disable other rtc's in t2 macs
Atharva Tiwari
[RFC PATCH 05/14] iio/accel: add driver for apple SMS
Atharva Tiwari
[RFC PATCH 03/14] watchdog: add driver for apple smc
Atharva Tiwari
Re: [RFC PATCH 03/14] watchdog: add driver for apple smc
Andy Shevchenko
[RFC PATCH 07/14] rtc: add support for x86 macs in macsmc-rtc
Atharva Tiwari
[RFC PATCH 14/14] mfd/macsmc: add ioctl to access smc keys
Atharva Tiwari
[RFC PATCH 10/14] power/supply: add support for x86 macs in macsmc-power
Atharva Tiwari
[PATCH v2 1/1] tpm: tis_i2c: Add reset delays for ST33KTPM2XI2C
Stefano Radaelli
Re: [PATCH v2 1/1] tpm: tis_i2c: Add reset delays for ST33KTPM2XI2C
Jarkko Sakkinen
[PATCH v3] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
[PATCH v1 1/1] tpm: tis_i2c: Add reset delays for ST33KTPM2XI2C
Stefano Radaelli
Re: [PATCH v1 1/1] tpm: tis_i2c: Add reset delays for ST33KTPM2XI2C
Jarkko Sakkinen
Re: [PATCH v1 1/1] tpm: tis_i2c: Add reset delays for ST33KTPM2XI2C
Stefano Radaelli
[PATCH v2] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v2] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v2] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
Re: [PATCH v2] KEYS: key_garbage_collector(): process in chunks
Jarkko Sakkinen
[PATCH v3 -next 00/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Cai Xinchen
[PATCH v3 -next 01/18] fs: pass struct path to notify_change()
Cai Xinchen
[PATCH v3 -next 05/18] LSM: pass struct path and struct file to the inode_setattr hook
Cai Xinchen
[PATCH v3 -next 07/18] LSM: pass struct path and struct file to the inode posix acl hooks
Cai Xinchen
[PATCH v3 -next 08/18] LSM: pass struct path and struct file to the inode fileattr hooks
Cai Xinchen
[PATCH v3 -next 06/18] LSM: pass struct path and struct file to the inode xattr hooks
Cai Xinchen
[PATCH v3 -next 14/18] LSM: rename inode_setsecctx to path_setsecctx
Cai Xinchen
[PATCH v3 -next 03/18] fs: pass struct path to xattr helpers
Cai Xinchen
[PATCH v3 -next 18/18] Documentation: Update landlock doc for metadata rights
Cai Xinchen
[PATCH v3 -next 11/18] LSM: rename the inode xattr hooks to path_xattr hooks
Cai Xinchen
[PATCH v3 -next 12/18] LSM: rename the inode posix acl hooks to path_*_acl hooks
Cai Xinchen
[PATCH v3 -next 17/18] samples/landlock: Add metadata rights to sandboxer
Cai Xinchen
[PATCH v3 -next 13/18] LSM: rename the inode fileattr hooks to path_file_* hooks
Cai Xinchen
[PATCH v3 -next 15/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Cai Xinchen
[PATCH v3 -next 10/18] LSM: rename inode_setattr to path_setattr
Cai Xinchen
[PATCH v3 -next 09/18] LSM: rename inode_getattr to path_getattr and pass struct file
Cai Xinchen
[PATCH v3 -next 02/18] LSM: pass struct path to the inode_setsecctx hook
Cai Xinchen
[PATCH v3 -next 16/18] selftests/landlock: Add tests for metadata access rights
Cai Xinchen
[PATCH v3 -next 04/18] fs: pass struct path to POSIX ACL helpers
Cai Xinchen
[PATCH 0/1] tpm: TEE driver for a discrete TPM owned by OP-TEE
Jorge Ramirez-Ortiz
[PATCH 1/1] tpm: add TEE driver for a discrete TPM behind OP-TEE
Jorge Ramirez-Ortiz
Re: [PATCH 1/1] tpm: add TEE driver for a discrete TPM behind OP-TEE
Jarkko Sakkinen
Re: [PATCH 1/1] tpm: add TEE driver for a discrete TPM behind OP-TEE
Jorge Ramirez
Re: [PATCH 1/1] tpm: add TEE driver for a discrete TPM behind OP-TEE
Jarkko Sakkinen
[PATCH] tpm: Check return value of crypto_kpp_set_secret()
Eric Biggers
Re: [PATCH] tpm: Check return value of crypto_kpp_set_secret()
Jarkko Sakkinen
Re: [PATCH] tpm: Check return value of crypto_kpp_set_secret()
Eric Biggers
Re: [PATCH] tpm: Check return value of crypto_kpp_set_secret()
Jarkko Sakkinen
Re: [PATCH] tpm: Check return value of crypto_kpp_set_secret()
Jarkko Sakkinen
Re: [PATCH] tpm: Check return value of crypto_kpp_set_secret()
Eric Biggers
Re: [PATCH] tpm: Check return value of crypto_kpp_set_secret()
Jarkko Sakkinen
[PATCH v4 0/6] tpm_crb: Add command and response buffer chunking support
Arun Menon
[PATCH v4 5/6] tpm: Increase TPM_BUFSIZE to 8kB for chunking support
Arun Menon
Re: [PATCH v4 5/6] tpm: Increase TPM_BUFSIZE to 8kB for chunking support
Jarkko Sakkinen
Re: [PATCH v4 5/6] tpm: Increase TPM_BUFSIZE to 8kB for chunking support
Jarkko Sakkinen
Re: [PATCH v4 5/6] tpm: Increase TPM_BUFSIZE to 8kB for chunking support
Arun Menon
Re: [PATCH v4 5/6] tpm: Increase TPM_BUFSIZE to 8kB for chunking support
Jarkko Sakkinen
[PATCH v4 1/6] tpm_crb: Add register definitions of TPM CRB chunking fields
Arun Menon
[PATCH v4 2/6] tpm_crb: Split start method into a separate header
Arun Menon
Re: [PATCH v4 2/6] tpm_crb: Split start method into a separate header
Jarkko Sakkinen
Re: [PATCH v4 2/6] tpm_crb: Split start method into a separate header
Arun Menon
Re: [PATCH v4 2/6] tpm_crb: Split start method into a separate header
Jarkko Sakkinen
[PATCH v4 3/6] tpm_crb: Add start_cmd parameter to tpm_crb_start wrapper
Arun Menon
[PATCH v4 4/6] tpm: tis_i2c: Use local 4KB buffer to limit memory usage
Arun Menon
[PATCH v4 6/6] tpm_crb: Implement command and response chunking logic
Arun Menon
Re: [PATCH v4 6/6] tpm_crb: Implement command and response chunking logic
Jarkko Sakkinen
Re: [PATCH v4 6/6] tpm_crb: Implement command and response chunking logic
Arun Menon
[PATCH v4 0/2] ima: reject modsig when detached data cannot be supplied
Jérémy Jean
[PATCH v4 1/2] ima: discard modsig when detached data cannot be supplied
Jérémy Jean
Re: [PATCH v4 1/2] ima: discard modsig when detached data cannot be supplied
Jérémy Jean
[PATCH v4 2/2] ima: audit failure to supply detached data for modsig
Jérémy Jean
Re: [RFC] Make hibernation work with lockdown
Jarkko Sakkinen
Re: [RFC] Make hibernation work with lockdown
Jarkko Sakkinen
[GIT PULL] TPM DEVICE DRIVER changes for v7.4-rc1
Jarkko Sakkinen
Re: [GIT PULL] TPM DEVICE DRIVER changes for v7.4-rc1
Jarkko Sakkinen
Re: [GIT PULL] TPM DEVICE DRIVER changes for v7.4-rc1
Jarkko Sakkinen
[GIT PULL] TPM DEVICE DRIVER changes for v7.4-rc1
Jarkko Sakkinen
Re: [GIT PULL] TPM DEVICE DRIVER changes for v7.4-rc1
pr-tracker-bot
Re: [PATCH v4 1/3] tee: qcomtee: Register qcom.tz.tpm service for discovery
Amirreza Zarrabi
Re: [PATCH v4 2/3] tpm: Introduce Qualcomm TPM driver
Amirreza Zarrabi
[PATCH v3 0/2] ima: reject modsig when detached data cannot be supplied
Jérémy Jean
[PATCH v3 1/2] ima: discard modsig when detached data cannot be supplied
Jérémy Jean
Re: [PATCH v3 1/2] ima: discard modsig when detached data cannot be supplied
Mimi Zohar
[PATCH v3 2/2] ima: audit failure to supply detached data for modsig
Jérémy Jean
Re: [PATCH v3 2/2] ima: audit failure to supply detached data for modsig
Mimi Zohar
Re: [PATCH v3 2/2] ima: audit failure to supply detached data for modsig
Jérémy Jean
[GIT PULL] KEYS: changes for v7.4-rc1
Jarkko Sakkinen
Re: [GIT PULL] KEYS: changes for v7.4-rc1
Linus Torvalds
Re: [GIT PULL] KEYS: changes for v7.4-rc1
Jarkko Sakkinen
Re: [GIT PULL] KEYS: changes for v7.4-rc1
pr-tracker-bot
Re: [PATCH v2 14/15] arm64: drtm: Call UNPROTECT_MEMORY
Jonathan Cameron
Re: [PATCH v2 14/15] arm64: drtm: Call UNPROTECT_MEMORY
Jason Gunthorpe
Re: [PATCH v2 14/15] arm64: drtm: Call UNPROTECT_MEMORY
Jason Gunthorpe
Re: [PATCH v2 11/15] arm64: drtm: Add macro definitions for DEN0113
Jonathan Cameron
Re: [PATCH v2 11/15] arm64: drtm: Add macro definitions for DEN0113
Jason Gunthorpe
Re: [PATCH v2 08/15] efi/libstub: Have efi_kaslr_relocate_kernel() handle extra_size
Jonathan Cameron
Re: [PATCH v2 08/15] efi/libstub: Have efi_kaslr_relocate_kernel() handle extra_size
Jason Gunthorpe
Re: [PATCH v2 03/15] efi/libstub: Free cmdline_ptr in efi_pe_entry
Jonathan Cameron
Re: [PATCH v2 07/15] efi/libstub: Add generic arch callbacks for DRTM
Jonathan Cameron
Re: [PATCH v2 06/15] efi/zboot: Lift efi_cache_sync_image() from efi_zboot_decompress()
Jonathan Cameron
Re: [PATCH v2 04/15] efi/libstub: Add a general way to get symbols from the vmlinux into zboot
Jonathan Cameron
Re: [PATCH v2 02/15] efi/riscv: libstub: Don't set image_size in handle_kernel_image()
Jonathan Cameron
Re: [PATCH v4 0/3] Add TPM support via Qualcomm TEE TPM TA
Kuldeep Singh
Re: [PATCH v4 0/3] Add TPM support via Qualcomm TEE TPM TA
Jarkko Sakkinen
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Yeoreum Yun
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Jason Gunthorpe
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Yeoreum Yun
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Yeoreum Yun
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Jason Gunthorpe
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Yeoreum Yun
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Jonathan Cameron
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Jason Gunthorpe
Re: [PATCH v2 15/15] efi/arm64: Implement ARM64 DRTM in the stub
Jonathan Cameron
Re: [PATCH v2 12/15] arm64: drtm: Update the linker script for EFI_STUB_DRTM
Yeoreum Yun
Re: [PATCH v2 12/15] arm64: drtm: Update the linker script for EFI_STUB_DRTM
Jason Gunthorpe
Re: [PATCH] KEYS: trusted: Reject short TPM2 public areas
Jarkko Sakkinen
[PATCH v2] KEYS: trusted: Reject short TPM2 public areas
Daehyeon Ko
Re: [PATCH v2] KEYS: trusted: Reject short TPM2 public areas
Jarkko Sakkinen
[PATCH v2] kexec: Select ima_get/free_kexec_buffer() with CONFIG_HAVE_IMA_KEXEC(_OF)
Roberto Sassu
Re: [PATCH v2] kexec: Select ima_get/free_kexec_buffer() with CONFIG_HAVE_IMA_KEXEC(_OF)
Mimi Zohar
Re: [PATCH v2] kexec: Select ima_get/free_kexec_buffer() with CONFIG_HAVE_IMA_KEXEC(_OF)
Jonathan McDowell
Re: [PATCH v2] kexec: Select ima_get/free_kexec_buffer() with CONFIG_HAVE_IMA_KEXEC(_OF)
Krzysztof Kozlowski
Re: [PATCH v2] kexec: Select ima_get/free_kexec_buffer() with CONFIG_HAVE_IMA_KEXEC(_OF)
Srish Srinivasan
Re: [PATCH v2] kexec: Select ima_get/free_kexec_buffer() with CONFIG_HAVE_IMA_KEXEC(_OF)
Catalin Marinas
GIT PULL] integrity: subsystem fixes for v7.4
Mimi Zohar
Re: [PATCH v2 2/2] tpm_crb: Raise durations for Amazon NitroTPM
Surendran Kanagaraj
Re: [PATCH v2 2/2] tpm_crb: Raise durations for Amazon NitroTPM
Jarkko Sakkinen
Re: [PATCH v2 2/2] tpm_crb: Raise durations for Amazon NitroTPM
Jarkko Sakkinen
[PATCH v2 -next 00/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Cai Xinchen
[PATCH v2 -next 02/18] LSM: pass struct path to the inode_setsecctx hook
Cai Xinchen
[PATCH v2 -next 03/18] fs: pass struct path to xattr helpers
Cai Xinchen
[PATCH v2 -next 06/18] LSM: pass struct path to the inode xattr hooks
Cai Xinchen
[PATCH v2 -next 16/18] selftests/landlock: Add tests for metadata access rights
Cai Xinchen
[PATCH v2 -next 08/18] LSM: pass struct path to the inode fileattr hooks
Cai Xinchen
[PATCH v2 -next 15/18] LSM: rename inode_setsecctx to path_setsecctx
Cai Xinchen
[PATCH v2 -next 18/18] Documentation: Update landlock doc for metadata rights
Cai Xinchen
[PATCH v2 -next 09/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Cai Xinchen
Re: [PATCH v2 -next 09/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Justin Suess
Re: [PATCH v2 -next 09/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Günther Noack
Re: [PATCH v2 -next 09/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Cai Xinchen
Re: [PATCH v2 -next 09/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Cai Xinchen
[PATCH v2 -next 04/18] fs: pass struct path to POSIX ACL helpers
Cai Xinchen
[PATCH v2 -next 11/18] LSM: rename inode_setattr to path_setattr
Cai Xinchen
[PATCH v2 -next 13/18] LSM: rename the inode posix acl hooks to path_*_acl hooks
Cai Xinchen
[PATCH v2 -next 10/18] LSM: rename inode_getattr to path_getattr
Cai Xinchen
[PATCH v2 -next 14/18] LSM: rename the inode fileattr hooks to path_file_* hooks
Cai Xinchen
[PATCH v2 -next 01/18] fs: pass struct path to notify_change()
Cai Xinchen
Re: [PATCH v2 -next 01/18] fs: pass struct path to notify_change()
Christian Brauner
Re: [PATCH v2 -next 01/18] fs: pass struct path to notify_change()
Cai Xinchen
[PATCH v2 -next 05/18] LSM: pass struct path to the inode_setattr hook
Cai Xinchen
[PATCH v2 -next 17/18] samples/landlock: Add metadata rights to sandboxer
Cai Xinchen
[PATCH v2 -next 12/18] LSM: rename the inode xattr hooks to path_xattr hooks
Cai Xinchen
[PATCH v2 -next 07/18] LSM: pass struct path to the inode posix acl hooks
Cai Xinchen
Re: [PATCH v2 -next 00/18] landlock: Add READ_METADATA and WRITE_METADATA access rights
Christian Brauner
[PATCH v3] ima: recover number of violations after kexec
Enrico Bravi
Re: [PATCH v3] ima: recover number of violations after kexec
Roberto Sassu
[PATCH] ima: bind cached appraisal results to policy identity
Sung Byeongchan
Re: [PATCH] ima: bind cached appraisal results to policy identity
Roberto Sassu
[GIT PULL] KEYS changes for v7.3-rc7
Jarkko Sakkinen
Re: [GIT PULL] KEYS changes for v7.3-rc7
Linus Torvalds
Re: [GIT PULL] KEYS changes for v7.3-rc7
Jarkko Sakkinen
Re: [GIT PULL] KEYS changes for v7.3-rc7
pr-tracker-bot
[PATCH v2 0/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Yuqi Xu
[PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Yuqi Xu
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Jarkko Sakkinen
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Jarkko Sakkinen
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Yuqi Xu
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Yuan Tan
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Jarkko Sakkinen
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Jarkko Sakkinen
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Yuqi Xu
Re: [PATCH v2 1/1] tpm: reject duplicate PCR banks in tpm2_get_pcr_allocation
Jarkko Sakkinen
[QUESTION] IMA: kexec appraisal and the unauthenticated target command line
Danny Hu
Re: [QUESTION] IMA: kexec appraisal and the unauthenticated target command line
Mimi Zohar
Re: [QUESTION] IMA: kexec appraisal and the unauthenticated target command line
Danny Hu
Re: [QUESTION] IMA: kexec appraisal and the unauthenticated target command line
Danny Hu
Earlier messages