I have not look to a LyX code. My behaviour was like a simple regular
user - i set in a preferencies dialog some settings, and if that does
not worked for me - i write a mail to a mailing list...

And, when will be avalable LyX with more standart settings and with
better suport different languages, like Lithuanian or Latvian?

And, why is solution to set utf8x and L7x,T1 in preferencies so
deprecated and should be do not used? But this solution is only, those
was worked for me like expected...

Another thing - when I set ASCII for Lithuanian language, error related
to L7x still exists. 
Kt, 2010 12 02 08:22 +0000, Guenter Milde rašė:
> On 2010-12-01, Egidijus Kamarauskas wrote:
> > Hallo.
> > On my system have I installed texlive-lang-lithuanian package and I have
> > on my machine lithuanian.ldf file (It is placed
> > on /usr/share/texmf-texlive/tex/latex/lithuanian/lithuanian.ldf , so
> > told me Synaptic).
> This looks OK.
> > I have tried to do this things like set Document>Settings>Language
> > Lithuanian and without other 
> > \usepackage{lit...} in the preamble, 
> This too.
> > either to set utf8x. Errors exists. I can not write Lithuanian texts.
> > If I use English in settings, I can write this letters - ąčęėįšųūž, LyX
> > compiles document very well, but Figure is Figure, Part is Part, and I
> > can not change to right words. 
> You could copy the code that defines the Lithuanian translations from
> lithuanian.ldf to your preamble, but this would leave the hyphenation
> at English, so better find another way.
> > Now I have attached my LyX file :
> > newfile1.lyx with text. Try to set Lithuanian language and compile.
> Thanks for the file. I cannot compile here (without installing the
> texlive-lang-lithuanian Debian package).
> However, View>Source with a tick at "complete sourec" revealed a strange
> thing:
> The document preamble starts:
>   \documentclass{article}
>   \usepackage[T1]{fontenc}
>   \usepackage[l7xenc]{inputenc}
>   \usepackage[lithuanian]{babel}
> But L7x is a *font* encoding, no *input* encoding.
> Loading it with "inputenc" is a bug.
> (The correct way would be ``\usepackage[L7x,T1]{fontenc}`` or
>  ``\usepackage[T1,L7x]{fontenc}``, the last option becomes the default
>  font encoding).
> This buggy line goes away, when I change
> Document>Settings>Language>Encoding from "Language default" to ASCII.
> However, I found no occurence of the string "l7x" in the .lyx source
> file, nor in LYX's languages file!
> Günter

Reply via email to