Bruce Momjian wrote:
> Alvaro Herrera wrote:
> > Bruce Momjian wrote:
> > > Andrew Dunstan wrote:
> > > >
> > > > >> I suggest "redirect_logs", although it's arguably too general as it
> > > > >> doesn't apply to syslog/eventlog.
> > > > >
> > > > > Perhaps it should be named analogously to stats_start_collector,
> > > > > ie think of the syslogger process as a "log collector". I don't
> > > > > much like "log_start_collector" though --- "start_log_collector"
> > > > > seems far less confusing as to where the verb is.
> > > >
> > > > Nobody else seems to care much. I'll go with "start_log_collector".
> > >
> > > Are we trying to use log_* prefixes, e.g. log_start_collector?
> > That sounds like you want to log when the collector starts, which is not
> > the case and is confusing -- what collector is it talking about? This
> > is about starting the log collector.
> Yea, good point. I was just wondering because I don't see 'start' used
> in anywhere at the beginning of a GUC variable.
Good point too. In other places we just name the feature that's to be
started, for example we don't use "start_autovacuum".
Alvaro Herrera http://www.flickr.com/photos/alvherre/
"Granting software the freedom to evolve guarantees only different results,
not better ones." (Zygo Blaxell)
---------------------------(end of broadcast)---------------------------
TIP 2: Don't 'kill -9' the postmaster