Josh Berkus <[EMAIL PROTECTED]> writes:
>> The problem here is that "log" seems to be a verb in "log_collector"
>> which is what makes it confusing.  So we need another verb to make it
>> clear that "log" is not one.  This is not a problem with "autovacuum"
>> because that one cannot be confused with a verb.
>> start_log_collector still gets my vote.

> log_collector_enable or log_collector_start or even log_redirect.  But 
> something with log_*

I'm voting with Alvaro on this.  All of your suggestions are confusing
because "log" looks like the verb, which it is not.  Specifically, they
sound like what the switch does is to cause a log message to be emitted
about some action that would occur anyway.

                        regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 9: In versions below 8.0, the planner will ignore your desire to
       choose an index scan if your joining column's datatypes do not

Reply via email to