> The problem here is that "log" seems to be a verb in "log_collector"
> which is what makes it confusing.  So we need another verb to make it
> clear that "log" is not one.  This is not a problem with "autovacuum"
> because that one cannot be confused with a verb.
> start_log_collector still gets my vote.

I vote against.  Remember that some people look at the GUCs in alpha order 
from pg_settings.  As such, if we're changing GUC names it ought to be in a 
way that groups logically if we can.

log_collector_enable or log_collector_start or even log_redirect.  But 
something with log_*

Josh Berkus
PostgreSQL @ Sun
San Francisco

---------------------------(end of broadcast)---------------------------
TIP 1: if posting/reading through Usenet, please send an appropriate
       subscribe-nomail command to [EMAIL PROTECTED] so that your
       message can get through to the mailing list cleanly

Reply via email to