Hi Alex,
> That's interesting! i3 is a 64-bit CPU, right? So the check for long> mode 
> doesn't work? I would at least expect an error message.
Yes it is also a 64-bit, just now i also got the same result here at my room's 
PC which is an AMD64, how is the checking done btw?

> The checks are done in "pilos/x86-64/beg.l" starting from line 32. If> the 
> checks were successful, it should next print "Initializing memory".> 
> Otherwise, we should see "ERROR: CPU does not support long mode" or> "ERROR: 
> CPU has no local APIC".
OK did a quick peek and most of them are in x86 assembly hmmm

> Normally, all those messages are not visible, because the boot is so> fast 
> that they are overwritten quickly.>> ...> > No, it all goes in a tiny 
> fraction of a second. Normally, you don't see> any of the messages.
I see, so it means it got stuck somewhere on the checking, would it be possible 
to be inside an infinite loop? hmm if only there is a WDT... is it possible to 
have a debug mode for PilOS that it will not overwrite the messages? Like it 
will just do a newline per message like we did with pilMCU emulator version? 
Might be useful during polishing pilOS to able to boot in all different x86-64 

> I think other people also tried VirtualBox, and said it doesn't work. It> 
> doesn't even load the remaining sectors from the drive. This is done via> 
> BIOS interrupt 0x13:>>  
> https://en.wikipedia.org/wiki/INT_13#INT_13h_AH.3D42h:_Extended_Read_Sectors_From_Drive>>
>  I think VirtualBox doesn't support this interrupt call.
I see, ok noted. But still this can be reworked right? Coz it would be nice to 
have it boot in all cases as long as its x86-64 machine, correct?

> Alex, you already got the following results, I'm just reposting them to the 
> list> as well.>> I have tried PilOS on the following machines:
Hi Mattias, thanks for sharing your list! It looks like the current pilOS is 
tailored for Acer hardware's hmmm might make sense coz Alex developed it on his 
Acer laptop as well...



     On Wednesday, July 8, 2015 6:57 PM, Mattias Sundblad 
<mattias....@gmail.com> wrote:

 Hi George and Alex,

> Yes! i was able build the image and immediately tried it using my USB stick, 
> it's working!!! but I'm stuck at "Checking long mode".. maybe because I'm 
> trying it under an Intel i3? Let me try it with my AMD machine back in my 
> room and feedback to you how it goes... this is great!!

I ran into the same message when trying to boot PilOS on an Asus UL30A,
this machine has a core2duo cpu.

Alex, you already got the following results, I'm just reposting them to the list
as well.

I have tried PilOS on the following machines:

*Acer Aspire One 722, AMD C-60 cpu
Everything works fine on this machine.

*Lenovo Thinkpad x201i, i3 cpu
Fails with the message "READ ERROR 08"

*Lenovo Thinkpad x230, i5 cpu
Fails with the message "READ ERROR 01"

*and finally the Asus UL30A, Core2Duo cpu
Does not get past the message "Checking long mode"

Best regards,

UNSUBSCRIBE: mailto:picolisp@software-lab.de?subject=Unsubscribe


Reply via email to