On 2017-08-09 10:46-0000 Arjen Markus wrote:

-----Original Message-----
From: Alan W. Irwin [mailto:ir...@beluga.phys.uvic.ca]
Sent: Wednesday, August 09, 2017 10:51 AM

That is a report for Cygwin which you apparently ran on 2017-08-07, but which 
have not described yet.  Is that the one where you addressed all the remaining
Cygwin platform regressions?

No, I thought I would run the tests again without the "-DNON_TRANSITIVE" option 
to make sure nothing ontowards would occur.

OK.  That sounds like that was an interim Cygwin result that I should ignore.

What I requested was the report for the MinGW-w64/MSYS2 test you did recently
with Qt4 and diffutils installed where there were unexpected PostScript 


I noticed there is a difference between the results with the "MSYS
Makefiles" generator and the "Unix Makefiles" generator using
MinGW-w64/MSYS2. It is subtle (see the extra files with only the
output from CMake) but it causes wxWidgets not to be found in the
latter case. The recommendation should probably be (at this moment) to
use the former, though in principle there should not matter, I think.

"MSYS Makefiles" historically worked for MinGW/MSYS so I would expect
(as you have found) it would continue to work for MinGW-w64/MSYS2.
From your results it also appears that "Unix Makefiles" (which I never
tried for MinGW/MSYS) almost works now for MinGW-w64/MSYS2.  It is
possible we could get "Unix Makefiles" to work completely for
MinGW-w64/MSYS with some changes to cmake/modules/FindwxWidgets.cmake,
but I think that is something we should only pursue post-release.

No luck sofar with PyQt4 - it appears I need both SIP (got that),
pyqt4 (got that) and pyqtconfig (presenting a puzzle). The latter
component has me puzzled, as I do not know anything about Python
package management. First I downloaded a tarball for pyqtconfig, from
PyPI, but it has no instructions on the actual installation. It seems
I need PIP, so I got that, but that does not show up as a runnable
command (either in the command shell or in the Python shell). So I am
stuck, unless it is a matter of unpacking the tarball in the right

Please advise me on how to proceed.

If what you have done is unpacked an external tarball (i.e., the
pyqtconfig tarball you mentioned) on top of your existing
MinGW-w64/MSYS2 snapshot system files, then I cannot emphasize enough,
that procedure is absolutely not recommended.  The issue is that
overwriting your system that way can introduce system
incompatibilities and even security issues for your platform.

So if you did overwrite your system that way, then to retrieve the
 situation (i.e., go back to a pure form of MinGW-w64/MSYS2 without
 such overwriting you need to install a new snapshot from scratch. So
 I hope you have automated that procedure as I suggested to make that
 procedure convenient for you to do.

Once you are back to pure MinGW-w64/MSYS2 (or if you are already there
because you did not do what I described above), then the question
is why is pyqtconfig missing (which I presume is the issue you
were trying to solve by unpacking that external tarball)?

I suggested you install mingw-w64-x86_64-python3-sip AND all its
dependencies, and I assume you have done that, but the issue
is likely that you need to
install one or more additional packages to get access to "pyqtconfig"

For example, on Debian Jessie my search for packages which contain
any file with "pyqtconfig" somewhere in the filename yielded the following:

irwin@raven> apt-file search pyqtconfig
python-qt4: /usr/lib/python2.7/dist-packages/PyQt4/pyqtconfig.py
python-qt4-dbg: /usr/lib/python2.7/dist-packages/PyQt4/pyqtconfig_d.py
python3-pyqt4: /usr/lib/python3/dist-packages/PyQt4/pyqtconfig.py
python3-pyqt4: /usr/lib/python3/dist-packages/PyQt4/pyqtconfig_nd4.py
python3-pyqt4-dbg: /usr/lib/python3/dist-packages/PyQt4/pyqtconfig_d4.py

I only have the names of the MinGW-w64/MSYS2 packages available to
me and not their file contents, but if you currently do not have
mingw-w64-x86_64-python3-pyqt4 installed, I suggest you install
that package to see if that solves the missing pyqtconfig issue.

By the way, this missing files problem will likely occur many more
times for you with MinGW-w64/MSYS2. And you obviously should not have
to guess (which is what we are doing here) at MinGW-w64/MSYS2 packages
you need to install based on what files Debian provides in their own
packages.  Therefore, I strongly suggest you should ask on the MSYS2
list what is the recommended equivalent of the Debian apt-file command
to search all (both installed and uninstalled) MinGW-w64/MSYS2
packages for any given filename pattern.

This issue of finding filename patterns in system packages has come up
before between us, and at that time I did a google search and found
somone else had asked that question on the MSYS2 list several years
ago, but the answer provided then did not work for you. So it is now
time for you to ask that question directly and iterate with the list
until you do have an answer that actually works for modern

I will now take a look at your latest report tarball and comment
separately on what I find there.


Alan W. Irwin

Astronomical research affiliation with Department of Physics and Astronomy,
University of Victoria (astrowww.phys.uvic.ca).

Programming affiliations with the FreeEOS equation-of-state
implementation for stellar interiors (freeeos.sf.net); the Time
Ephemerides project (timeephem.sf.net); PLplot scientific plotting
software package (plplot.sf.net); the libLASi project
(unifont.org/lasi); the Loads of Linux Links project (loll.sf.net);
and the Linux Brochure Project (lbproject.sf.net).

Linux-powered Science

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Plplot-devel mailing list

Reply via email to