Mar 16, 2019, 2:31 AM by

> Issues...
> * When launching a program from the Qubes menu, particularly if the
>  target   appVM has to be started, the program often fails to be
>  launched. This happens very frequently with the Text Editor.
Interesting, my experience is limited to mostly debian-based templates and for 
those, the only program that fails to start from the menu is gnome-terminal. 

>  Since I had been using Linux distributions based, directly or
>  indirectly, on Debian, when I first set up Qubes, I created my appVMs
>  based on Debian. That  was painful as I then had to install a lot of
>  basic software.
>  When I re-read the documentation, I realized the security reasons,
>  so I switched all my appVMs (except one!) back to Fedora. It was not
>  painful, but I would have rather have spent the time doing something
>  else.
I've never come across guidance favoring Fedora over Debian in the docs. Can 
you provide a link? 

>  Since Firefox and Flash were working fine on my Linux Mint laptop
>  (which I use "to play with"), I re-based my untrusted appVM on Debian
>  and, lo and behold, Firefox and Flash worked just fine. This, by the
>  way, was when I attempted to use Chromium.
This is how I used to get flash working too - chromium + some flash plugin on a 
debian-based appvm. Thankfully flash is dying and I don't need it anymore.

>  At least for some people, it seems Debian is a necessity, but it is
>  not given the attention it deserves. At a minimum, a GUI software
>  installer should be included in the Qubes distribution which would
>  make it much easier for people to install other software they feel
>  inclined to use.
I think the policy is that Qubes defers to the distro. So if the distro doesn't 
have a GUI installer, than the template won't, and it sounds like it would be 
out of scope for Qubes to provide a GUI installer.

On the flip side, if the distro has an optional GUI package manager, it should 
work. For example, for debian, have you tried installing synaptic in the 

> * Screenshot only appears to work from Qubes Tools. I can "add"
>  "Screenshot" to appVMVs based on Fedora (but not on Debian). But it
>  does not work -- The dialog comes up but, having chosen to select an
> area, I cannot do so.
>  Subsequent attempts to use Screenshot do not even present a dialog.
>  Although I have not seen this documented anywhere (which does not
>  mean it is not), it seems logical -- dom0 owns the screen (monitor),
>  so it makes sense that it handles screenshots. However, that means
>  screenshots are saved in dom0 and have to be moved (or, I suppose,
>  copied) to the desired appVM. It seems a bit awkward. If one is in a
>  program in an appVM and decides a screenshot would be nice, it is
>  probably focussed on that window or a portion of it. Since the OS
>  displaying the window "knows" what it is displaying, it seems logical
>  that some kind of screenshot could be made by that OS, but restricted
>  to its window.
It *would* be nice if you could right-click a file in dom0 and send to VM using 
the VM picker. Useful for screenshots and log files, for GUI-inclined users.

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
To view this discussion on the web visit
For more options, visit

Reply via email to