Emil Ong schrieb:
> On Wed, May 13, 2009 at 12:24:19PM +0200, Michael Ludwig wrote:

> Eclipse's WTP framework doesn't really allow for putting platform
> dependent string in.  Without rewriting that part of the framework,
> we have to choose some default for everybody.

Alright, it's not important. It just added to the uncertainty about how
to use it.

>> I'm still seeing the same error message pop up on shutdown via the
>> Eclipse server shutdown button: "failed to start" (sic).

This is still there. Might be related to the other issue I wrote
concerning the progress indicator in the bottom right corner of the
IDE which keeps showing the job "Starting Resin 4.0 at localhost" in
progress. Looks like that message got held up somewhere on its way to
the list, so here's a copy of it:

| Another issue: The process of starting Resin keeps sitting around in
| the background while Resin is already serving requests. This is
| indicated in the Eclipse IDE by a symbol in the bottom right corner
| indicating ongoing background jobs.
| After some minutes, the following error message pops up:
|    Server Resin 4.0 at localhost was unable to start withing 240
|    seconds. If the server requires more time, try increasing the
|    timeout in the server editor.
| Sounds like the Resin start job (Ant in this case, as per your mail)
| should report back to Eclipse on finishing the job.

So after a couple of minutes, this error message pops up in a window
labeled "Problem Occurred" and the running and serving Resin is stopped,
maybe because it hasn't reported startup success back to the parent

I added -consoleLog to my eclipse.ini, but I have no idea where the log
is going. If it is just the console window in the IDE, there is nothing
special to see, just the usual Resin startup messages plus additional
debug info my application generates.

>> (2) "in place"
>> A new error message :-) - "Reference to undefined variable
>> resin.configuration.file". Won't start :-(

I can't reproduce this error. But I swear it was there the first time

But with this "in place" configuration, all I get is 404. I tried all
kinds of possible context paths, but none seems to work. Which is sort
of logical, as I don't see my application's startup blurb in the console
log. On the other hand, Resin mentions it (DbXml01):

[20:13:46.062] {main} resin.home = C:\MILU\Server\resin-4.0.0\
[20:13:46.062] {main} resin.root = C:\MILU\Server\resin-4.0.0\
[20:13:46.328] {main} resin.conf = 
[20:13:46.328] {main}
[20:13:46.328] {main} server     = (:)
[20:13:46.328] {main} user.name  = MiLu
[20:13:46.328] {main}
[20:13:46.593] {main} WebApp[http://default/DbXml01] active
[20:13:46.593] {main} Host[default] active
[20:13:46.593] {main}
[20:13:46.609] {main} http listening to *:8099
[20:13:46.625] {main}
[20:13:46.625] {main} Server[id=,cluster=] active
[20:13:46.625] {main} Resin[id=] started in 1188ms

20:14:59,20 C:\MILU\dev\ds
# netstat -p tcp -na | findstr 8099
   TCP               ABHÖREN
   TCP         FIN_WARTEN_2

The port I specified is taken into account, the address isn't.

Michael Ludwig

resin-interest mailing list

Reply via email to