Surprisingly though, I am able to send mails using Thunderbird and same settings.
On Fri, Apr 24, 2009 at 12:22 PM, Ritesh Nadhani <[email protected]> wrote: > Alright, finally I got some more time off work to review it. > > Not sure what is the problem. If I give incorrect SMTP details, > reviewboard fails with the exception: > > Traceback: > File > "/usr/lib/python2.5/site-packages/Django-1.0.2_final-py2.5.egg/django/core/handlers/base.py" > in get_response > 86. response = callback(request, *callback_args, > **callback_kwargs) > File > "/usr/lib/python2.5/site-packages/Django-1.0.2_final-py2.5.egg/django/views/decorators/cache.py" > in _wrapped_view_func > 44. response = view_func(request, *args, **kwargs) > File > "/usr/lib/python2.5/site-packages/Djblets-0.5beta1-py2.5.egg/djblets/webapi/decorators.py" > in _checklogin > 32. response = view_func(request, *args, **kwargs) > File > "/usr/lib/python2.5/site-packages/ReviewBoard-1.0beta2-py2.5.egg/reviewboard/webapi/json.py" > in review_request_publish > 493. review_request.publish(request.user) > File > "/usr/lib/python2.5/site-packages/ReviewBoard-1.0beta2-py2.5.egg/reviewboard/reviews/models.py" > in publish > 458. mail_review_request(user, self, changes) > File > "/usr/lib/python2.5/site-packages/ReviewBoard-1.0beta2-py2.5.egg/reviewboard/reviews/email.py" > in mail_review_request > 184. extra_context) > File > "/usr/lib/python2.5/site-packages/ReviewBoard-1.0beta2-py2.5.egg/reviewboard/reviews/email.py" > in send_review_mail > 114. message.send() > File > "/usr/lib/python2.5/site-packages/Django-1.0.2_final-py2.5.egg/django/core/mail.py" > in send > 271. return self.get_connection(fail_silently).send_messages([self]) > File > "/usr/lib/python2.5/site-packages/Django-1.0.2_final-py2.5.egg/django/core/mail.py" > in send_messages > 166. new_conn_created = self.open() > File > "/usr/lib/python2.5/site-packages/Django-1.0.2_final-py2.5.egg/django/core/mail.py" > in open > 131. > local_hostname=DNS_NAME.get_fqdn()) > File "/usr/lib/python2.5/smtplib.py" in __init__ > 244. (code, msg) = self.connect(host, port) > File "/usr/lib/python2.5/smtplib.py" in connect > 310. raise socket.error, msg > > Exception Type: error at /api/json/reviewrequests/8/publish/ > Exception Value: (111, 'Connection refused') > > So that means the mailing module is being called. > > When I give right details, it just succeeds without any error...but > the mail is never delivered? > > On Tue, Apr 14, 2009 at 2:06 PM, Ritesh Nadhani <[email protected]> wrote: >> Thanks Christian for all the inputs. >> >> I will work on it this after work later today and will try to find out >> problems on my side. There has to be something stupid going on my side >> as I believe people have been using RB without any problem :) >> >> Yes, I can also try with an internal server. Will come back with feedback >> soon. >> >> On Tue, Apr 14, 2009 at 1:40 PM, Christian Hammond <[email protected]> >> wrote: >>> It looks like your configuration is set up to log server connections/errors >>> to an SQL database, and it's not configured correctly. So that's what most >>> of those errors are. I don't see anything in there that would tell us more >>> here. >>> >>> Generally, if your e-mail address is set for the administrator contact info >>> in General Settings, and DEBUG is False, you would receive an e-mail with >>> the error info. But of course that implies that you have e-mail working :) >>> The other method is to set DEBUG to True and then click the button on that >>> error banner for seeing more info, but if the page is jumping away, that >>> won't work so well. >>> >>> I don't have a working solution off-hand that I can recommend. I'll give it >>> some thought. >>> >>> Is there another e-mail server you can use that's internal? >>> >>> Christian >>> >>> -- >>> Christian Hammond - [email protected] >>> Review Board - http://www.review-board.org >>> VMware, Inc. - http://www.vmware.com >>> >>> >>> On Tue, Apr 14, 2009 at 10:08 AM, Ritesh Nadhani <[email protected]> wrote: >>>> >>>> Hello >>>> >>>> On Mon, Apr 13, 2009 at 7:40 PM, Christian Hammond <[email protected]> >>>> wrote: >>>> > The e-mail settings being lost sounds like an issue we just fixed in a >>>> > nightly. If you set the e-mail settings and then restart your web >>>> > server, do >>>> > they still disappear? >>>> >>>> Interestingly no. I restarted Apache couple of times and it kept the >>>> record. Though after submitting 3-4 times, it loses it. Probably, >>>> fixed in the nightly. >>>> >>>> So how do I go about testing it? Should I just get the SVN and do - >>>> sudo setup.py install or do I have to upgrade the site also? >>>> >>>> This is a test machine so I can play around with stuff. >>>> >>>> > >>>> > It's hard to say what's wrong with your e-mail settings. Can you check >>>> > your >>>> > web server's error log and see if there's any backtraces? >>>> > >>>> >>>> Hmm, for some reason - the error message stayed for one second longer >>>> and it seemed to be some server error. >>>> >>>> tail -f /var/log/apache2/error.log >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: child spawned but >>>> unable to open database link >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: insufficient >>>> configuration info to establish database link >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: child spawned but >>>> unable to open database link >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: insufficient >>>> configuration info to establish database link >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: child spawned but >>>> unable to open database link >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: insufficient >>>> configuration info to establish database link >>>> [Tue Apr 14 10:05:45 2009] [error] mod_log_sql: child spawned but >>>> unable to open database link >>>> [Tue Apr 14 10:05:45 2009] [notice] Apache/2.2.8 (Ubuntu) >>>> mod_python/3.3.1 Python/2.5.2 PHP/5.2.4-2ubuntu5.5 with Suhosin-Patch >>>> configured -- resuming normal operations >>>> [Tue Apr 14 10:06:02 2009] [error] mod_log_sql: insufficient >>>> configuration info to establish database link >>>> [Tue Apr 14 10:06:02 2009] [error] mod_log_sql: child spawned but >>>> unable to open database link >>>> >>>> Does that help? I dont know how it can be database error because it >>>> seems to be the storing the data correctly. >>>> >>>> > Christian >>>> > >>>> > -- >>>> > Christian Hammond - [email protected] >>>> > Review Board - http://www.review-board.org >>>> > VMware, Inc. - http://www.vmware.com >>>> > >>>> > >>>> > On Mon, Apr 13, 2009 at 4:07 PM, Ritesh Nadhani <[email protected]> >>>> > wrote: >>>> >> >>>> >> Hello >>>> >> >>>> >> So I created 3 users and added them to default reviewer group. I then >>>> >> went to Admin section and added the Email settings. I added my gmail >>>> >> settings and checking use TLS authentication. >>>> >> >>>> >> According to docs at >>>> >> >>>> >> >>>> >> http://www.review-board.org/docs/manual/dev/admin/management/review-groups/#e-mail-and-review-groups, >>>> >> since I dont have any mailing list attached to the repository so it >>>> >> will send mail to everybody in the review board. >>>> >> >>>> >> After doing the email settings, I went ahead and added a request. For >>>> >> some reason, the process got stuck when I click on Publish. The >>>> >> buttons are greyed out and nothing happened. Clicking on "View Diff" >>>> >> threw up some error for microsecond which I could not read. Then the >>>> >> publish/discard publish were gone and the patch was correctly >>>> >> submitted. >>>> >> >>>> >> Hoping that the mail was sent, I check my inbox and nothing there. >>>> >> >>>> >> I repeat the process using the same patch and test and same errors. I >>>> >> could not read the error :( >>>> >> >>>> >> Suddenly, it worked. But no mails. I went and checked the email >>>> >> settings and BAM and everything was gone. The settings were changed to >>>> >> the default localhost and port 25. Hmm. >>>> >> >>>> >> I edited the settings and tried to repeat the process and same thing. >>>> >> First 3-4 times (though I could not repeat the exact number of times) >>>> >> will give you an error (which will only stay for couple of >>>> >> microseconds and go off). Then suddenly it works and the email >>>> >> settings are lost. >>>> >> >>>> >> Setting the debug value to True as suggested at: >>>> >> >>>> >> >>>> >> http://groups.google.com/group/reviewboard/browse_thread/thread/42fd2fd6ee5285bd?pli=1 >>>> >> >>>> >> Nothing special happened except that the error stayed for some more >>>> >> time and I was able to catch a glimpse: >>>> >> >>>> >> Publishing of the draft has failed for some reason Error 0 (i think). >>>> >> >>>> >> Please contact your admin. >>>> >> >>>> >> If I go and remove the email, then everything works. >>>> >> >>>> >> Any idea how I can debug this problem? >>>> >> >>>> >> -- >>>> >> Ritesh >>>> >> http://www.riteshn.com >>>> >> >>>> >> >>>> > >>>> > >>>> > > >>>> > >>>> >>>> >>>> >>>> -- >>>> Ritesh >>>> http://www.riteshn.com >>>> >>>> >>> >>> >>> >>> >>> >> >> >> >> -- >> Ritesh >> http://www.riteshn.com >> > > > > -- > Ritesh > http://www.riteshn.com > -- Ritesh http://www.riteshn.com --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "reviewboard" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/reviewboard?hl=en -~----------~----~----~----~------~----~------~--~---
