On Oct 12, 2009, at 11:27, David Trowbridge wrote:

> If you run post-review with --debug, it'll spit out a bunch of output
> which should hopefully tell you the real error.

I must be going bling; I didn't see that option in the output of  
"post-review -h" but it's right there at the bottom.  Here's the  
(slightly edited) output which is not very helpful to me but  
hopefully will be to someone on this list:

   $ post-review -d
   >>> svn info
   >>> repository info: Path: svn+ssh://svn.XXX.com/svn/projectX,  
Base path: /trunk, Supports changesets: False
   >>> svn propget reviewboard:url /scratch/Sandbox/projectX/trunk
   >>> svn diff --diff-cmd=diff
   >>> svn info Scripts/install.sh
   >>> svn info Scripts/install.sh
   >>> svn info Scripts/install.sh
   >>> svn info Scripts/install.sh
   >>> Looking for 'rb.XXX.com /rb/' cookie in /home/avc/.post-review- 
cookies.txt
   >>> Loaded valid cookie -- no login required
   >>> Attempting to create review request for None
   >>> HTTP GETting /api/json/repositories/
   >>> HTTP GETting /api/json/repositories/1/info/
   >>> repository info: Path: svn+ssh://svn.XXX.com/svn/projectX,  
Base path: /trunk, Supports changesets: False
   >>> HTTP POSTing to http://rb.XXX.com/rb/api/json/reviewrequests/ 
new/: {'repository_path': 'svn+ssh://svn.XXX.com/svn/projectX'}
   >>> Review request created
   >>> Uploading diff, size: 3187
   >>> HTTP POSTing to http://rb.XXX.com/rb/api/json/reviewrequests/6/ 
diff/new/: {'basedir': '/trunk'}
   Error uploading diff: One or more fields had errors (105)
   >>> {'fields': {'path': ["global name 'ClientError' is not  
defined"]}, 'stat': 'fail', 'err': {'msg': 'One or more fields had  
errors', 'co
   Your review request still exists, but the diff is not attached.

Any ideas what can be causing my post-review error?

Alfred


--~--~---------~--~----~------------~-------~--~----~
Want to help the Review Board project? Donate today at 
http://www.review-board.org/donate/
Happy user? Let us know at http://www.review-board.org/users/
-~----------~----~----~----~------~----~------~--~---
You received this message because you are subscribed to the Google
Groups "reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to