Hi,

The only way to get a ClientError is if pysvn didn't import properly. This
sporadic behavior can happen if you've installed pysvn since starting
Apache. Some threads will have failed to import it (back when it didn't
exist) and some will have succeeded (as they tried after the install). This
is the only thing I can see happening.

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.review-board.org
VMware, Inc. - http://www.vmware.com


On Tue, Oct 13, 2009 at 6:05 AM, Alfred von Campe <alf...@von-campe.com>wrote:

>
> On Oct 12, 2009, at 11:42, Alfred von Campe wrote:
>
> The error I posted yesterday is suddenly gone today; that is, I ran
> post-review again in the same sandbox and the review posted without
> errors.  I have not changed a thing on the server.  Furthermore, when
> I went into the web interface and clicked on "View Diff" for the
> first time, I got a similar stack trace containing "ClientError not
> defined".  However, the second time I clicked on "View Diff" it
> displayed properly.  So it looks like I'm all set to announce this to
> the developers, although it appears to be a little fragile still.  I
> don't like it when things "fix themselves" and I don't understand
> what the underlying problem was (or is) as it will probably come back
> to bite me in the future.  Now if I can just get LDAP or AD
> integration to work...
>
> Alfred
>
>
> > You received this message because you are subscribed to the Google
> Groups "reviewboard" group.
> To post to this group, send email to reviewboard@googlegroups.com
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
> -~----------~----~----~----~------~----~------~--~---
>
>

--~--~---------~--~----~------------~-------~--~----~
Want to help the Review Board project? Donate today at 
http://www.review-board.org/donate/
Happy user? Let us know at http://www.review-board.org/users/
-~----------~----~----~----~------~----~------~--~---
You received this message because you are subscribed to the Google
Groups "reviewboard" group.
To post to this group, send email to reviewboard@googlegroups.com
To unsubscribe from this group, send email to
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/reviewboard?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to