Yes, everything in the ticket shows up for the faulty user except for the 
attachment. The rights for this user and other basic users of the system are 
the same.

chanel


From: Dustin Graves [mailto:dus...@bestpractical.com]
Sent: Monday, March 14, 2016 1:58 PM
To: Chanel Wheeler
Cc: rt-users@lists.bestpractical.com
Subject: Re: [rt-users] Attachments don't reach database for one user


On Mar 10, 2016, at 5:09 PM, Chanel Wheeler 
<chanel.whee...@yavapai.us<mailto:chanel.whee...@yavapai.us>> wrote:

Hi all,
Hi Chanel,


I have one user that has used RT for a while with no problems. Recently, her 
attachments to web tickets ceased coming through. I’ve watched her add  
attachments and they appear to upload successfully but there’s no trace of them 
in the Attachments table. We tried multiple browsers and the same thing 
happened on each. I logged in as her on my computer and still the problem 
happened. Another person logged in to RT on her computer and successfully 
attached items. So it’s something to do with her account. I’ve taken a look at 
her user record in the db and I don’t see anything amiss.

Any ideas on what I might try?

We’re running RT 4.4 and use LDAP for authentication.

I would start by checking the rights for these two users and how they might be 
different.

Can the faulty user see the missing attachment’s associated 
comment/correspondence? If the user cannot, that is why the attachment is 
missing. A user needs the ShowTicketComments right to see attachments added as 
part of a comment.

If this is not the problem, then I can investigate further.


Thanks!
chanel
Thank you,
Dustin
---------
RT 4.4 and RTIR Training Sessions https://bestpractical.com/training
* Washington DC - May 23 & 24, 2016

Reply via email to