Oh dea, this is becoming strange:

The output of configure says that

atlas, openblas, iconv will NOT be installed, but

bzip2-1.0.6-20150304.p0
readline-6.3.008.p0
xz-5.2.2.p0
pcre-8.40.p2
curl-7.62.0.p0

However, I certainly have bzip2, xz, pcre and curl on my system, and I 
guess also readline.

Might there be a bug in configure?

Martin

Am Mittwoch, 15. Januar 2020 13:00:51 UTC+1 schrieb Dima Pasechnik:
>
> On Wed, Jan 15, 2020 at 11:35 AM 'Martin R' via sage-release 
> <sage-r...@googlegroups.com <javascript:>> wrote: 
> > 
> > Am Mittwoch, 15. Januar 2020 12:02:30 UTC+1 schrieb Dima Pasechnik: 
> >> 
> >> On Wed, Jan 15, 2020 at 10:37 AM 'Martin R' via sage-release 
> >> <sage-r...@googlegroups.com> wrote: 
> >> > 
> >> > Thanks again!  It still tries to build R and fails 
> >> > 
> >> > I checked that system R starts, it does (R version 3.4.4) 
> >> Please also make sure that 
> >> 
> >> pkg-config --modversion libR 
> >> 
> >> outputs the version. 
> >> 
> > Yes, it does. 
> > 
> >> 
> >> However there is just no "checking for R" message in your config.log, 
> >> it indicates that there are still remains of R left 
> >> in your installation. 
> >> 
> >> I've opened https://trac.sagemath.org/ticket/29016 
> >> to deal with R being hard to clean away - feel free to try it. 
> >> 
> >> Maybe you also need to run 
> >> 
> >> make r-clean 
> > 
> > 
> > I did that, it says that there is no legacy uninstaller for r, and that 
> there is nothing to do.  I checked for the files in the ticket, but none of 
> them exists. :-( 
> > 
> > The config.log contains the lines 
> > 
> > configure:18950: checking installing any of atlas openblas iconv 
> readline bzip2 xz pcre curl? 
> > configure:18954: result: yes; install r as well 
> > 
> > but I do not know how to find out which of those (atlas openblas iconv 
> readline bzip2 xz pcre curl) is the problem. 
>
> The easiest is to look at the output of ./configure 
> It should contain lines like 
>
> atlas-3.10.2.p3 will not be installed (configure check) 
>
> for each of the packages in that list. 
> So for any of these that are not marked this way, please install the 
> corresponding system package 
> and re-run configure. 
>
>
>
> > 
> > Martin 
> > 
> > -- 
> > You received this message because you are subscribed to the Google 
> Groups "sage-release" group. 
> > To unsubscribe from this group and stop receiving emails from it, send 
> an email to sage-r...@googlegroups.com <javascript:>. 
> > To view this discussion on the web visit 
> https://groups.google.com/d/msgid/sage-release/5d105000-cea2-48a5-8840-aeb405a6cb71%40googlegroups.com.
>  
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"sage-release" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-release+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/sage-release/ca07b5bd-8fe6-4383-ad3a-eab749b3760e%40googlegroups.com.

Reply via email to