On Thu, 3 Sep 2026 15:03:34 GMT, Stefan Karlsson <[email protected]> wrote:
>> src/hotspot/share/cds/heapShared.cpp line 1780:
>>
>>> 1778: // Found a non-null flattened instance of vk. Let's record vk.
>>> 1779: add_value_class(_subgraph_info, vk);
>>> 1780: if (vk->has_inlined_fields()) {
>>
>> Suggestion:
>>
>> if (vk->has_value_fields()) {
>>
>>
>> Or may `has_flat_fields()`?
>
> I'll wait until someone decides what name I should give this.
It seems like "inlined_fields" has some meaning. Can you leave this name here
without it being inconsistent. You could have has_flat_fields() too maybe in a
further change?
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927170439