On Thu, 3 Sep 2026 17:48:30 GMT, Coleen Phillimore <[email protected]> wrote:
>> I'll wait until someone decides what name I should give this. > > It seems like "inlined_fields" has some meaning. Can you leave this name here > without it being inconsistent. You could have has_flat_fields() too maybe in > a further change? This should be `has_inlined_fields` or `has_flattened_fields`, it should not be `has_value_fields`. I followed the chain of setters for this, and it starts at `fieldLayoutBuilder.cpp:885`. It means "this IK has fields laid out in a flat fashion" and not "some of the fields in here are values (as in declared using `value class` or `value record`). Using my suggested names makes this very explicit. ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3927502637
