On Thu, 3 Sep 2026 14:50:24 GMT, Stefan Karlsson <[email protected]> wrote:
>> src/hotspot/share/oops/instanceKlassFlags.hpp line 56: >> >>> 54: flag(has_miranda_methods , 1 << 12) /* True if this >>> class has miranda methods in it's vtable */ \ >>> 55: flag(has_final_method , 1 << 13) /* True if klass >>> has final method */ \ >>> 56: flag(has_inlined_fields , 1 << 14) /* has inlined >>> fields and related embedded section is not empty */ \ >> >> This one should be renamed as well but not not entirely sure if it should be >> "value" or "flattened". value to be consistent with the inline->value >> mapping, flattened to be consistent with flat array naming. >> >> There's a few places that need to be consistently modified still related to >> this decision > > I think `has_value_fields` would be wrong. I think `has_flattened_fields` > would be a good name. Should I change it to that? FYI - we agreed to defer this to another, more targeted RFE ------------- PR Review Comment: https://git.openjdk.org/jdk/pull/32673#discussion_r3929840333
