David E. Ross wrote:
On 7/15/2009 9:59 PM, Ant wrote:
On 7/15/2009 8:38 AM PT, David E. Ross typed:
I noticed lately Gizmodo's Web pages are rendering slowly and hogging
Web browser's CPU and memory badly.

Example:
http://gizmodo.com/5313690/why-you-cant-complain-about-the-price-of-todays-gadgets

Is anyone else having this problem? If so, then what's going on? Thank
you in advance. :)

on FF 1.5.0.9 / XP-SP2 that URL is a crapper... there is a script
running that refuses to be killed, so I closed FF, disabled JavaScript
and re-opened the URL.... it works properly that way for me.
Try disabling JS, see what happens your end!

reg
I've seen Web pages with scripts that, when rendering of the page is
done, a script then downloads additional scripts from a server.
Sometimes it seems that one of the addtional scripts then downloads even
more scripts.  Since I have a dial-up Internet connection, this really
slows things down.

The Web site for the Vanguard Group (mutual funds) is one such site.  I
generally disable JavaScript when viewing pages at that site.  However,
I must enable JavaScript for certain pages to complete transactions or
view account statements.
Did you ever e-mail the Web team over there? If so, then any luck? :(
There is also a problem with viewing parts of the Vanguard site with
SeaMonkey, caused by sniffing for "Firefox" and not "Gecko".  See bug
#417955 at<https://bugzilla.mozilla.org/show_bug.cgi?id=417955>.

I sent E-mail to the Web team, I called them on the phone, and I sent a
postal letter to the CEO.  They claim that the security of their Web
site requires that they test the site for any browser they allow to view
it.  (After all, Vanguard is one of the two largest mutual fund groups
in the U.S.)  They tested the site for Firefox but not for SeaMonkey.
They don't agree that "Gecko is Gecko".  As for the delays caused by the
use of scripts that download more scripts, their response was that I
should use broadband service instead of dial-up.

As for the sniffing for "Firefox", I ran into the same problem with my
bank and my credit union.  I "solved" the problem by creating a special
SeaMonkey profile where I am permanently spoofing Firefox.  (The UA
string ends with "SeaMonkey/1.1.17 NOT Firefox/2.0.0.20".)  To make
these sites work, I also had to set my preferences to accept all cookies
and all popups.  I am careful not to browse any other sites from that
profile.

David, I think it may be a little-more complicated than simply sniffing the Firefox vs SeaMonkey UA.
I don't have a Vanguard account, so that may be a factor for me...
I don't spoof-UA ever, but using the nightly-Linux-64bit build over broadband ~

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2a1pre) Gecko/20090716 Lightning/1.0pre SeaMonkey/2.1a1pre ID:20090716013332

 on your UA/Flash test-URL at

<https://personal.vanguard.com/us/VanguardViewsArticlePublic?ArticleJSP=/freshness/News_and_Views/news_ALL_mmyields_01262009_ALL.jsp&src=NMC&returnLink=/freshness/News_and_Views/news_ALL_mmyields_01262009_ALL.jsp
  
<https://personal.vanguard.com/us/VanguardViewsArticlePublic?ArticleJSP=/freshness/News_and_Views/news_ALL_mmyields_01262009_ALL.jsp&src=NMC&returnLink=/freshness/News_and_Views/news_ALL_mmyields_01262009_ALL.jsp>>

I got this :-

http://www.flickr.com/photos/22198...@n03/3727717220/sizes/l/

Which I think, renders the page OK? What do you think? Barry.

_______________________________________________
support-seamonkey mailing list
support-seamonkey@lists.mozilla.org
https://lists.mozilla.org/listinfo/support-seamonkey

Reply via email to