On Wed, 31 Jan 2007 [EMAIL PROTECTED] wrote:

> Teemu Suikki wrote:
> > With only one card installed, both cards work fine.  ...
> This sounds like an interesting solution... Can you post a link to
> picture showing this particular setup? :-P scnr

Bah. :)

> > It could be some hardware issue, if there is some conflict with two
> > cards.. But I have tried both cards in all PCI slots, no difference there.
> With both cards installed, load the budget and the budget-ci modules and
> then take a look at the dmesg output and see what it says.

Actually both cards use budget-ci, the other card just doesn't have the
physical connector although it has a place for it in the PCB. The cards
look very similar, but newer card has tda10046 and older tda10045
frontend.. Both have saa7146 pci chip.

Here's dmesg output, looks ok to me:

saa7146: register extension 'budget_ci dvb'.
PCI: Found IRQ 11 for device 0000:02:05.0
PCI: Sharing IRQ 11 with 0000:00:0d.0
saa7146: found saa7146 @ mem e0974c00 (revision 1, irq 11) (0x13c2,0x1012).
saa7146 (0): dma buffer size 192512
DVB: registering new adapter (TT-Budget-T-CI PCI).
adapter has MAC addr = 00:d0:5c:04:43:33
input: Budget-CI dvb ir receiver saa7146 (0) as /class/input/input1
budget_ci: CI interface initialised
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
dvb_ca adapter 0: DVB CAM detected and initialised successfully

PCI: Found IRQ 3 for device 0000:02:08.0
saa7146: found saa7146 @ mem e0976800 (revision 1, irq 3) (0x13c2,0x1011).
saa7146 (1): dma buffer size 192512
DVB: registering new adapter (TT-Budget/WinTV-NOVA-T     PCI).
adapter has MAC addr = 00:d0:5c:22:27:8a
input: Budget-CI dvb ir receiver saa7146 (1) as /class/input/input2
DVB: registering frontend 1 (Philips TDA10045H DVB-T)...

> Look into /proc/interrupts and see if both cards may be using the same
> interrupt.


3:    64681          XT-PIC  saa7146 (1)
11:    3565          XT-PIC  saa7146 (0), eth0

Adapter 0 is the one that is working, so it doesn't matter that it shares
interrupt with eth0. Adapter 1 seems to generate a lot of interrupts for
some reason..

> What happens if you append "acpi=off" and/or "noapic" to the kernel? >

No difference..

One thing I noticed is that after a reboot, working card always
has valid firmware, but non-working card's firmware must always be
re-uploaded.. So the firmware gets corrupted somehow?

Also I tried to tune channels with "tzap". It "works" for both cards, but
the other card never reports FE_HAS_LOCK and "ber" is very high. Looks
pretty much the same as if the antenna was unplugged.. (it's not..) :)

Perhaps there is some problem having tda10045 and tda10046 in same system?
After all, both are handled by the same tda1004x module..

Teemu Suikki

vdr mailing list

Reply via email to