Update of patch #3186 (project wesnoth):
Assigned to: None => boucman
_______________________________________________________
Follow-up Comment #11:
Ok, so we've discussing this issues a bit with anonymissimus...
we are interested in the movethrough but
* it's a fragile area of code
* it's an area that really needs refactoring
so our current plan is to commit jamit's refactoring patch and then ask you to
rework your idea on top of it... it's unfortunate we have two patches in the
same area, but it's probably the cleanest way to deal with it.
you probably can start working on top of his current patch, and then solve
what needs to be solved once we commit the final version
brilliand, jamit, is that OK with both of you ?
OK, now on the specifics of this particular new feature...
I think movethrough should be renamed into enter_hex or something similar,
this way the "not fired on first hex but fired on last hex" logic would be
obvious
as for the enter_empty_hex versus enter_occupied hex, I would strongly
recommand not separating the events, do a single "enter_hex" event and have a
way to have some sort of SUF/SLF filters to check if the hex is occupied
I expect the most common case not to care if the hex is occupied, and a
separate syntax would highly complicate WML code.
I'll ask our WML experts to comment on a particular syntax details...
_______________________________________________________
Reply to this item at:
<http://gna.org/patch/?3186>
_______________________________________________
Message posté via/par Gna!
http://gna.org/
_______________________________________________
Wesnoth-bugs mailing list
[email protected]
https://mail.gna.org/listinfo/wesnoth-bugs