Hi Paul,

> 1. Install system to pair of mirrored disks (c0t2d0s0 c0t3d0s0),

> system works fine

I don't remember at this point which disks were which, but I believe it was 0 
and 1 because during the first install there were only 2 drives in the box 
because I had only 2 drives.

> 2. add two more disks (c0t0d0s0 c0t1d0s0), create zpool tank, test and
> determine these disks are fine

Again, probably was on disks 2 and 3 but in principle, correct.

> 3. copy data to save to rpool (c0t2d0s0 c0t3d0s0)

I did this in a few steps that probably don't make sense because I had only 2 
500G drives at the beginning when I did my install. Later I got two 320G and 
realized I should have the root pool on the smaller drives. But in the interim, 
I installed the new pair of 320G and moved a bunch of data onto that pool. 
After the initial installation when update 8 first came out, what happened next 
was something like:

1. I created tank mirror on the 2 320G drives and moved data from another 
system on to the tank. After I verified it was good I rebooted the box and 
checked again and everything was healthy, all pools were imported and mounted 

2. Then I realized I should install on the 320s and use the 500s for storage so 
I copied everything I had just put on the 320s (tank) onto the 500s (root). I 
rebooted again and verified the data on root was good, then I deleted it from 

3. I installed a new install on the 320s (formerly tank)

4. I rebooted and it used my old root on the 500s as root, which surprised me 
but makes sense now because it was created as rpool during the very first 

5. I rebooted in single user mode and tried to import the new install. It 
imported fine.

6. I don't know what happened next but I believe after that I rebooted again to 
see why Solaris didn't choose the new install, the tank pool could not be 
imported and I got the panic shown in the screenshot.

> 3. install OS to c0t0d0s0, c0t1d0s0
> 4. reboot, system still boots from old rpool (c0t2d0s0 c0t3d0s0)

Correct. At some point I read you can change the name of the pool so I imported 
rpool as tank and that much worked. At this point both pools were still good, 
and now the install was correctly called rpool and my tank was called tank.

> 5. change boot device and boot from new OS (c0t0d0s0 c0t1d0s0)

That was the surprising thing. I had already changed my BIOS to boot from the 
new pool, but that didn't stop Solaris from using the old install as the root 
pool, I guess because of the name. I thought originally as long as I specified 
the correct boot device I wouldn't have any problem, but even taking the old 
rpool out of the boot sequence and specifying only the newly installed pool as 
boot devices wasn't enough.

> 6. cannot import old rpool (c0t2d0s0 c0t3d0s0) with your data
> At this point could you still boot from the old rpool (c0t2d0s0 c0t3d0s0) ?

Yes, I could use the newly installed pool to boot from, or import it from shell 
in several versions of Solaris/Sol 11, etc. Of course now I cannot, since I 
have installed so many times over that pool trying to get the other pool 

> <something happens> and
> 7. cannot import old rpool (c0t2d0s0 c0t3d0s0), any attempt causes a
> kernel panic, even when booted from different OS versions

Right. I have tried OpenIndiana 151 and Solaris 11 Express (latest from Oracle) 
several times each as well as 2 new installs of Update 8.

> Have you been using the same hardware for all of this ?

Yes, I have. 

Thanks for the help,


zfs-discuss mailing list

Reply via email to