On May 31, 2007, at 4:04 AM, Chris Withers wrote:
Jim Fulton wrote:
I don't see how this helps one say that they want to depend on a
minimum version of a major version. That is, how does it prevent
foo >=1.0 <1.999
I'm wondering how Gentoo got *that* right.
I wonder if the package should have something in it's setup.py that
says "I won't be compatible with anything expecting version" <2.0 ?
You say that by sayng that you require >=2. (I suspect a typo on your
This would end up as metadata on pypi or in the egg/.tar.gz and
setuptools could do the "hard work" of resolving the dependencies...
Setuptools doesn't try that hard. Someday, buildout will try a lot
harder -- when necessary.
It also removes the burden of specifying maximum revision numbers
on the consuming packages and puts it where it belongs: on the
maintainer of the package who knows if it's going to be backwards
compatible or not..
I don't understand that argument. You still have to state a
requirement. Maybe I don't understand your proposal.
Jim Fulton mailto:[EMAIL PROTECTED] Python
CTO (540) 361-1714
Zope Corporation http://www.zope.com http://www.zope.org
Zope3-dev mailing list