Jim Fulton wrote:


I don't see how this helps one say that they want to depend on a minimum version of a major version. That is, how does it prevent dependencies like:

    foo >=1.0 <1.999

?

I'm wondering how Gentoo got *that* right.

I wonder if the package should have something in it's setup.py that says "I won't be compatible with anything expecting version" <2.0 ?

This would end up as metadata on pypi or in the egg/.tar.gz and setuptools could do the "hard work" of resolving the dependencies...

It also removes the burden of specifying maximum revision numbers on the consuming packages and puts it where it belongs: on the maintainer of the package who knows if it's going to be backwards compatible or not..

cheers,

Chris

--
Simplistix - Content Management, Zope & Python Consulting
           - http://www.simplistix.co.uk

_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to