On Sun 18 Sep 2016 at 18:10:39 -0400, brian wrote:

> My dear old Laserjet 5N finally having died, I bought an HP Laserjet
> P1109w to replace it. I have managed to install it to the extent that
> it's recognised (USB connection, not wireless) but the problem is that
> it apparently needs a *proprietary* plug-in to print properly. 
> I have H-Ps installer, and everything goes OK up to the point at which
> it goes to an unspecified H-P site to download the plug-in. The
> installer then claims that the file it tried to download has an
> invalid checksum and may have been modified, and that's it, the
> program exits. Substantially the same thing happens if I use hp-plugin
> outside of the installer, it just tells me that it can't download the
> file due to an invalid checksum. 
> H-P support are as much use as a chocolate teapot, all they will do is
> to point me back to the site where I can download the installer again.
> I have tried to point out to them that it appears to be a corrupted
> file on their website (if I believe the error message!) but it gets me
> nowhere. 

To be fair to HP they make it crystal clear how Linux printing support
is provided:


You might want to co-operate with the process and report your problem as
a question if it persists.
> Anybody got any ideas before I package the printer up and send it back
> to Amazon to exchange it for another brand? I'm using 64-bit testing,
> should anyone feel that makes a difference.

1. Go to


   and download the latest *.run.

2. 'mkdir plugin' and move your file into it.

3. The file is a shell script containing needed plugins and other files.
   Make it executable with 'chmod 755 *.run' and look at its help with
   './*.run -h'.

4. Check what you are going to install by using './*.run --tar vxf' to
   extract the files from the script.

5. Install with './*.run'. Only this final step needs root privilege.


Reply via email to