On Mon 19 Sep 2016 at 05:56:44 -0400, brian wrote:

> On Mon, 19 Sep 2016 09:34:33 +0100, Brian wrote:
> >
> >1. Go to
> >
> >     https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/
> >
> >   and download the latest *.run.
> >
> >2. 'mkdir plugin' and move your file into it.
> >
> >3. The file is a shell script containing needed plugins and other files.
> >   Make it executable with 'chmod 755 *.run' and look at its help with
> >   './*.run -h'.
> >
> >4. Check what you are going to install by using './*.run --tar vxf' to
> >   extract the files from the script.
> >
> >5. Install with './*.run'. Only this final step needs root privilege.
> Thank you very much, that all worked, given an extra step of removing
> HPLIP and installing the version I downloaded from the URL which you
> gave (the version I had installed was from the Debian repos, that one
> apparently wasn't correctly detected by the plugin software). Why the
> original installer couldn't refer me to that website, I have no idea. 

hp-plugin is setup to go to the openprinting site for the plugin. :)

It has been some time since I used this technique so I was working
partly from memory. Step 5 was poor advice because that script would
expect a GUI with QT to be available. The situation I devised the
method for was one in which there was no X; step 5 should read

5. Make installPlugin.py executable and do './installPlugin.py'.

Another mistake is in step 1. The advice should be to download the
version of *.run corresponding with the hplip version you have.

But it is good it all worked out. You could purge the version of hplip
you now have, install from the Debian repros and install the plugin
again if you wanted.


Reply via email to