Problem: package glycin-loaders-2.2~beta-1.fc45.i686 from fedora requires libheif.so.1, but none of the providers can be installed - package libheif-1.23.3-2.fc45.i686 from updates-testing requires libavcodec.so.62, but none of the providers can be installed - package libheif-1.23.3-2.fc45.i686 from updates-testing requires libavcodec.so.62(LIBAVCODEC_62), but none of the providers can be installed - package libheif-1.23.3-2.fc45.i686 from fedora requires libavcodec.so.62, but none of the providers can be installed - package libheif-1.23.3-2.fc45.i686 from fedora requires libavcodec.so.62(LIBAVCODEC_62), but none of the providers can be installed - package libavcodec-free-8.1.2-12.fc45.i686 from fedora requires libopenh264.so.8, but none of the providers can be installed - package openh264-2.6.0-3.fc45.x86_64 from fedora-cisco-openh264 obsoletes noopenh264 < 1:0 provided by noopenh264-2.6.0-5.fc45.i686 from fedora - problem with installed package - problem with installed package - openh264-2.6.0-3.fc44.x86_64 does not belong to a distupgrade repository - libheif-1.21.2-1.fc44.i686 does not belong to a distupgrade repository - glycin-loaders-2.1.5-1.fc44.i686 does not belong to a distupgrade repository You can try to add to command line: --skip-broken to skip uninstallable packages
This is what i got On Fri, 11 Sept 2026 at 16:46, Miro Hrončok via devel < [email protected]> wrote: > On 11. 09. 26 0:57, Miro Hrončok wrote: > > Problem 16: package rpmlint-2.9.0-3.fc45.noarch from fedora requires > > python3.15dist(file-magic), but none of the providers can be installed > > - package python3-file-magic-5.48-3.fc45.noarch from updates-testing > > conflicts with python3-magic provided by > python3-magic-0.4.27-18.fc45.noarch > > from fedora > > - package python3-file-magic-5.47-3.fc45.noarch from fedora conflicts > with > > python3-magic provided by python3-magic-0.4.27-18.fc45.noarch from fedora > > - package diffoscope-325-2.fc45.x86_64 from fedora requires > > python3.15dist(python-magic), but none of the providers can be installed > > - problem with installed package > > - problem with installed package > > - rpmlint-2.8.0-2.fc43.noarch does not belong to a distupgrade > repository > > - diffoscope-306-1.fc43.x86_64 does not belong to a distupgrade > repository > > > > Conflicting Python magics. Long term problem. > > > > https://bugzilla.redhat.com/show_bug.cgi?id=1899279 > > > > Maybe revert https://src.fedoraproject.org/rpms/diffoscope/c/ > > ef3db93c9f913d2ac899d6d78d4da73809b80cb9?branch=rawhide if we can? > > > > I got an email about this months ago asking if we should patch rpmlint, > but I > > lost track, because it was an email and not a bugzilla. I'd rather not :( > > See https://src.fedoraproject.org/rpms/diffoscope/pull-request/3 > > -- > Miro Hrončok > -- > Phone: +420777974800 <+420%20777%20974%20800> > > -- > _______________________________________________ > devel mailing list -- [email protected] > To unsubscribe send an email to [email protected] > Fedora Code of Conduct: > https://docs.fedoraproject.org/en-US/project/code-of-conduct/ > List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines > List Archives: > https://lists.fedoraproject.org/archives/list/[email protected] > Do not reply to spam, report it: > https://forge.fedoraproject.org/infra/tickets/issues/new >
-- _______________________________________________ devel mailing list -- [email protected] To unsubscribe send an email to [email protected] Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/ List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines List Archives: https://lists.fedoraproject.org/archives/list/[email protected] Do not reply to spam, report it: https://forge.fedoraproject.org/infra/tickets/issues/new
