On Mon, 7 Jun 2004, Robert Krueger wrote:

> checking for pkg-config... /usr/local/bin/pkg-config
> checking for GLIB - version >= 2.2.0...
> *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.3.6)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files

It seems to me that pkg-config returns one version and the linker
finds another version, in this case pkg-config returns 2.2.3 and the
linker finds 2.3.6.  I would try to update the list of files the
linker uses to find libraries to link by doing ldconfig as root.
If that doesn't work then try editing /etc/ld.so.conf, or where
ever that file is if you system uses this this and rearrange the
paths for the libraries to list the version returned by pkg-config

If you don't want to all that above, just set LD_LIBRARY_PATH to
the directory where your 2.2.3 glib is and that should fix this
problem.  Of course, I've read that this method is not a good thing
to do because it does something bad but I don't remember what.

Hope that helps

Gimp-user mailing list

Reply via email to