Thong Nguyen wrote:

On Mon, 7 Jun 2004, Robert Krueger wrote:

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.2.0...
*** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.3.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

It seems to me that pkg-config returns one version and the linker finds another version, in this case pkg-config returns 2.2.3 and the linker finds 2.3.6. I would try to update the list of files the linker uses to find libraries to link by doing ldconfig as root. If that doesn't work then try editing /etc/, or where ever that file is if you system uses this this and rearrange the paths for the libraries to list the version returned by pkg-config first.

If you don't want to all that above, just set LD_LIBRARY_PATH to
the directory where your 2.2.3 glib is and that should fix this
problem.  Of course, I've read that this method is not a good thing
to do because it does something bad but I don't remember what.

Hope that helps

OK, let's see if I miss anybody here.
Thong - did all that...including LD_LIBRARY_PATH
Et All - Wanky?? At any rate, everything was checked at compile time of gimp. I went down the list posted on the site of dependencies, and if I didn't have that version on my 9.0 system, I built it from source. If anything complained that it needed something newer, it was added. Eventually, everything compiled correctly as source. The error I stated in the beginning was the only one left to solve, which I have brought to this forum.
Tim and others - The location of the only existing glib-2.0.pc files on my system are located in /usr/local/lib/pkgconfig, and /opt/gnome/lib/pkgconfig, of which both are listed in PKG_CONFIG_PATH, so this is not the issue, it appears. I cannot locate any other file that ends with .pc and starts with glib.
I cannot locate the particular file or text that seems to be confusing pkgconfig into thinking that 2.3.6 is still on the system. It was installed in the early stages of trying to solve this problem, but has since been removed. Glibc on my system is 2.3.3, which is "stock" for 9.1, and in compliance with gimp 2.01 requirements.
As there is no other glib*.pc file on my system, the information concerning 2.3.6 is obviously coming from somewhere else, and locating this source seems to me to be the most important direction for me to take, if I had a clue as to where to look.
Barring some new direction from you folks, I will start again from scratch, checking currently installed versions, adding what's missing, rechecking to see if they registered, and so on. But until proven otherwise, I firmly believe that locating the source of the information that is returning "2.3.6" to the configure script of gimp is the next step towards solving this problem.
I really appreciate all of your input, truly, you have all tried to help me sort this out.
I'm not giving up yet, but when I do, I'll probably fork out another $80.00 to upgrade to 9.1. As an aside, every Linux system has it's loyal followers, and I am no exception.
I've installed 3-4 versions each of RedHat, Mandrake, and Suse over the last 4 years, and have had the best experience with SuSe, no doubt partly due to the advances of the system in general, but also due to system characteristics that make my life easier for the many tasks I do. At this stage of the Linux evolutionary ladder, the three I've mentioned and Debian as well are all good, solid systems.

Gimp-user mailing list

Reply via email to