Why is package config in /usr/local/bin ? Are you installing the whole
of gnome from source to try and get this to work? This will cause
problems in the future as you won't be able to automatically upgrade.

Did you install glib from source or rpm? Removing the version glib that
everything is using is most likly going to give you a world of pain. But
'make uninstall' from the directory you installed it from as root if
it's source. And "rpm -e <name of package>" if rpm (as root again).

If your installing libs from source you need to set up your computer to
use them. As the error message says. Not sure exactly what would be
needed on Suse. Most likly adding /usr/local/lib to /etc/ld.so.conf. Add
setting PKG_CONFIG_PATH to /usr/local/lib/pkgconfig. Possibly other
things too.

Rember you need all the -dev rpms if you want to compile stuff.

It would be a much much beter idea for you to install the rpm. Ditching
suse for debian would also be a good idea.


On Mon, 2004-06-07 at 21:17, Robert Krueger wrote:
> Robert Krueger wrote:
> > On Mon, Jun 07, 2004 at 02:53:44PM -0400, Robert Krueger wrote:
> >
> >>  
> >>
> >>> Hi,
> >>>  I am having a terrible time getting 2.01 to run in my Suse 9.0 
> >>> system.    I do have 1.2 working ok, but I have read everything I 
> >>> can on this, and spent 3 weeks on and off trying to get it to 
> >>> configure.    I feel especially bad because we downloaded the 2.01 
> >>> Windows version onto my wifes new Dell laptop with the XP system, 
> >>> and it's running peachy, no problems.    The main problem centers 
> >>> around pkg-config.    Here's the error.
> >>>
> >>> "pkg-config --modversion glib-2.0'   returned 2.2.3 but GLIB ( 2.3.6 
> >>> ) was found!"
> >>>
> As an additional note, here is the complete message:
> checking for pkg-config... /usr/local/bin/pkg-config
> checking for GLIB - version >= 2.2.0...
> *** 'pkg-config --modversion glib-2.0' returned 2.2.3, but GLIB (2.3.6)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> Sure would like some help...
> Thanks,
> Robert
> _______________________________________________
> Gimp-user mailing list
> http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Gimp-user mailing list

Reply via email to