Good work debugging, David.

As I said, I don't use Windows, but if this problem occurred under
Linux the first thing I would try is to create a symlink (perhaps in
Windows this is similar to a "shortcut"?) for "maxima.exe", which
points to wxMaxima.exe. Does that work?

If that does not work, the next thing I would try (on Linux) is to
create a script called "maxima.exe" which runs wxMaxima.exe with the
same arguments and pipes it was passed. On Windows perhaps a batch
file called "maxima.exe" could do this? But then again, I think
Windows pays close attention to suffixes in which case batch files
must end in ".bat" so this would not work?

I suppose neither of these would work if you don't have Administrator
privileges though?


On Wed, Sep 4, 2013 at 2:35 PM, David R. José <> wrote:
> Scott, thanks to you I've found the trick.
> Never realized I could find the issue viewing the Messages log :)
> For those out there who are having the same issue: there is no solution.
> LyX tries to find the CAS_names.exe at the pointed dir.
> Since Maxima runs in Windows as wxMaxima.exe through a .bat file, there is
> simply no way to do it.
> I also failed to do the same with Maple.
> But it worked with Mathematica :)
> Mathematica 9 has a Mathematica.exe, which indeed IS the very core.
> So, just point to, (usually, under win7) "C:\Program Files\Wolfram
> Research\Mathematica\9.0\" at "Path prefix" under Tools -> Preferences ->
> Paths. Save it and CAS -> Mathematica should work fine ;)
>> Date: Wed, 4 Sep 2013 12:11:09 -0400
>> Subject: Re: LyX + CAS
>> From:
>> To:
>> CC:
>> On Wed, Sep 4, 2013 at 10:24 AM, David R. José <> wrote:
>> > Hello.
>> > I've been having trouble in pairing LyX and a CAS.
>> > While trying to use Maxima and Maple, I've added the address (eg:
>> > c:\maxima\) where the .exe is to the "Path prefix" under Tools ->
>> > Preferences -> Paths.
>> > Still no results in even solving a simple 2+2 in Math mode. All I get is
>> > a
>> > equal sign with an empty space beside it.
>> > LyX 2.0.6
>> > wxMaxima 12.04.0
>> > Maple 16
>> > Win 7 x64 SP1
>> >
>> > Has someone successfully paired LyX and a CAS in Windows?
>> > Any help on what or where my problem is at?
>> I do not have Windows. But you could try seeing if View > Messages
>> provides some useful output.
>> Scott

Reply via email to