At 11:44 13.08.2003 -0700, you wrote:
John,
could the difference come in with which point you started drawing your wire? Starting at the resistor pin or starting from the other connection first? Just a thought. One would have to see exactly how you wired to or past that pin to understand exactly how you are getting the results that you got.


As well I always work with the auto junction on and have never turned it off. But doesn't the autojunction just aid in making junctions, it doesn't exclude making junctions.

Using ERC is still the only way to check a schematic, especially for missed/misplaced pin connections.

It's also a good idea to set the ERC a bit tighter.
I marked all unconnected pins as a warning, except for the power pin, witch is an error.
On intentionally left open pins, I place a "no erc mark" on it. Keystrokes p-i-n, witch is easy to remember because you'll place them on a pin.


I have found quite a lot of schematic errors this way.

This would have found your unconnected passive pin of the pullup.
Do you have other things connected to the power port witch should be connected to the pull up? If no, this should definitly be marked as an error.


Edi Im Hof


Sincerely,
Brad Velander.

Lead PCB Designer
Norsat International Inc.
Microwave Products
Tel   (604) 292-9089 (direct line)
Fax  (604) 292-9010
email: [EMAIL PROTECTED]
http://www.norsat.com


> -----Original Message----- > From: John Branthoover [mailto:[EMAIL PROTECTED] > Sent: Wednesday, August 13, 2003 11:10 AM > To: Protel EDA Forum > Subject: [PEDA] Unacceptable Bug in Protel 99 SE SP6..! > > > Hello All, > I have a schematic of a board that I just had > fabricated. When I drew the > schematic, I did so with the Auto-Junction feature turned > off. I always > draw schematics like this because of problems that I have had > in the past > with the Auto-Junction feature placing junctions where I > don t want them. > During testing of the new board, my boss brought me the > schematics asking > why I failed to attach one end of a pull-up resistor to the > +5 volt supply. > I had simply forgot to place a junction at the point where the wires > intersected. My mistake. > > In looking at the board, the connection was made. I > ran a netlist. It > showed that the connection was made. How can this be? I added the > junction, created another netlist. The netlist showed that > the connection > was still made, as expected. I then deleted the dot, > created another > netlist. The connection was still there. The only way that > I could remove > the connection was to delete the wires and redraw them. > After that the > schematic started to behave as expected. No junction, no > connection. I > also tried the procedure on other junctions on the same > schematic page. I > could not reproduce the error. > > I have no idea how this error (bug) originally > happened. It has made me > loose all faith in Protel s schematic capture side. Has > anyone else seen > this behavior? How can I deal with this problem without > checking the entire > netlist before I bring it over to the PCB? Argh!!!!! > > Looks like it is time to start looking for a new PCB > design software. > Beware and good luck. > > > John Branthoover : > Electrical Design Engineer : > Acutronic R & D :Phone (412) 968-1051 > 640 Alpha Drive :Fax (412) 963-0816 > Pittsburgh PA 15238 :Email [EMAIL PROTECTED] > USA :WEB http://www.acutronic.com >




++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ + IH electronic + Phone: ++41 52 320 90 00 + + Edi Im Hof + Fax: ++41 52 320 90 04 + + Doernlerstrasse 1, Sulz + URL: http://www.ihe.ch + + CH-8544 Rickenbach-Attikon + E-Mail: [EMAIL PROTECTED] + + Switzerland + + ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/[EMAIL PROTECTED]
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to