Yes, SVM and IOMMU are enabled and show as enabled when booting raw Linux when 
I pass in explicit ivrs_ioapic parameters at boot.

I just tried again passing in iommu=debug and loglvl=all as described at [1], 
and xl dmesg just reports:

(Xen) IVHD Error: Invalid IO-APIC 0
(Xen) AMD-Vi: Error initialization
(Xen) I/O virtualization disabled

No further information as to what's causing the issue seems to be available. I 
checked the xl dmesg also for a boot without explicitly passing in ivrs_ioapic 
and this output looks the same, so perhaps my explicit settings are ignored.

If that's the case, then I already know my BIOS doesn't provide the proper 
mappings which is why I try to do so explicitly. That might explain why 
virtualization appears disabled. If anyone knows this for sure and knows how I 
can specify the IOMMU/SMBus mappings explicitly, I'd appreciate it!

Sandro

[1] 
https://groups.google.com/forum/#!searchin/qubes-users/ivrs_ioapic|sort:date/qubes-users/GESQugF4eIo/wyUZyDubAgAJ


On Monday, 1 October 2018 12:07:02 UTC-4, Jonathan Seefelder  wrote:
> maybe a dump Question, but did you check if its enabled in the BIOS ? ;)
> 
> 
> cheers
> 
> 
> On 10/1/18 11:46 AM, I wrote:
> > My first attempt at installing Qubes brought up a dialog indicating AMD-Vi 
> > and interrupt remapping wasn't available. I know my hardware supports the 
> > necessary virtualization extensions (AMD FX-8120 on a 990FX mobo), so 
> > further investigation suggested that the bios was probably buggy.
> >
> > I updated the bios but still no luck, so I tried a manual procedure as 
> > described at [1]: I ran a recent live linux distro from a USB key and 
> > confirmed that interrupt remapping was disabled by default due to this BIOS 
> > bug. I then figured out the IOMMU and SMBus addresses using the described 
> > procedure and managed to get the live linux to boot with interrupt 
> > remapping and virtualization enabled as reported by dmesg.
> >
> > I tried the same ivrs_ioapic mapping procedure for the Qubes installer, but 
> > it still raises that dialog saying no interrupt remapping, AMD-Vi, etc. 
> > Running dmesg in the Qubes installer console reports only that IOMMUv2 is 
> > not available, which the live linux also reported, but no other errors. The 
> > dmesg output is a little different though, so perhaps I missed something.
> >
> > Any suggestions on what to do next?
> >
> > [1] https://superuser.com/questions/1052023/ioapic0-not-in-ivrs-table
> >
> -- 
> Kind Regards 
> Jonathan Seefelder
> CryptoGS IT-Security Solutions
> Hofmark 43b
> D-84564 Oberbergkirchen
> Phone: +49 8637-7505
> Fax: +49 8637-7506
> Mail: i...@cryptogs.de
> www.cryptogs.de

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/dcf244a6-0f0d-4e14-ad17-93d213e172bc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to