> I updated the bios but still no luck, so I tried a manual procedure as 
> described at [1]: I ran a recent live linux distro from a USB key and 
> confirmed that interrupt remapping was disabled by default due to this BIOS 
> bug. I then figured out the IOMMU and SMBus addresses using the described 
> procedure and managed to get the live linux to boot with interrupt remapping 
> and virtualization enabled as reported by dmesg.
> 
> I tried the same ivrs_ioapic mapping procedure for the Qubes installer, but 
> it still raises that dialog saying no interrupt remapping, AMD-Vi, etc. 
> Running dmesg in the Qubes installer console reports only that IOMMUv2 is not 
> available, which the live linux also reported, but no other errors. The dmesg 
> output is a little different though, so perhaps I missed something.
> 
> Any suggestions on what to do next?
> 
> [1] https://superuser.com/questions/1052023/ioapic0-not-in-ivrs-table

To fix the bug I inserted some parms on the xen command line (grub boot) and 
after I did "sudo grub2-mkconfig -o /boot/grub2/grub.cfg"
But at that time there was a qubes-hcl-report bug not recognizing Remapping:
HVM:       Active
I/O MMU:   Active
HAP/SLAT   Yes
Remapping: no

xl dmesg works fine:
(XEN) AMD-Vi: IOMMU 0 Enabled.
(XEN) I/O virtualisation enabled
(XEN)  – Dom0: mode: Relaxed
(XEN) Interrupt remapping enabled

see: https://ubuntuforums.org/showthread.php?t=2254677

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/f5263830-51d2-4ac7-bbaa-0e2e597d1f46%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to