We're working on a better repository form that will be a lot easier to use,
and automatically determine many of the fields, but in the meantime, I'll
make a note to improve the help text.

Service URL is the path to the root of your GitLab server. Same with the
URL field for the bug tracker. (I know it's inconsistent.)

What version of Paramiko do you have?

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
Beanbag, Inc. - http://www.beanbaginc.com


On Wed, Feb 12, 2014 at 10:30 PM, Greg <g...@kinostudios.com> wrote:

> I'm having this same problem with GitLab. :-(
>
> Running Debian Jessie and PyCrypto 2.6.1.
>
> Help very much appreciated.
>
> Also: it's great that this supposedly supports gitlab, but I have no idea
> what to put into the fields, and the documentation isn't helpful at all.
>
> What goes into "Service URL"? Where is this documented?
>
> What do I put for the bug tracker URL?
>
> Not a single example is given. :(
>
> Thanks,
> Greg
>
>
> On Wednesday, January 15, 2014 4:33:04 AM UTC-6, Christian Hammond wrote:
>
>> Hi Juia,
>>
>> This is likely a PyCrypto-related issue. It's fortunately not
>> GitLab-specific, and can likely be fixed with a dependency upgrade.
>>
>> Can you tell me which OS/Linux distro you installed this on?
>>
>> Also, can you run:
>>
>>     $ python
>>     >>> import Crypto
>>     >>> Crypto.__file__
>>
>> This should give you a path to the version of PyCrypto you have
>> installed. Can you show me that path?
>>
>> You can then try to upgrade, either through a new package from your
>> distro, or by doing:
>>
>>     $ sudo easy_install -U pycrypto
>>
>> Christian
>>
>> --
>> Christian Hammond - chi...@chipx86.com
>>
>> Review Board - http://www.reviewboard.org
>> Beanbag, Inc. - http://www.beanbaginc.com
>>
>>
>> On Wed, Jan 15, 2014 at 2:21 AM, Julia S.S. <hit...@gmail.com> wrote:
>>
>>>  Hi, I just updated review board to 1.7.21 and I'm trying to add a new
>>> repo from gitlab with the new gitlab support, as I have no gitlab account
>>> configured I'm leaving <Link new account selected> and filling user and
>>> pass, I'm also adding redmine.
>>> When I click on save I get *Unknown error when linking the account: PID
>>> check failed. RNG must be re-initialized after fork(). Hint: Try
>>> Random.atfork()*
>>>
>>> What should I do to fix it?
>>>
>>> Thanks,
>>> Julia
>>>
>>> --
>>> Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
>>> ---
>>> Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
>>> ---
>>> Happy user? Let us know at http://www.reviewboard.org/users/
>>> ---
>>> You received this message because you are subscribed to the Google
>>> Groups "reviewboard" group.
>>> To unsubscribe from this group and stop receiving emails from it, send
>>> an email to reviewboard...@googlegroups.com.
>>>
>>> For more options, visit https://groups.google.com/groups/opt_out.
>>>
>>
>>

-- 
Get the Review Board Power Pack at http://www.reviewboard.org/powerpack/
---
Sign up for Review Board hosting at RBCommons: https://rbcommons.com/
---
Happy user? Let us know at http://www.reviewboard.org/users/
--- 
You received this message because you are subscribed to the Google Groups 
"reviewboard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to reviewboard+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to