Re: [blfs-dev] Vala-0.42.0

2018-09-30 Thread Pierre Labastie via blfs-dev
On 9/30/18 6:49 PM, Pierre Labastie via blfs-dev wrote: > On 9/29/18 9:32 PM, Bruce Dubbs via blfs-dev wrote: >> On 09/29/2018 08:52 AM, Pierre Labastie via blfs-dev wrote: >>> On 9/28/18 6:04 PM, Bruce Dubbs via blfs-dev wrote: >> >>>> I have used doxyg

Re: [blfs-dev] Vala-0.42.0

2018-09-30 Thread Pierre Labastie via blfs-dev
On 9/29/18 9:32 PM, Bruce Dubbs via blfs-dev wrote: > On 09/29/2018 08:52 AM, Pierre Labastie via blfs-dev wrote: >> On 9/28/18 6:04 PM, Bruce Dubbs via blfs-dev wrote: > >>> I have used doxygen when I was doing development work and that needed a full >>> graphviz,

Re: [blfs-dev] Vala-0.42.0

2018-09-29 Thread Pierre Labastie via blfs-dev
On 9/28/18 6:04 PM, Bruce Dubbs via blfs-dev wrote: > On 09/28/2018 10:25 AM, spiky via blfs-dev wrote: >> >> >> On 28/09/18 14:53, Douglas R. Reno wrote: >>> >>> >>> On Fri, Sep 28, 2018 at 6:16 AM spiky via blfs-dev >>> >> > wrote: >>> >>>     Just

Re: [blfs-dev] perl modules branch

2018-09-29 Thread Pierre Labastie via blfs-dev
On 9/28/18 5:21 PM, Bruce Dubbs via blfs-dev wrote: > On 09/28/2018 02:11 AM, Pierre Labastie via blfs-dev wrote: >> On 9/28/18 7:51 AM, Ken Moffat via blfs-dev wrote: >>> On Fri, Sep 28, 2018 at 12:17:07AM -0500, Bruce Dubbs via blfs-dev wrote: >>>> On 09/27/2018 11:

Re: [blfs-dev] perl modules branch

2018-09-28 Thread Pierre Labastie via blfs-dev
On 9/28/18 7:51 AM, Ken Moffat via blfs-dev wrote: > On Fri, Sep 28, 2018 at 12:17:07AM -0500, Bruce Dubbs via blfs-dev wrote: >> On 09/27/2018 11:54 PM, Ken Moffat via blfs-dev wrote: >>> I've updated the online rendered versions of the branch, again at >>>

Re: [blfs-dev] perl modules branch

2018-09-29 Thread Pierre Labastie via blfs-dev
On 9/29/18 12:38 PM, Pierre Labastie via blfs-dev wrote: > On 9/28/18 5:21 PM, Bruce Dubbs via blfs-dev wrote: >> How about this: >> >> >> >> And have blfs key off of "perl-instr" to use >> >> perl Makefile.PL && >> make   

Re: [blfs-dev] Vala and graphviz.

2018-09-25 Thread Pierre Labastie via blfs-dev
On 9/25/18 8:38 PM, Bruce Dubbs via blfs-dev wrote: > On 09/25/2018 11:42 AM, Ken Moffat via blfs-dev wrote: >> A quick look at vala-0.42.0 shows that graphviz is only recommended, >> and an explanation for the sed is still present.  But the sed is not >> visible in the rendered book. >> >>

Re: [blfs-dev] Trimming BLFS

2018-09-25 Thread Pierre Labastie via blfs-dev
On 9/24/18 9:36 PM, Bruce Dubbs via blfs-dev wrote: > Over the years, BLFS has grown a lot.  There are over 1000 individual tarballs > listed in the book.  This creates a large maintenance burden. It is a rare > week when we have less than 30 new packages that need to be updated. > > The most

[blfs-dev] Unable to extract git manual pages

2019-01-22 Thread Pierre Labastie via blfs-dev
Maybe this should go to support, but this might also be an issue with tar or git man-pages. Tar version: 1.31 git version: 2.20.1 Running: - sudo tar -xf ../git-manpages-2.20.1.tar.xz \ -C /usr/share/man --no-same-owner --no-overwrite-dir - just returns: - Aborted - the exit

[blfs-dev] Is six really required for libtasn1?

2019-01-22 Thread Pierre Labastie via blfs-dev
Hi, On the libtasn1 page, the dependency on "six" has been added at revision 20311 (August 15th, 2018, by bdubbs)). But I do not see any reference to six (except in the word posix) in the libtasn1 build tree, and I do not any reference to python either. I suspect it is an oversight (rev 20311 is

Re: [blfs-dev] Is six really required for libtasn1?

2019-01-22 Thread Pierre Labastie via blfs-dev
On 22/01/2019 14:57, Ryan Marsaw via blfs-dev wrote: > On Tue, 22 Jan 2019, Pierre Labastie via blfs-dev wrote: > >> Hi, >> >> On the libtasn1 page, the dependency on "six" has been added at revision >> 20311 >> (August 15th, 2018, by bdubbs)). But

Re: [blfs-dev] NetworkManager needs the Python2 module from pygobject3

2019-01-23 Thread Pierre Labastie via blfs-dev
On 23/01/2019 01:00, Douglas R. Reno via blfs-dev wrote: > > On 1/22/19 1:51 PM, Douglas R. Reno via blfs-dev wrote: >> Hi Guys, >> >> >> It seems that NetworkManager needs the 'gi' Python 2 module from >> PyGObject-3.30.4. Checking the file mentioned in the error below shows that >> it's a

Re: [blfs-dev] Is six really required for libtasn1?

2019-01-23 Thread Pierre Labastie via blfs-dev
On 22/01/2019 15:42, Pierre Labastie via blfs-dev wrote: > On 22/01/2019 15:28, Pierre Labastie via blfs-dev wrote: >> On 22/01/2019 14:57, Ryan Marsaw via blfs-dev wrote: >>> On Tue, 22 Jan 2019, Pierre Labastie via blfs-dev wrote: >>> >>>> Hi, >>

Re: [blfs-dev] NetworkManager needs the Python2 module from pygobject3

2019-01-23 Thread Pierre Labastie via blfs-dev
On 23/01/2019 09:43, Pierre Labastie via blfs-dev wrote: > On 23/01/2019 01:00, Douglas R. Reno via blfs-dev wrote: >> >> On 1/22/19 1:51 PM, Douglas R. Reno via blfs-dev wrote: >>> Hi Guys, >>> >>> >>> It seems that NetworkManager needs the 'gi'

Re: [blfs-dev] NetworkManager needs the Python2 module from pygobject3

2019-01-23 Thread Pierre Labastie via blfs-dev
On 23/01/2019 16:37, Bruce Dubbs via blfs-dev wrote: > On 01/23/2019 02:43 AM, Pierre Labastie via blfs-dev wrote: > >> I understand the changes I have made to the python modules can lead to some >> instability and I hope it is not too much an inconvenience. I think it is >

Re: [blfs-dev] NetworkManager needs the Python2 module from pygobject3

2019-01-23 Thread Pierre Labastie via blfs-dev
On 23/01/2019 17:11, Pierre Labastie via blfs-dev wrote: > On 23/01/2019 16:37, Bruce Dubbs via blfs-dev wrote: >> On 01/23/2019 02:43 AM, Pierre Labastie via blfs-dev wrote: >> >>> I understand the changes I have made to the python modules can lead to some >>> ins

Re: [blfs-dev] Meson projects with debug buildtype

2019-01-23 Thread Pierre Labastie via blfs-dev
On 23/01/2019 20:48, Bruce Dubbs via blfs-dev wrote: > On 01/23/2019 01:33 PM, Brendan L via blfs-dev wrote: >> I noticed some of the projects that switched to meson haven't set and >> default buildtype, which means a debug build is produced.  Most of the >> gnome projects that switched set a

Re: [blfs-dev] NetworkManager needs the Python2 module from pygobject3

2019-01-23 Thread Pierre Labastie via blfs-dev
On 23/01/2019 16:15, Pierre Labastie via blfs-dev wrote: > On 23/01/2019 09:43, Pierre Labastie via blfs-dev wrote: >> On 23/01/2019 01:00, Douglas R. Reno via blfs-dev wrote: >>> >>> On 1/22/19 1:51 PM, Douglas R. Reno via blfs-dev wrote: >>>> Hi Guys, >

Re: [blfs-dev] Is six really required for libtasn1?

2019-01-22 Thread Pierre Labastie via blfs-dev
On 22/01/2019 15:28, Pierre Labastie via blfs-dev wrote: > On 22/01/2019 14:57, Ryan Marsaw via blfs-dev wrote: >> On Tue, 22 Jan 2019, Pierre Labastie via blfs-dev wrote: >> >>> Hi, >>> >>> On the libtasn1 page, the dependency on "six" has been

Re: [blfs-dev] Python modules dependencies

2018-12-13 Thread Pierre Labastie via blfs-dev
On 13/12/2018 21:44, Brendan L via blfs-dev wrote: > On Sun, Dec 9, 2018 at 2:15 AM Pierre Labastie via blfs-dev > wrote: >> >> On 08/12/2018 23:30, Ken Moffat via blfs-dev wrote: >>> On Sat, Dec 08, 2018 at 11:11:03PM +0100, Pierre Labastie via blfs-dev >

Re: [blfs-dev] libpwquality-1.4.0

2018-12-23 Thread Pierre Labastie via blfs-dev
On 23/12/2018 15:53, spiky0011 via blfs-dev wrote: > > On 23/12/2018 13:08, spiky0011 wrote: >> Building libpwquality-1.4.0, it fails >> >> "checking python version... ./configure: line 15249: python: command not >> found" >> >> Python3 was rebuilt in blfs. Python2 not installed. >> >> > With

[blfs-dev] LLVM and Python3

2018-12-27 Thread Pierre Labastie via blfs-dev
Hi, ATM, the book stipulates that Python2 is required for LLVM. But I've been able to build and test LLVM-7.0.1 with only Python3 installed on the system: only 11 tests out of more than 33000 fail, and missing python(2) seems to lead to only 2 failures out of 11. I've not tried to build the doc,

Re: [blfs-dev] Module updates

2018-12-11 Thread Pierre Labastie via blfs-dev
On 11/12/2018 19:07, Bruce Dubbs via blfs-dev wrote: > There has been a lot of discussion and work done on modules recently. The > following tickets have been around for a while: > > Perl > > #11315   IO::Socket::SSL-2.060 but tests still problematic. > #11363   Net-DNS-1.19 (Perl Module) >

Re: [blfs-dev] Python modules dependencies

2018-12-16 Thread Pierre Labastie via blfs-dev
On 16/12/2018 16:52, Pierre Labastie via blfs-dev wrote: > On 13/12/2018 23:05, Bruce Dubbs via blfs-dev wrote: >> >> >> I just updated to mesa-18.3.1 earlier today.  A couple of things I found >> after >> reading this thread: >> >> 1.  Pac

Re: [blfs-dev] Python modules dependencies

2018-12-16 Thread Pierre Labastie via blfs-dev
On 13/12/2018 23:05, Bruce Dubbs via blfs-dev wrote: > On 12/13/2018 03:06 PM, Pierre Labastie via blfs-dev wrote: >> On 13/12/2018 21:44, Brendan L via blfs-dev wrote: >>> On Sun, Dec 9, 2018 at 2:15 AM Pierre Labastie via blfs-dev >>> wrote: >>>> >&g

Re: [blfs-dev] Python modules dependencies

2018-12-16 Thread Pierre Labastie via blfs-dev
On 16/12/2018 18:05, Bruce Dubbs via blfs-dev wrote: > On 12/16/2018 10:33 AM, Pierre Labastie via blfs-dev wrote: >> On 16/12/2018 16:52, Pierre Labastie via blfs-dev wrote: >>> On 13/12/2018 23:05, Bruce Dubbs via blfs-dev wrote: >>>> >>>> >&g

Re: [blfs-dev] Python modules dependencies

2018-12-16 Thread Pierre Labastie via blfs-dev
On 16/12/2018 18:57, Pierre Labastie via blfs-dev wrote: > On 16/12/2018 18:05, Bruce Dubbs via blfs-dev wrote: >> On 12/16/2018 10:33 AM, Pierre Labastie via blfs-dev wrote: >>> On 16/12/2018 16:52, Pierre Labastie via blfs-dev wrote: >>>> On 13/12/2018 23:05,

Re: [blfs-dev] vte-0.54.2 error

2018-12-23 Thread Pierre Labastie via blfs-dev
On 23/12/2018 21:29, spiky0011 via blfs-dev wrote: > I get an error building vte-0.54.2, I tried on my old build and it failed, but > I did upgrade alot of packages. > > Now this is a new systemd build today. All deps installed. > > make[2]: Leaving directory '/home/spiky/build/vte-0.54.2/src' >

Re: [blfs-dev] perl module issues

2018-11-28 Thread Pierre Labastie via blfs-dev
On 27/11/2018 20:53, Ken Moffat via blfs-dev wrote: On Tue, Nov 27, 2018 at 10:54:44AM -0600, Bruce Dubbs via blfs-dev wrote: On 11/27/2018 10:07 AM, Pierre Labastie via blfs-dev wrote: Well, Up to now, I believed that we were trying to avoid bundled libraries in book packages

Re: [blfs-dev] perl module issues

2018-11-29 Thread Pierre Labastie via blfs-dev
On 29/11/2018 16:57, Douglas R. Reno via blfs-dev wrote: On 11/26/18 12:28 PM, Alain Toussaint via blfs-dev wrote: Le lundi 26 novembre 2018 à 12:24 -0600, Bruce Dubbs via blfs-dev a écrit : Reference: http://wiki.linuxfromscratch.org/blfs/ticket/11246 (git and shipped perl modules)

[blfs-dev] Python modules dependencies

2018-12-08 Thread Pierre Labastie via blfs-dev
While testing jhalfs dependency algorithm, I discovered a few things about python modules (there may be others): - several modules have instructions for both python2 and python3, but Python2 is not listed as a dependency (or is only listed as optional). Either Python2 should be listed as a

Re: [blfs-dev] Python modules dependencies

2018-12-08 Thread Pierre Labastie via blfs-dev
On 08/12/2018 17:44, Bruce Dubbs via blfs-dev wrote: > On 12/08/2018 06:33 AM, Thomas Trepl via blfs-dev wrote: >> Am Samstag, den 08.12.2018, 09:39 +0100 schrieb Pierre Labastie via >> blfs-dev: >>> While testing jhalfs dependency algorithm, I discovered a few things

Re: [blfs-dev] Quick detail about OpenJDK

2018-11-23 Thread Pierre Labastie via blfs-dev
On 23/11/2018 14:49, Alain Toussaint via blfs-dev wrote: Hello, Since the start of the week, I've been building a gnome desktop based Linux system with all the recommended and optional packages included via the ALFS build tool and for OpenJDK, the build took 894 minutes (yes, nearly 15h) only

[blfs-dev] automated perl module tests as a POC for automated full BLFS tests

2018-11-24 Thread Pierre Labastie via blfs-dev
Hi, As you may have noticed from my other posts, I'd like to set up a tool allowing automated testing of the BLFS book. This morning, I've written a short script, which allowed me to test all the perl modules of the "Perl Modules" page individually. That is: -start from a known state (only perl

Re: [blfs-dev] perl module issues

2018-11-27 Thread Pierre Labastie via blfs-dev
On 26/11/2018 19:28, Alain Toussaint via blfs-dev wrote: Le lundi 26 novembre 2018 à 12:24 -0600, Bruce Dubbs via blfs-dev a écrit : Reference: http://wiki.linuxfromscratch.org/blfs/ticket/11246 (git and shipped perl modules) http://wiki.linuxfromscratch.org/blfs/ticket/11295 (Error-0.17027

Re: [blfs-dev] Planning for BLFS 8.4

2019-01-07 Thread Pierre Labastie via blfs-dev
On 07/01/2019 03:28, Bruce Dubbs via blfs-dev wrote: > [...] > > http://wiki.linuxfromscratch.org/blfs/query?status=assigned=new=reopened=milestone=id=summary=status=owner=component=time=time > Ooops, I had forgotten about the python modules. Will do them within a few days, sorry. Pierre --

Re: [blfs-dev] Poppler 0.73.0 and XPDF Headers

2019-01-12 Thread Pierre Labastie via blfs-dev
On 12/01/2019 20:36, Pierre Labastie via blfs-dev wrote: > On 11/01/2019 21:46, Douglas R. Reno via blfs-dev wrote: >> >> On 1/11/19 10:44 AM, Bruce Dubbs via blfs-dev wrote: >>> On 01/11/2019 07:52 AM, Ryan Marsaw via blfs-dev wrote: >>>> Hello all. >&

Re: [blfs-dev] Poppler 0.73.0 and XPDF Headers

2019-01-12 Thread Pierre Labastie via blfs-dev
On 11/01/2019 21:46, Douglas R. Reno via blfs-dev wrote: > > On 1/11/19 10:44 AM, Bruce Dubbs via blfs-dev wrote: >> On 01/11/2019 07:52 AM, Ryan Marsaw via blfs-dev wrote: >>> Hello all. >>> >>> Poppler 0.73.0 changed the XPDF headers switch (from the NEWS file:) >>> >>> ... >>> build system:

Re: [blfs-dev] LLVM and Python3

2018-12-28 Thread Pierre Labastie via blfs-dev
On 28/12/2018 02:48, Bruce Dubbs via blfs-dev wrote: > On 12/27/2018 02:20 AM, Pierre Labastie via blfs-dev wrote: >> Hi, >> >> ATM, the book stipulates that Python2 is required for LLVM. But I've been >> able >> to build and test LLVM-7.0.1 with only Python3 in

Re: [blfs-dev] Python modules dependencies

2018-12-09 Thread Pierre Labastie via blfs-dev
On 08/12/2018 23:30, Ken Moffat via blfs-dev wrote: > On Sat, Dec 08, 2018 at 11:11:03PM +0100, Pierre Labastie via blfs-dev wrote: >> >> Excluding the archive and the .svn directories from the search, it goes down >> to 70. Still a lot of work though. Do I understand co

Re: [blfs-dev] Python modules dependencies

2018-12-09 Thread Pierre Labastie via blfs-dev
On 09/12/2018 09:14, Pierre Labastie via blfs-dev wrote: > On 08/12/2018 23:30, Ken Moffat via blfs-dev wrote: >> On Sat, Dec 08, 2018 at 11:11:03PM +0100, Pierre Labastie via blfs-dev wrote: >>> >>> Excluding the archive and the .svn directories from the search, it

Re: [blfs-dev] meson, cmake, autotools : proposed addition

2019-04-02 Thread Pierre Labastie via blfs-dev
On 31/03/2019 01:42, Brendan L via blfs-dev wrote: > On Sat, Mar 30, 2019 at 1:27 PM Ken Moffat via blfs-dev > wrote: >> >> After the discussions on meson, and cmake, I've made an attempt to >> add details to the book. It's a bit longer than I had expected >> (heh, I never use ywo words where

Re: [blfs-dev] Meson defaults to debug builds

2019-03-27 Thread Pierre Labastie via blfs-dev
On 26/03/2019 20:35, Ken Moffat via blfs-dev wrote: > I originally posted most of this to lfs-dev, thinking that since > meson was in LFS there must be something there which used it. But > AFAICS everything which uses meson is in BLFS, so moving this to > here, with some updated details. > > I

[blfs-dev] RFC: remove `&&' in our instructions

2019-03-27 Thread Pierre Labastie via blfs-dev
Hi, When making scripts from the book (either by copy/paste or some use of xsltproc), the generated scripts have `&&' at the end of each line. It allows to not execute the following instructions if one instructions fail, but it defeats the use of "set -e". From the bash man page under the set

Re: [blfs-dev] RFC: remove `&&' in our instructions

2019-03-27 Thread Pierre Labastie via blfs-dev
On 27/03/2019 17:04, Bruce Dubbs via blfs-dev wrote: On 3/27/19 9:44 AM, Roger Koehler via blfs-dev wrote: On Wed, Mar 27, 2019, 6:52 AM Pierre Labastie via blfs-dev <mailto:blfs-dev@lists.linuxfromscratch.org>> wrote:     Hi,     When making scripts from the book (either by c

Re: [blfs-dev] libssh2 breaks vlc

2019-03-22 Thread Pierre Labastie via blfs-dev
On 22/03/2019 22:11, Ken Moffat via blfs-dev wrote: > On Fri, Mar 22, 2019 at 08:23:00PM +, Ken Moffat via blfs-dev wrote: >> Building a current system, including this week's security update to >> libssh2, vlc fails to build: >> >> access/sftp.c: In function 'Open': >> access/sftp.c:310:14:

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-24 Thread Pierre Labastie via blfs-dev
On 24/03/2019 19:17, Bruce Dubbs via blfs-dev wrote: > On 3/24/19 12:35 PM, Pierre Labastie via blfs-dev wrote: >> On 24/03/2019 16:53, Bruce Dubbs via blfs-dev wrote: >>> On 3/24/19 9:43 AM, Pierre Labastie via blfs-dev wrote: >>>> On 23/03/2019 22:08, Pier

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-24 Thread Pierre Labastie via blfs-dev
On 24/03/2019 18:35, Pierre Labastie via blfs-dev wrote: > On 24/03/2019 16:53, Bruce Dubbs via blfs-dev wrote: >> On 3/24/19 9:43 AM, Pierre Labastie via blfs-dev wrote: >>> On 23/03/2019 22:08, Pierre Labastie via blfs-dev wrote: >>>> On 23/03/2019 21:22,

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-24 Thread Pierre Labastie via blfs-dev
On 24/03/2019 19:51, Pierre Labastie via blfs-dev wrote: > On 24/03/2019 18:35, Pierre Labastie via blfs-dev wrote: >> On 24/03/2019 16:53, Bruce Dubbs via blfs-dev wrote: >>> On 3/24/19 9:43 AM, Pierre Labastie via blfs-dev wrote: >>>> On 23/03/2019 22:08, Pier

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-24 Thread Pierre Labastie via blfs-dev
On 23/03/2019 22:08, Pierre Labastie via blfs-dev wrote: > On 23/03/2019 21:22, Bruce Dubbs via blfs-dev wrote: >> On 3/23/19 12:13 PM, Pierre Labastie via blfs-dev wrote: >>> >>> Summary: Error in plasma-workspace, appeared wirth cmake-3.14 >> >> I'm su

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-24 Thread Pierre Labastie via blfs-dev
On 24/03/2019 16:53, Bruce Dubbs via blfs-dev wrote: > On 3/24/19 9:43 AM, Pierre Labastie via blfs-dev wrote: >> On 23/03/2019 22:08, Pierre Labastie via blfs-dev wrote: >>> On 23/03/2019 21:22, Bruce Dubbs via blfs-dev wrote: >>>> On 3/23/19 12:13 PM, Pier

Re: [blfs-dev] Cannot build colord manpages

2019-03-23 Thread Pierre Labastie via blfs-dev
On 23/03/2019 10:07, Xi Ruoyao via blfs-dev wrote: > On Sat, 2019-03-23 at 08:10 +0100, Armin K. via blfs-dev wrote: >> On 22.3.2019. 00:04, Douglas R. Reno via blfs-dev wrote: >>> On 3/21/19 5:59 PM, Ken Moffat via blfs-dev wrote: colord reports: Program xsltproc found: YES

Re: [blfs-dev] meson

2019-03-28 Thread Pierre Labastie via blfs-dev
On 28/03/2019 03:59, Bruce Dubbs via blfs-dev wrote: > There are just too many problems with meson-0.50.0.  Therefore I have reverted > to meson-0.49.2 in lfs-svn until it gets fixed. > If this is a conclusion of private discussions, please make them public, or summarize them... If it is not,

Re: [blfs-dev] meson

2019-03-28 Thread Pierre Labastie via blfs-dev
On 28/03/2019 16:25, Douglas R. Reno via blfs-dev wrote: On 3/28/19 2:28 AM, Pierre Labastie via blfs-dev wrote: On 28/03/2019 03:59, Bruce Dubbs via blfs-dev wrote: There are just too many problems with meson-0.50.0.  Therefore I have reverted to meson-0.49.2 in lfs-svn until it gets fixed

Re: [blfs-dev] mesa-19.0.1

2019-04-06 Thread Pierre Labastie via blfs-dev
On 06/04/2019 19:03, Ken Moffat via blfs-dev wrote: > On Sat, Apr 06, 2019 at 10:56:01AM -0500, Douglas R. Reno via blfs-dev wrote: >> >> On 4/6/19 8:29 AM, Roger Koehler via blfs-dev wrote: >>> I believe you meant to say: >>> >>> patch -Np1 -i ../mesa-19.0.1-add_xdemos-1.patch >>> >>> not >>> >>>

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-23 Thread Pierre Labastie via blfs-dev
On 3/23/19 5:36 PM, Pierre Labastie via blfs-dev wrote: When building plasma 5.15, everything goes well until "plasma-workspace". Then I get the following: --- [...] Scanning dependencies of target appmenu [ 7%] Building CXX object appmenu/CMakeFiles/appmenu.dir/appme

Re: [blfs-dev] libssh2 breaks vlc

2019-03-23 Thread Pierre Labastie via blfs-dev
On 3/23/19 6:16 PM, Pierre Labastie via blfs-dev wrote: On 3/23/19 5:56 PM, Ken Moffat via blfs-dev wrote: When I was looking through my log to find out what was wrong, I noticed some dependencies which were either familiar to me because of this week's firefox shenanigans, or were things I

[blfs-dev] build error in plasma 5.15.0

2019-03-23 Thread Pierre Labastie via blfs-dev
When building plasma 5.15, everything goes well until "plasma-workspace". Then I get the following: --- [...] Scanning dependencies of target appmenu [ 7%] Building CXX object appmenu/CMakeFiles/appmenu.dir/appmenu_autogen/mocs_c ompilation.cpp.o [ 7%] Building CXX object

Re: [blfs-dev] libssh2 breaks vlc

2019-03-23 Thread Pierre Labastie via blfs-dev
On 3/23/19 5:56 PM, Ken Moffat via blfs-dev wrote: On Sat, Mar 23, 2019 at 09:17:48AM +0100, Pierre Labastie via blfs-dev wrote: On 23/03/2019 00:40, Ken Moffat via blfs-dev wrote: On Fri, Mar 22, 2019 at 10:54:42PM +0100, Pierre Labastie via blfs-dev wrote: Slightly off topic: libssh2

Re: [blfs-dev] libssh2 breaks vlc

2019-03-23 Thread Pierre Labastie via blfs-dev
On 23/03/2019 00:40, Ken Moffat via blfs-dev wrote: > On Fri, Mar 22, 2019 at 10:54:42PM +0100, Pierre Labastie via blfs-dev wrote: >> >> Slightly off topic: libssh2 is nowhere mentioned as a dep of vlc. Shouldn't >> it >> be added? (together with a description o

Re: [blfs-dev] Cannot build colord manpages

2019-03-23 Thread Pierre Labastie via blfs-dev
On 23/03/2019 08:10, Armin K. via blfs-dev wrote: > On 22.3.2019. 00:04, Douglas R. Reno via blfs-dev wrote: >> >> On 3/21/19 5:59 PM, Ken Moffat via blfs-dev wrote: >>> colord reports: >>> >>> Program xsltproc found: YES (/usr/bin/xsltproc) >>> >>> man/meson.build:6:2: ERROR: Problem encountered:

Re: [blfs-dev] build error in plasma 5.15.0

2019-03-23 Thread Pierre Labastie via blfs-dev
On 23/03/2019 21:22, Bruce Dubbs via blfs-dev wrote: > On 3/23/19 12:13 PM, Pierre Labastie via blfs-dev wrote: >> >> On 3/23/19 5:36 PM, Pierre Labastie via blfs-dev wrote: >>> When building plasma 5.15, everything goes well until "plasma-workspace".

Re: [blfs-dev] firefox and seamonkey issues

2019-02-20 Thread Pierre Labastie via blfs-dev
On 20/02/2019 23:07, Bruce Dubbs via blfs-dev wrote: > On 2/20/19 3:34 PM, Douglas R. Reno via blfs-dev wrote: >> >> On 2/20/19 12:24 AM, Bruce Dubbs via blfs-dev wrote: >>> On 2/19/19 10:40 PM, Douglas R. Reno via blfs-dev wrote: On 2/19/19 10:12 PM, Bruce Dubbs via blfs-dev wrote:

[blfs-dev] Archive Jinja2?

2019-02-21 Thread Pierre Labastie via blfs-dev
Hi, The Python module Jinka2 is in the systemd book, but is only referenced as an optional dependency on the kf5-frameworks page. Can't it be archived? Regards Pierre -- http://lists.linuxfromscratch.org/listinfo/blfs-dev FAQ: http://www.linuxfromscratch.org/blfs/faq.html Unsubscribe: See the

Re: [blfs-dev] pulseaudio / fftw

2019-02-20 Thread Pierre Labastie via blfs-dev
On 20/02/2019 09:32, Ken Moffat via blfs-dev wrote: > On Wed, Feb 20, 2019 at 08:05:46AM +, Ken Moffat via blfs-dev wrote: >> >> A few nits about the Command Explanations: >> >> For --enable-float we mention RawTherapee, and then say >> >> "These versions are not usable by packages in this

[blfs-dev] Asymptote needs a patch for using system GC

2019-02-21 Thread Pierre Labastie via blfs-dev
Hi, With GC-8.0.2, I get: -- if test -n ""; then \   g++ -Wall -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64 -DUSEGC  -pthread -DF FTWPP_SINGLE_THREAD  -I/opt/texlive/2018/include/gc -I/usr/include/gc -I/usr/inc lude/tirpc -std=c++11 -g -O3 -fno-var-tracking -o asy camperror.o

Re: [blfs-dev] cracklib 2.9.7

2019-03-06 Thread Pierre Labastie via blfs-dev
On 06/03/2019 22:29, Pierre Labastie via blfs-dev wrote: > On 06/03/2019 22:14, Roger Koehler via blfs-dev wrote: >> I waited 24 hours but get the same message: >> >> --2019-03-06 14:12:44--  >> https://github.com/cracklib/cracklib/releases/downloadv2

Re: [blfs-dev] cracklib 2.9.7

2019-03-06 Thread Pierre Labastie via blfs-dev
On 06/03/2019 22:14, Roger Koehler via blfs-dev wrote: > I waited 24 hours but get the same message: > > --2019-03-06 14:12:44--  > https://github.com/cracklib/cracklib/releases/downloadv2.9.7/cracklib-2.9.7.tar.bz2 There is a `/' missing: download/v2.9.7. Will fix the book > Resolving

Re: [blfs-dev] BLFS 8.4 Progress Report

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 11:27, Thomas Trepl via blfs-dev wrote: Am Freitag, den 22.02.2019, 10:59 +0100 schrieb Thomas Trepl via blfs- dev: Am Freitag, den 22.02.2019, 10:19 +0100 schrieb Pierre Labastie via blfs-dev: On 22/02/2019 07:11, Bruce Dubbs via blfs-dev wrote: We only have a few tags left

Re: [blfs-dev] BLFS 8.4 Progress Report

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 13:48, Pierre Labastie via blfs-dev wrote: On 22/02/2019 11:27, Thomas Trepl via blfs-dev wrote: Am Freitag, den 22.02.2019, 10:59 +0100 schrieb Thomas Trepl via blfs- dev: Am Freitag, den 22.02.2019, 10:19 +0100 schrieb Pierre Labastie via blfs-dev: On 22/02/2019 07:11, Bruce

Re: [blfs-dev] BLFS 8.4 Progress Report

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 07:11, Bruce Dubbs via blfs-dev wrote: > We only have a few tags left: > > lfs83 tags:  33 > ;fs84 tags: 803 > > Five open tickets. > > If anyone not tagging wants to jump in, please do so.  Doug is doing Gnome > apps and the tickets.  Other packages that need tagging are: > >

Re: [blfs-dev] alsa-firmware

2019-02-25 Thread Pierre Labastie via blfs-dev
On 22/02/2019 21:18, Pierre Labastie via blfs-dev wrote: > On 22/02/2019 20:43, Douglas R. Reno via blfs-dev wrote: >> >> On 2/22/19 1:19 PM, Bruce Dubbs via blfs-dev wrote: >>> On 2/22/19 1:04 PM, Douglas R. Reno via blfs-dev wrote: >>>> >>>> On

Re: [blfs-dev] BLFS 8.4 Progress Report

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 14:15, Pierre Labastie via blfs-dev wrote: On 22/02/2019 13:48, Pierre Labastie via blfs-dev wrote: On 22/02/2019 11:27, Thomas Trepl via blfs-dev wrote: Am Freitag, den 22.02.2019, 10:59 +0100 schrieb Thomas Trepl via blfs- dev: Am Freitag, den 22.02.2019, 10:19 +0100

Re: [blfs-dev] BLFS 8.4 Progress Report

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 16:04, Pierre Labastie via blfs-dev wrote: On 22/02/2019 14:15, Pierre Labastie via blfs-dev wrote: On 22/02/2019 13:48, Pierre Labastie via blfs-dev wrote: On 22/02/2019 11:27, Thomas Trepl via blfs-dev wrote: Am Freitag, den 22.02.2019, 10:59 +0100 schrieb Thomas Trepl via

Re: [blfs-dev] BLFS 8.4 Progress Report

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 20:22, Bruce Dubbs via blfs-dev wrote: > On 2/22/19 11:32 AM, Bruce Dubbs wrote: >> On 2/22/19 9:32 AM, Pierre Labastie via blfs-dev wrote: >>> >>> On 22/02/2019 16:04, Pierre Labastie via blfs-dev wrote: >>>> >>>> On 2

Re: [blfs-dev] alsa-firmware

2019-02-22 Thread Pierre Labastie via blfs-dev
On 22/02/2019 20:43, Douglas R. Reno via blfs-dev wrote: > > On 2/22/19 1:19 PM, Bruce Dubbs via blfs-dev wrote: >> On 2/22/19 1:04 PM, Douglas R. Reno via blfs-dev wrote: >>> >>> On 2/22/19 12:21 PM, Bruce Dubbs via blfs-dev wrote: There has been some problem with ALSA getting their

[blfs-dev] heads-up for users of jhalfs

2019-02-22 Thread Pierre Labastie via blfs-dev
Hi, Postgresql gives an error when built with jhalfs, while it does not, with the exact same instructions when built manually. The reason is that jhalfs calls each build script from a Makefile, so that MAKELEVEL is 1 when entering "make" after the configure phase... Some build systems (at

Re: [blfs-dev] Asymptote needs a patch for using system GC

2019-02-21 Thread Pierre Labastie via blfs-dev
On 2/21/19 9:28 PM, Bruce Dubbs via blfs-dev wrote: On 2/21/19 2:15 PM, Pierre Labastie via blfs-dev wrote: Hi, [...] There is a commit: https://github.com/vectorgraphics/asymptote/commit/38a59370dc5ac720c29e1424614a10f7384b943f This can be done with a sed: sed -i '$a\ #ifdef USEGC

Re: [blfs-dev] A few issues with most recent book

2019-03-16 Thread Pierre Labastie via blfs-dev
On 16/03/2019 10:39, Pierre Labastie via blfs-dev wrote: > Hi, > > For porting lxde to GTK+3, I have decided to rebuild completely lfs/blfs with > most recent versions. I found a few issues (only built lxde deps): > - mesa-19.0.0: running "make -C ../xdemos DEMOS_PREFIX=$XO

Re: [blfs-dev] A few issues with most recent book

2019-03-16 Thread Pierre Labastie via blfs-dev
On 16/03/2019 18:52, Douglas R. Reno via blfs-dev wrote: > > On 3/16/19 12:39 PM, Pierre Labastie via blfs-dev wrote: >> On 16/03/2019 17:40, Douglas R. Reno via blfs-dev wrote: >>> On 3/16/19 8:33 AM, Roger Koehler via blfs-dev wrote: >>>> On Sat, Mar 16, 2019 at

Re: [blfs-dev] New page lua-5.2

2019-03-11 Thread Pierre Labastie via blfs-dev
On 11/03/2019 09:03, Pierre Labastie via blfs-dev wrote: > On 11/03/2019 08:34, Douglas R. Reno wrote: >> >> >> On Mon, Mar 11, 2019, 2:23 AM Pierre Labastie via blfs-dev >> > <mailto:blfs-dev@lists.linuxfromscratch.org>> wrote: >> >>

Re: [blfs-dev] Error building atk-spi2-core with meson-0.50.0

2019-03-13 Thread Pierre Labastie via blfs-dev
On 3/13/19 5:32 PM, Pierre Labastie via blfs-dev wrote: On 3/13/19 5:16 PM, Brendan L via blfs-dev wrote: On Wed, Mar 13, 2019 at 10:52 AM Pierre Labastie via blfs-dev wrote: When running meson, I get: - [...] WARNING: Project targetting '>= 0.40.1' but tried to use feat

[blfs-dev] Error building atk-spi2-core with meson-0.50.0

2019-03-13 Thread Pierre Labastie via blfs-dev
When running meson, I get: - [...] WARNING: Project targetting '>= 0.40.1' but tried to use feature introduced in '0.50.0': install arg in configure_file Configuring atspi-2.pc using configuration atspi/meson.build:60:0: ERROR: Subdir keyword must not be an absolute path.

Re: [blfs-dev] giflib-5.1.7 needs xmlto

2019-03-12 Thread Pierre Labastie via blfs-dev
On 12/03/2019 21:31, Bruce Dubbs via blfs-dev wrote: > On 3/12/19 2:40 PM, John Burrell via blfs-dev wrote: >> I don't have xmlto installed and when I compile giflib-5.1.7 I get: >> >> make -C doc >> make[1]: Entering directory '/usr/src/libraries/giflib/giflib-5.1.7/doc' >> xmlto xhtml-nochunks

[blfs-dev] Is the i686 patch needed for Qtwebengine-5.12.1?

2019-02-08 Thread Pierre Labastie via blfs-dev
Hi, Trying to build qtwebengine-5.12.1 (for x86_64), I applied the patch (done automatically by jhalfs), and the build failed quickly. Looking at the source, it seems to me that the proper macro is now defined if gcc is used... So I wonder whether the patch is still needed. Maybe, Douglas can

Re: [blfs-dev] Is the i686 patch needed for Qtwebengine-5.12.1?

2019-02-08 Thread Pierre Labastie via blfs-dev
On 08/02/2019 17:21, Roger Koehler via blfs-dev wrote: > On Fri, Feb 8, 2019 at 2:22 AM Pierre Labastie via blfs-dev > wrote: >> >> Hi, >> >> Trying to build qtwebengine-5.12.1 (for x86_64), I applied the patch (done >> automatically by jhalfs), a

Re: [blfs-dev] Is the i686 patch needed for Qtwebengine-5.12.1?

2019-02-08 Thread Pierre Labastie via blfs-dev
On 08/02/2019 19:48, Douglas R. Reno via blfs-dev wrote: > > On 2/8/19 3:22 AM, Pierre Labastie via blfs-dev wrote: >> Hi, >> >> Trying to build qtwebengine-5.12.1 (for x86_64), I applied the patch (done >> automatically by jhalfs), and the build failed quic

Re: [blfs-dev] [blfs-book] r21178 - in trunk/BOOK: general/genutils general/graphlib lxde/desktop x/lib

2019-02-17 Thread Pierre Labastie via blfs-dev
On 17/02/2019 17:06, Bruce Dubbs via blfs-dev wrote: > On 2/17/19 7:35 AM, Pierre Labastie via blfs-dev wrote: >> >> >> >> >> >> On 17/02/2019 00:16, bdubbs--- via blfs-book wrote: >>> Author: bdubbs >>> Date: Sat Feb 16 15:16:14 2

Re: [blfs-dev] [blfs-book] r21178 - in trunk/BOOK: general/genutils general/graphlib lxde/desktop x/lib

2019-02-17 Thread Pierre Labastie via blfs-dev
On 17/02/2019 19:56, Bruce Dubbs via blfs-dev wrote: > On 2/17/19 12:23 PM, Pierre Labastie via blfs-dev wrote: >> On 17/02/2019 17:06, Bruce Dubbs via blfs-dev wrote: >>> On 2/17/19 7:35 AM, Pierre Labastie via blfs-dev wrote: >>>> >>>> >>>>

Re: [blfs-dev] [blfs-book] r21178 - in trunk/BOOK: general/genutils general/graphlib lxde/desktop x/lib

2019-02-17 Thread Pierre Labastie via blfs-dev
On 17/02/2019 00:16, bdubbs--- via blfs-book wrote: > Author: bdubbs > Date: Sat Feb 16 15:16:14 2019 > New Revision: 21178 > > Log: > Add harfbuzz as an optional (circular) dependency of cairo. > [...] > Modified: trunk/BOOK/x/lib/cairo.xml >

Re: [blfs-dev] [blfs-book] r21178 - in trunk/BOOK: general/genutils general/graphlib lxde/desktop x/lib

2019-02-17 Thread Pierre Labastie via blfs-dev
On 2/17/19 9:46 PM, Thanos Baloukas via blfs-dev wrote: On 17/2/19 10:03 μ.μ., Bruce Dubbs via blfs-dev wrote: On 2/17/19 1:38 PM, Pierre Labastie via blfs-dev wrote: Not sure I understand: if a dep is in the recommended chain, what does it bring to put it in optional? Specially

Re: [blfs-dev] Markup for i686 sed in Xorg intel driver ?

2019-02-18 Thread Pierre Labastie via blfs-dev
On 2/17/19 10:54 PM, Bruce Dubbs via blfs-dev wrote: On 2/17/19 3:15 PM, Ken Moffat via blfs-dev wrote: The intel xorg driver has a sed for i686. I assume that people who use jhalfs will apply it even on x86_64.  Is that a problem ?    If you are building on i686, apply a sed to

Re: [blfs-dev] ALSA URLs broken

2019-02-18 Thread Pierre Labastie via blfs-dev
On 18/02/2019 12:38, Bruce Dubbs via blfs-dev wrote: On 2/17/19 7:03 PM, Ken Moffat via blfs-dev wrote: On Sun, Feb 17, 2019 at 06:37:26PM -0600, Douglas R. Reno via blfs-dev wrote: Hi guys, I was going to download alsa-lib (the last version I have is 1.1.7), and it seems that they pulled

Re: [blfs-dev] qt-5.12.1, falkon, QtX11Extras missing -> suggesting adjustment to BLFS QT page

2019-02-09 Thread Pierre Labastie via blfs-dev
‌ Sorry if this message is not properly formatted, I have to use my ISP webmail, because the connection through imap does not work... De : "Jean-Marc Pigeon via blfs-dev" A : blfs-dev@lists.linuxfromscratch.org,"Jean-Marc Pigeon" Envoyé: samedi 9 février 2019 17:40 Objet : Re: [blfs-dev]

[blfs-dev] It seems the gwenview and libkexiv2 patches are still needed

2019-02-10 Thread Pierre Labastie via blfs-dev
When updating to 18.12.2 version, the patches for gwenview and libkexiv2 have been removed. But: - diffing libkexiv2-18.12.0 and libkexiv2-18.12.2, there is no difference (I haven't tried diffing gwenview). - diffing extra-cmake-modules-5.53 and 5.55, there is nothing related to Exiv2 - trying to

Re: [blfs-dev] It seems the gwenview and libkexiv2 patches are still needed

2019-02-10 Thread Pierre Labastie via blfs-dev
On 10/02/2019 16:49, Bruce Dubbs via blfs-dev wrote: > On 02/10/2019 06:49 AM, Pierre Labastie via blfs-dev wrote: >> When updating to 18.12.2 version, the patches for gwenview and libkexiv2 have >> been removed. But: >> - diffing libkexiv2-18.12.0 and libkexiv2-18.12.2, ther

Re: [blfs-dev] xterm log out

2019-02-12 Thread Pierre Labastie via blfs-dev
On 12/02/2019 08:47, spiky0011 via blfs-dev wrote: > Having built blfs latest svn, I have noticed that when in X with xterm, when I > exit xterm I return to tty but the user is logged out. > >   Now this is a new thing that has just started happenning which is very > annoying, what is the cause

Re: [blfs-dev] xterm log out

2019-02-12 Thread Pierre Labastie via blfs-dev
ion of twm (see the thread starting at http://lists.linuxfromscratch.org/pipermail/blfs-support/2019-February/080725.html) And please do not top-post. My 2nd answer is coming before your 1st question:) > > On 12/02/2019 08:39, Pierre Labastie via blfs-dev wrote: >> On 12/02/2019 08

[blfs-dev] dependencies of libsndfile

2019-02-19 Thread Pierre Labastie via blfs-dev
Hi, Libsndfile has only optional dependencies. This means it can be built early, without any sound library present. When pulseaudio is later built, the utility paplay, which is useful for testing sound, can only play .wav files, not .ogg, for example. So that libsndfile needs to be rebuilt

Re: [blfs-dev] Is the i686 patch needed for Qtwebengine-5.12.1?

2019-02-08 Thread Pierre Labastie via blfs-dev
On 08/02/2019 21:37, Pierre Labastie via blfs-dev wrote: > On 08/02/2019 19:48, Douglas R. Reno via blfs-dev wrote: >> >> On 2/8/19 3:22 AM, Pierre Labastie via blfs-dev wrote: >>> Hi, >>> >>> Trying to build qtwebengine-5.12.1 (for x86_64), I applied t

  1   2   3   4   >