clone [-m copy] [-s zfs_snapshot] [brand-specific options] source_zone

On 2/9/2012 3:20 PM, "Hung-Sheng Tsao (Lao Tsao 老曹) Ph.D." wrote:

please check
    The following solaris brand-specific subcommand options are
    supported by zoneadm(1M)

clone [-c config_profile.xml | dir]

    -c config_profile.xml | dir

        Provides a profile or a directory of profiles to apply after
        installation from the repository.

        All profiles must have an .xml extension.

On 2/9/2012 3:00 PM, Will Fiveash wrote:
On Thu, Feb 09, 2012 at 02:43:41PM -0500, "Hung-Sheng Tsao (Lao Tsao ??) Ph.D." 
I ASS U ME that you have see this
That is good info, thanks.  Of course now I see another problem.  In
that guide above there is an example of having zoneadm clone use the
sysconfig created profile like so:

Step 3: Create webzone-2 by Cloning webzone-1

Next create webzone-2 using the modified configuration (by using zonecfg), and 
then perform the clone of webzone-1 (by using zoneadm). Remember to add the 
full path to the system config template. Note how quickly the clone is 
completed. (We can see this by prepending the time command to our zonecfg clone 

root@global:~# zonecfg -z webzone-2 -f /zones/webzone-2-profile
root@global:/zones# time zoneadm -z webzone-2 clone -c 
/zones/webzone-2-template.xml webzone-1

However, the only description of -c I find in the S11 zoneadm man page
is for list.  Can someone confirm that -c<sysconfig profile file>  works
for clone?  Also how do I use -c when creating a new zone that is not a

On 2/9/2012 2:33 PM, "Hung-Sheng Tsao (Lao Tsao ??) Ph.D." wrote:
not sure about your sequence of event
in general  after create
one do install with the *xml
then run zlogin
  * *For a shared-IP zone:*
    #*sysconfig create-profile -o /path/sysconf.xml -g 

*Use the created profile during zone install, clone, or attach
#*zoneadm -z my-zone install -c /path/sysconf.xml*
did you run install?

On 2/9/2012 1:59 PM, Will Fiveash wrote:
After I was able to configure and boot a zone I used sysconfig to
configure the new zone.  What I did was first create a system profile
.xml file using sysconfig create-profile -o /tmp/zone-profile.xml I then
used that as a template in my createzone script where I write that to a
temporary file, modifying some values like the node name and IP address
for that particular zone then I copy that into the zone from the global
zone and once the zone (called mit in this example) is booted I run:

# zlogin mit /usr/sbin/sysconfig configure -g system -c /var/tmp/mit.profile.xml

What I see is:
svcadm: No such instance "svc:/system/svc/restarter:default".

Unable to initiate unconfiguration process.

Anyone know what is going on there?

Note that after this I am able to zlogin into the zone and it appears to
be configured appropriately and:

# svcs svc:/system/svc/restarter:default
STATE          STIME    FMRI
online         11:51:16 svc:/system/svc/restarter:default

Hung-Sheng Tsao Ph D.
Founder&   Principal
HopBit GridComputing LLC
cell: 9734950840
Hung-Sheng Tsao Ph D.
Founder&   Principal
HopBit GridComputing LLC
cell: 9734950840

fn:Hung-Sheng Tsao
org:HopBit GridComputing LLC
title:Founder&  Principal
note;quoted-printable:Worked at Sun/oralce for almost 17 years, retired but 
abailable for Consu=
        Solaris, zone, ldom, ZFS=0D=0A=
        Solaris Cluster=0D=0A=
        Solaris Migration=0D=0A=
        GridEngine, Rocksclusters, HPC=0D=0A=
        Exadata, exalogic and SPARC suportcluster=0D=0A=

Hung-Sheng Tsao Ph D.
Founder&  Principal
HopBit GridComputing LLC
cell: 9734950840

Hung-Sheng Tsao Ph D.
Founder&  Principal
HopBit GridComputing LLC
cell: 9734950840

<<attachment: laotsao.vcf>>

zones-discuss mailing list

Reply via email to