Github user nickwallen commented on a diff in the pull request:
    --- Diff: 
    @@ -34,15 +34,15 @@
        * @param rawMessage
        * @return If null is returned, this is treated as an empty list.
    -  List<T> parse(byte[] rawMessage);
    +  List<T> parse(byte[] rawMessage, SensorParserConfig sensorParserConfig);
    --- End diff --
    @merrimanr  Whichever way we go, the interface has to change. I think we 
just need to decide the best way to do it.
    I totally get the logic in adding `parseOptional` in that you don't want to 
break existing code.  But on the other hand, the project is young and we 
control all of the parsers. We can update and change them however we need to. 
    When we just append methods to the interface (like `parseOptional`), we get 
interfaces that are not concise and clear.  To me that is a bigger problem that 
will only get worse with time.  We should bite the bullet now and make the 
interface change to something that is clear and concise.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

Reply via email to