しみずょぅです。

ちょうど最近 4-STABLE → 5-STABLE → 6-STABLE と make でアッ
プグレードしてみました。マシンが古い ThinkPad X20 なんでとて
も時間がかかりました。

宮楠 勝行さん <[EMAIL PROTECTED]> writes:

>  前任者が立ち上げた会社のサーバ(SOHOレベルの規模)では、
> FreeBSD 4.9-RELEASE を使っており、そろそろアップグレードしよ
> うと情報を集めていましたら、最低限5.5にした方が良いかなと思
> いました。
>
>  そこで、取りあえず実験用ノートPC(個人所有)に
> FreeBSD 4.9-RELEASE をセットアップして、会社のサーバと同じ環
> 境作ってアップグレードの実験をして、発生する問題の有無を調べ
> ようと考えました。

/usr/src/UPDATING に「To upgrade in-place from 4.x-stable to
5.x」という箇所があるので、そのとおりにやればできるはずです。

5 から 6 にするときは古いファイルを消すしくみがあるのですが、
4 から 5 は古いファイルが残ってしまうので注意が必要です。(特
に場所や名前が変わったもの)

-- 
清水 洋 (しみずょぅ)

メールによる返信