Just to drop something to a discussion about Access violation errors.
I posted the problem on this forum some 2 weeks ago and received no answer.
I also reported this to Protel - no answer too.

I paste here a part of that post:
--------------------------------------------------------------------------
Issue : Linking a document file which is within another database

When the user adds a link to an external file in a "normal" way - from the
menu File\Link Document or by right-clicking in Design Window (when in Folder
View) the dialog window appears - it seems impossible to point to a file
being inside another database.
But, when the user opens two databases, picks up a file from one ddb, drags
and drops it into another's ddb window, he may move, copy or LINK that file.
In that way a link to a file which is within another ddb is established.

I tried to use such links pointing to documents of several document-types:
Schematic, PCB, Text, Autocad Drawing and also (just curiosity) Schematic
Library, and it worked well for all of them EXCEPT ONE - Schematic document.
Trying to open one I get a message:
Access violation at address ... in module VCL50.BPL
---------------------------------------------------------------------------
I checked it on 3 computers: two running under WinNT4, thirtd - Windows98,
all have Protel99SE + SP6 installed (the other software is obviously
different) - the same results, only links to schematics do no open and
cause access violation errors.

And I had 2 questions:
1. Is it possible to link schematic document which resides within another ddb?
2. Is it safe using such links (DOES ANYBODY HAVE ANY EXPERIENCE documents
    linked that way)?

But a few days after posting this query I tried it again on another computer
and guess what - everything worked very well. What's interesting is the fact
that this computer has exactly the same hardware as one of the other computers
I had checked before. And both are running under WinNT4, both have the same
service packs for NT and Protel. Just the other software is different.

Any guess, any idea, any comments?
Thanks in advance for any feedback.

Wojciech Oborski


************************************************************************
* Tracking #: 061A5F1E5F84CC4687DFD05306EE9E60D84A56C8
*
************************************************************************

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/proteledaforum@techservinc.com
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to