Xa temos un repositorio para construír extensións XPI baseadas en Hunspell.

É dicir, instalar a última instantánea do corrector en Firefox só require
executar as seguintes ordes:

git clone --recursive https://github.com/eitsl/hunspell-xpi.git
cd hunspell-xpi/
python2 utils/build.py -l gl -p drag

E arrastrar o ficheiro «build/gl-drag.xpi» a unha xanela do Firefox. Tamén
se pode substituír «-p drag» por «-p comunidade» para construír o corrector
da comunidade.

Por motivos de eficiencia os scripts non usan puro Python senón que
utilizan ferramentas do sistema como «sort» durante a construción do
complemento, polo que non descarto que a algún non lle funcione ben o guión
«build.py». Por non falar de dependencias como PyICU que a maioría non
teredes instalada e poderían ser necesarias para o guión. En calquera caso,
agradezo os detalles de calquera problema para mellorar a forma en que o
guión informa das dependencias necesarias non atopadas.

O guión está pensado unicamente para probas, non para xerar o XPI final que
poder publicar logo no sitio web de Mozilla. Para isto último xa
traballarei noutro guión que Dani poida usar para ese fin.
_______________________________________________
Proxecto mailing list
Proxecto@trasno.net
http://listas.trasno.net/listinfo/proxecto

Responderlle a