ist not that i disagree with you, I just don’t agree : D
Logic Analyzer sounds weird for me (but I'm also not so used to that).

So we should go on discussing.. and if no consensus is found we meet somewhere, 
two men, nobody else, no guns (and no bears!). Knifes are probably okay (have 
to check the Apache Policy on consensus finding again...) : )


Am 16.09.19, 09:45 schrieb "Christofer Dutz" <christofer.d...@c-ware.de>:

    Hi julian,
    Well  coming back to your explanation:
    I would never use an oszyloscope to analyze such plc signals they have a 
far to low frequency for oszylloscope analysis. Especially an oszylloscope 
requires things to have a frequency and you couldn't detect simple low frequent 
logic level shifts.
    Thinking about how I usually analyze signals in the IoT space, I always use 
my Logic-Analyzer which is much more suited for such tasks.
    So if we would stick to your reasoning, I would prefer "logic analyzer" 
instead of "oszylloscope".
    Am 16.09.19, 17:37 schrieb "Julian Feinauer" <j.feina...@pragmaticminds.de>:
        although I agree with Chris and Kai (better name things functionally) I 
personally prefer something like 'osciloscope' as it transpoets the intent of 
the lib better than 'process' or 'compute'-
        Oscilloscopes are known to help you with analyzing signals, in fact 
Wikipedia states:
        "The waveform can then be analyzed for properties such as amplitude, 
frequency, rise time, time interval, distortion, and others. Modern digital 
instruments may calculate and display these properties directly. Originally, 
calculation of these values required manually measuring the waveform against 
the scales built into the screen of the instrument.[3]"
        So I think this is the name I prefer most, especially because it brings 
the intent as close as possible.
        Am 16.09.19, 02:36 schrieb "Strljic, Matthias Milan" 
            +1 for that. I am not a fan of fancy cool names 😊. So Processing / 
Filter / SignalWatchDog would be better for me.
            Greetings Mathi
            Matthias Strljic, M.Sc.
            Universität Stuttgart
            Institut für Steuerungstechnik der Werkzeugmaschinen und 
Fertigungseinrichtungen (ISW)
            Seidenstraße 36
            70174 Stuttgart
            Tel: +49 711 685-84530
            Fax: +49 711 685-74530
            E-Mail: matthias.strl...@isw.uni-stuttgart.de
            Web: http://www.isw.uni-stuttgart.de
            -----Ursprüngliche Nachricht-----
            Von: Christofer Dutz <christofer.d...@c-ware.de> 
            Gesendet: Sunday, September 15, 2019 7:09 PM
            An: dev@plc4x.apache.org
            Betreff: Re: [DISCUSS] Rename CRUNCH to something different
            Hi all,
            The thing with Oszilloskope and dsp that I see, ist that für me it 
sort off relates to hard- and not Software (but that might just be me).
            I was discussing this with Julian here at apachecon and I quite 
like the idea of calling the current layer "PLC4X connect" and the new one 
"PLC4X process".
            Holen Sie sich Outlook für Android<https://aka.ms/ghei36>
            From: Tim Mitsch <t.mit...@pragmaticindustries.de>
            Sent: Sunday, September 15, 2019 9:43:13 AM
            To: dev@plc4x.apache.org <dev@plc4x.apache.org>
            Subject: Re: [DISCUSS] Rename CRUNCH to something different
            As i'm electrical engineer i like the name oscilloscope.
            But full ack to Kai, name should be clearer.
            Furthermore i like Kai's suggestion PLC4X DSP as it is short and 
clear what Crunch does ... processing and analyzing digitalized data. Maybe we 
could also call it PLC4X MSP for 'Mixed Signal Processing' or any other 
artifical acronym.
            Am 15.09.19, 18:20 schrieb "Kai Wähner" <megachu...@gmail.com>:
                I would vote for something like Niclas proposed. Much clearer 
than having
                yet another product / component name...
                For instance, PLC4X DSP, PLC4X Signal Processor, or something 
what clearly
                describes in one or two words / shortcuts what the component 
                See Kafka and its ecosystem: Kafka Connect, Kafka Streams, 
Confluent Schema
                Registry, Confluent Rest Proxy, Confluent Control Center, etc...
                On Sun, Sep 15, 2019 at 9:05 AM Julian Feinauer <
                j.feina...@pragmaticminds.de> wrote:
                > Hi,
                > I was thinking about naming and came up with ideas like...
                > - trace4j
                > - dsp4j (digital signal processing, that is)
                > - pluse (as we detect pulses and stuff)
                > - oscilloscope <-- I quite like that, it fits quite well as 
we really look
                > into signals
                > What are thoughts on those?
                > J
                > Am 08.09.19, 22:38 schrieb "Niclas Hedhman" 
                >     peanut gallery; I would recommend a descriptive name, in 
format of
                > "PLC4X
                >     Abc", rather than a stand-alone name. Somewhere in the 
future, you may
                > have
                >     a dozen of these and one wouldn't know where to start 
                >     Cheers
                >     Niclas
                >     On Mon, Sep 9, 2019 at 4:51 AM Julian Feinauer <
                > j.feina...@pragmaticminds.de>
                >     wrote:
                >     > Hi all,
                >     >
                >     > I just discussed (off-list) with Justin the next steps 
                >     > They are
                >     >
                >     > * fill out software grant (pm)
                >     > * Start IP clearance vote on incubator list (JF)
                >     > * Gather ICLA from all contributors of CRUNCH
                >     >
                >     > Parallel I’d like to start a discuss on how we should 
call it as
                > PLC4X
                >     > subproject.
                >     >
                >     > Any ideas or suggestions?
                >     >
                >     > Julian
                >     >
                >     --
                >     Niclas Hedhman, Software Developer
                >     http://polygene.apache.org - New Energy for Java

Reply via email to