From: Ryuji SUZUKAWA 
<[&#x30E1;&#x30FC;&#x30EB;&#x30A2;&#x30C9;&#x30EC;&#x30B9;&#x4FDD;&#x8B77;]>
> 私も先日より似たような症状に見舞われています。
> 私の場合、7.0-RELEASE-p1 なのですが、editors/openoffice.org-2
> のみが、portupgrade できません。
> (他の www/firefox,ja-scim-anthy あたりは動いています)
> 
> 試みたのは、
> portupgrade -rf devel/glib20 -m "WITH_COLLATION_FIX=yes"
> portupgrade -rf devel/icu -m "WITH_THREADS=yes" -m
> "WITH_SYSTEM_FREETYPE=yes"
> 
> の両方ですが、双方とも以下の同じ箇所(libvcl680fi.so)で
> エラーが発生してしまいます。
> 
> # portupgrade -m "WITH_TTF_BYTECODE_ENABLED=yes" -m "LOCALIZED_LANG=ja"
> -m "WITH_SYSTEM_FREETYPE=yes" openoffice.org
> 
> ・・・・・・・・・
> (略)
> ・・・・・・・・・
> 
> rm -f ../unxfbsdi.pro/lib/check_libvcl680fi.so
> mv ../unxfbsdi.pro/lib/libvcl680fi.so
> ../unxfbsdi.pro/lib/check_libvcl680fi.so
> /usr/ports/editors/openoffice.org-2/work/OOH680_m12/solenv/bin/checkdll.sh
> -L../unxfbsdi.pro/lib
> -L/usr/ports/editors/openoffice.org-2/work/OOH680_m12/solver/680/unxfbsdi.pro/lib
>  ../unxfbsdi.pro/lib/check_libvcl680fi.so
> Checking DLL ../unxfbsdi.pro/lib/check_libvcl680fi.so ...: ERROR:
> ../unxfbsdi.pro/lib/check_libvcl680fi.so: Undefined symbol
> "_ZNK7icu_3_814LEFontInstance17getDynamicClassIDEv"
> dmake:  Error code 1, while making '../unxfbsdi.pro/lib/libvcl680fi.so'
> ---* tg_merge.mk *---

Glib20 を WITH_COLLATION_FIX=yes でインストールすると、icu がインストールされ
これが openoffice.org の build を阻害するようです。

http://lists.freebsd.org/pipermail/freebsd-openoffice/2008-April/003663.html
のスレッドを読むと、icu をインストールしないようにすることで解決したよう
ですが、icu をインストールしたままでの解決策は示されていないようです。

-=-=-=-=-
木村博美  筑波大学 研究基盤総合センター http://www.tac.tsukuba.ac.jp/~hiromi/
PGP Fingerprint16 = 2A 27 2E 46 9E 75 4E 3D  E3 FD 5A DC 2A AA 3A 2E

メールによる返信