# MLに送れていなかったのでもう一度。二通受け取ってしまった人にはごめん
# なさい。

In "[FreeBSD-users-jp 91575] Re: 6.3R での GTK+ アプリの不具合( openoffice.org-2_7.0R )" 
at Sun, 20 Apr 2008 10:42:12 +0900
 Hiromi Kimura 
<[&#x30E1;&#x30FC;&#x30EB;&#x30A2;&#x30C9;&#x30EC;&#x30B9;&#x4FDD;&#x8B77;]>  
wrote:
> From: Ryuji SUZUKAWA 
> <[&#x30E1;&#x30FC;&#x30EB;&#x30A2;&#x30C9;&#x30EC;&#x30B9;&#x4FDD;&#x8B77;]>
> > 私も先日より似たような症状に見舞われています。
> > 私の場合、7.0-RELEASE-p1 なのですが、editors/openoffice.org-2
> > のみが、portupgrade できません。
> > (他の www/firefox,ja-scim-anthy あたりは動いています)
> > 
> > 試みたのは、
> > portupgrade -rf devel/glib20 -m "WITH_COLLATION_FIX=yes"
> > portupgrade -rf devel/icu -m "WITH_THREADS=yes" -m
> > "WITH_SYSTEM_FREETYPE=yes"

"WITH_SYSTEM_FREETYPE=yes"しなければbuildできます。(できました)

WITH_SYSTEM_FREETYPE=yesすると、-I/usr/local/includeがCFLAGSの最初に追
加されてしまい、icuのヘッダがそこにあるので、先に読みにいってしまうため
です。
  コンパイル時 : /usr/local/includeにインストールされたicuのヘッダを使う。
  リンク時     : OOoにbundleされたicuのlibraryをリンクする。
ようになってしまうため、リンクでこけます。

OOo bundleのicuは3.6で、しかも改造されています(ABIが変わってる)。

# とsend-prしようと思っていて忘れていました。

http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/121787

メールによる返信