Hi again,

I managed to start X:

Xvfb :1.0 -screen 0 10x10x16

So, the display is 1.

Now, I start the Gimp server:

gimp --display 1 --no-interface --batch \('extension-perl-server 0 0 0'\)

and I get this error:

Invalid option "--display"

I tried different "--display" options: ":1", ":1.0", "1.0". The result was the same.

I mention that the 1.3 version of Gimp started with  "--display :1.0".

I took the display option out of the startup command and the gimp server started. But, when I was running a script I got the same error as when I started the Gimp server without the X:

1117560504: accepted tcp connection from
Gtk-WARNING **: cannot open display: at /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/Gimp.pm line 264.
1117560504: closing connection 11 (1 requests in 0 seconds)


Sven Neumann wrote:


Andrei Simion <[EMAIL PROTECTED]> writes:

When I start the Gimp server with this command:

gimp --no-interface --batch '(extension-perl-server 0 0 0)' &

I got these messages:

GIMP is not properly installed for the current user.
User installation was skipped because the '--no-interface' flag was used.
To perform user installation, run the GIMP without the
--no-interface' flag.

GIMP: Could not open '/home/gimp/.gimp-2.2/pluginrc' for writing: No
such file or directory

GIMP: Unable to open a test swap file. To avoid data loss please check
the location and permissions of the swap directory defined in your
Preferences (currently "${gimp_dir}").

You have obviously not done the user installation for gimp yet. You
need to run gimp once with a user interface so that it creates the
user ~/.gimp-2.2 folder.

But could you please stop sending me private email and use the
mailing-list instead? Thank you.


Gimp-developer mailing list

Reply via email to