Yeahhh I keep meaning to deal with that...

I wanted to do more testing on it with existing setups so nothing broke. I
think it's safe, but let's try for 1.6 :)

Christian

-- 
Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com


On Sat, Sep 25, 2010 at 9:06 PM, David Trowbridge <trowb...@gmail.com>wrote:

> There's always http://reviews.reviewboard.org/r/686/ , which is almost
> 2 years old :)
>
> -David
>
>
>
> On Sat, Sep 25, 2010 at 8:56 PM, Christian Hammond <chip...@chipx86.com>
> wrote:
> > Thanks Daryl,
> >
> > I'm glad it's not a release-stopping bug, but we should do some
> validation
> > to make sure the path entered is absolute.
> >
> > Christian
> >
> > --
> > Christian Hammond - chip...@chipx86.com
> > Review Board - http://www.reviewboard.org
> > VMware, Inc. - http://www.vmware.com
> >
> >
> > On Sat, Sep 25, 2010 at 9:51 AM, Daryl <darylnebr...@gmail.com> wrote:
> >>
> >> Hi,
> >>
> >> I've upgraded to 1.5 RC2 also without issue.  I then decided to setup
> >> pylucene, which I had not done before.  This is on RHEL 5.1 with
> >> python 2.4.  The release notes mentioned compatibility with pylucene
> >> 3.x.  My first attempt was with the latest version 3.0.2-1.  I was
> >> able to build and install, enable search in RB, and create the search
> >> database.  When trying to search within RB I got the "taking a nap"
> >> page.  Adding "Debug = True" showed a long Traceback in apache error
> >> log.  Same result with pylucene 2.9.0-1.  Seeing other messages here
> >> about 2.9 being a pre-3.0, I tried 2.4.1-2.  That worked.
> >>
> >> Nevermind - I just found the problem.  Putting details here in case
> >> someone else does the same thing.  So I switched back to pylucene
> >> 3.0.2-1 to get the error log since I didn't save it.  And it worked.
> >> Turns out the problem was the search directory path I was putting in
> >> the admin settings.  When using "data/lucene_search" I got the "taking
> >> a nap" and a long Traceback in the apache error log.  Changing the
> >> admin settings to the full path to the search directory location fixes
> >> it.
> >>
> >> I went back to pylucene 2.4.1-2 to see what happens with the relative
> >> path of "data/lucene_search".  It doesn't show "taking a nap", rather
> >> a javaError saying it can't create "/data/lucene_search".  That's what
> >> led me to putting in the absolute path.
> >>
> >> Daryl
> >>
> >> On Sep 24, 4:19 pm, Christian Hammond <chip...@chipx86.com> wrote:
> >> > Hi Stephen,
> >> >
> >> > I suspect that 1829 is due to an installation or packaging problem
> with
> >> > Djblets. I can't reproduce this on our install, which was installed
> >> > using
> >> > easy_install. The log.html template is there, and has been for a
> while.
> >> >
> >> > 1828 is a definite bug, which I'll fix for the release.
> >> >
> >> > 1827 again looks to be an installation/configuration problem. E-mails
> >> > are
> >> > working fine on our install. I don't believe it's a Django 1.1 vs 1.2
> >> > incompatibility, as our nightly test suite checks for e-mail signaling
> >> > on
> >> > both versions. However, I'll look into this further for the release.
> Do
> >> > you
> >> > know if it worked in RC1? I don't think anything with the signaling
> has
> >> > changed in a long time.
> >> >
> >> > Christian
> >> >
> >> > --
> >> > Christian Hammond - chip...@chipx86.com
> >> > Review Board -http://www.reviewboard.org
> >> > VMware, Inc. -http://www.vmware.com
> >> >
> >> > On Fri, Sep 24, 2010 at 8:16 AM, Stephen Gallagher
> >> > <karrde...@gmail.com>wrote:
> >> >
> >> >
> >> >
> >> >
> >> >
> >> >
> >> >
> >> > > Great work getting 1.5 RC 2 out. I upgraded the FedoraHosted
> >> > > deployment today, but I've stumbled across three new bugs. (I
> strongly
> >> > > suspect that two of them were present in RC1 as well, but I didn't
> >> > > notice them then)
> >> >
> >> > > 1829 - Viewing the server log from the admin interface fails
> >> > > 1828 - 500 Error trying to "review" an image-only review request
> >> > > 1827 - Sending notification emails fails
> >> >
> >> > > Additionally, we noticed something that seems peculiar. When
> >> > > ReviewBoard (or maybe it's Django) makes postgresql requests, it
> >> > > starts a new connection for each request and terminates it at the
> end.
> >> > > I'm not certain if this is ReviewBoard or Django (or
> python-psycopg2)
> >> > > doing this, but the added overhead of those connection setups is
> >> > > nothing to sneeze at.
> >> >
> >> > > On Sep 20, 2:57 am, Christian Hammond <chip...@chipx86.com> wrote:
> >> > > > Hi everyone,
> >> >
> >> > > > Review Board 1.5 RC 2 is out the door.
> >> >
> >> > > > Details on the release, as well as further prodding about the
> >> > > > release
> >> > > party,
> >> > > > are up at:
> >> >
> >> > >
> >> > > > >
> http://www.reviewboard.org/news/2010/09/19/review-board-15-rc-2-relea...
> >> >
> >> > > > On an unrelated note, some of you have asked how you can help with
> >> > > > our
> >> > > > expenses without going through PayPal. One person has suggested a
> >> > > > service
> >> > > > called Flattr, which specializes in micropayments. I'm looking
> into
> >> > > > this
> >> > > as
> >> > > > an alternative, but if you've used it, I'd love to hear from you.
> >> >
> >> > > > Thanks!
> >> >
> >> > > > Christian
> >> >
> >> > > > --
> >> > > > Christian Hammond - chip...@chipx86.com
> >> > > > Review Board -http://www.reviewboard.org
> >> > > > VMware, Inc. -http://www.vmware.com
> >> >
> >> > > --
> >> > > Want to help the Review Board project? Donate today at
> >> > >http://www.reviewboard.org/donate/
> >> > > Happy user? Let us know athttp://www.reviewboard.org/users/
> >> > > -~----------~----~----~----~------~----~------~--~---
> >> > > To unsubscribe from this group, send email to
> >> > >
> >> > > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> <reviewboard%2bunsubscr...@googlegroups.com<reviewboard%252bunsubscr...@googlegroups.com>
> >
> >> > > For more options, visit this group at
> >> > >http://groups.google.com/group/reviewboard?hl=en
> >>
> >> --
> >> Want to help the Review Board project? Donate today at
> >> http://www.reviewboard.org/donate/
> >> Happy user? Let us know at http://www.reviewboard.org/users/
> >> -~----------~----~----~----~------~----~------~--~---
> >> To unsubscribe from this group, send email to
> >> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> >> For more options, visit this group at
> >> http://groups.google.com/group/reviewboard?hl=en
> >
> > --
> > Want to help the Review Board project? Donate today at
> > http://www.reviewboard.org/donate/
> > Happy user? Let us know at http://www.reviewboard.org/users/
> > -~----------~----~----~----~------~----~------~--~---
> > To unsubscribe from this group, send email to
> > reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> > For more options, visit this group at
> > http://groups.google.com/group/reviewboard?hl=en
>
> --
> Want to help the Review Board project? Donate today at
> http://www.reviewboard.org/donate/
> Happy user? Let us know at http://www.reviewboard.org/users/
> -~----------~----~----~----~------~----~------~--~---
> To unsubscribe from this group, send email to
> reviewboard+unsubscr...@googlegroups.com<reviewboard%2bunsubscr...@googlegroups.com>
> For more options, visit this group at
> http://groups.google.com/group/reviewboard?hl=en
>

-- 
Want to help the Review Board project? Donate today at 
http://www.reviewboard.org/donate/
Happy user? Let us know at http://www.reviewboard.org/users/
-~----------~----~----~----~------~----~------~--~---
To unsubscribe from this group, send email to 
reviewboard+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/reviewboard?hl=en

Reply via email to