On Sun, Sep 26, 2010 at 7:23 PM, Daryl <darylnebr...@gmail.com> wrote:

> Hey guys,
> Now I'm trying to use screenshots (for the first time).  First it
> wouldn't take them, but I didn't have PIL installed.  Some
> observations -
> 1. Created a (None - Graphics Only) review.  Attached a JPG
> screenshot.  I was able to click the picture and add a comment.  But
> when I clicked the Review button I got "A Server Error Occurred" with
> - 'NoneType' object has no attribute 'get_scmtool'.  Note that this
> was before publishing for the first time.  Although I just tried again
> after publishing it and I got the same error.

This was just reported and we fixed it last night. It should either be fixed
in last night's or tonight's nightly, and will definitely be in the release.

2. Opened an existing diff review and added a JPG using Add Screenshot
> button.  The picture was added and I was able to add comments to it.
> I then clicked "Discard Draft".  The banner went away but the picture
> remained.  When trying to remove the picture (red X), the draft banner
> came back.  Clicking "Discard Draft" again went back to having the
> picture there.  Shouldn't the picture have gone away when discarding
> the draft?

This is due to how the screenshots are stored. It's not ideal and we need to
improve it, but it was this way in 1.0. It'll continue to be that way in 1.5
for now.

 3.  I added some PNG files that are very small.  On the main Review
> Request page, the box is the same size as the JPG (square box w/
> thumbnail image and caption below it).  When hovering over it with the
> mouse, I got only the normal mouse pointer in most of the box.  I had
> to hover directly over the image part (top center of thumbnail box) to
> get the mouse icon to become a hand, allowing me to click it and open
> it.  Perhaps intentional?  Just an observation.

We could definitely improve that. Can you file a bug?

4.  Clicked on the thumbnail of an existing screenshot on the main
> Reviews page.  The picture comment page opened.  I clicked Add
> Screenshot to add another picture.  After browsing and selecting
> Upload, "Loading..." displayed at the top and the cursor spun.. and
> never stopped.  If I went back in the browser and refreshed the new
> picture is there.  The Add Screenshot worked fine on the main Review
> Request page.

We should fix that too. Probably just not including a JavaScript file we
need. Can you file a bug on that as well?

These will most likely make it into a 1.5.x, since they're not really



Christian Hammond - chip...@chipx86.com
Review Board - http://www.reviewboard.org
VMware, Inc. - http://www.vmware.com

Want to help the Review Board project? Donate today at 
Happy user? Let us know at http://www.reviewboard.org/users/
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to