Re: [rt-users] Date/Time issue

2008-04-15 Thread Martin Wheldon
Sounds to me as if the system time is incorrect. Is NTP configured and working OK. Martin On 4/13/08, IT GUY [EMAIL PROTECTED] wrote: hello everyone, Could anyone suggest me how to configure Date/Time for RTWhatever TIME is seen in the httpd error_log below, is not the actual local

Re: [rt-users] RT as a intranet portal? Or other suggestions?

2008-04-16 Thread Martin Wheldon
I personaly use pmwiki and have been very happy with it. Martin On 4/16/08, Nelson Pereira [EMAIL PROTECTED] wrote: Hi all, Is there an extension that will make RT look like an intranet portal? To be able to put in articles, upload docs, and such? Or do you guys have any

Re: [rt-users] Ticket creation fails

2012-12-19 Thread Martin Wheldon
Hi Matthias, I have experienced the same issue in the past and would recommend that you don't use fetchmail, but invoke the mail gate directly from your MTA as described in the following link. http://requesttracker.wikia.com/wiki/ManualEmailConfig Regards Martin On 2012-12-19 14:21,

Re: [rt-users] Reply to requestors not sending emails

2012-12-20 Thread Martin Wheldon
Hi, I'm not 100% sure about your question, but if you are asking if you can update a ticket without sending a reply to the requestor? Then all you need to do is select the Comment action and leave the update type set to Comments (Not sent to requestors). If I have miss understood your

Re: [rt-users] Placing 2 CF in RT ticket subject

2013-01-02 Thread Martin Wheldon
Hi, How about something like: my $subject = sprintf(%s %s, $self-TicketObj-FirstCustomFieldValue('Custom Field 1'), $self-TicketObj-FirstCustomFieldValue('Custom Field 2'); Best Regards Martin Wheldon On 2012-12-29 08:48, Nums wrote: I am trying to create a script which will pull 2

Re: [rt-users] Custom fields and non privileged users

2013-01-02 Thread Martin Wheldon
Hi, I suspect you may need to give write access to the custom fields for the non priviliged user, as I've never needed to I'm not sure. For the priviliged user you could write a scrip that checked if a transaction is a create and status is not new then reset status to new. Best Regards

Re: [rt-users] https redirects to http

2013-01-07 Thread Martin Wheldon
Hi, You will need to have the webserver rewrite requests for http to https. Best Regards Martin Wheldon On 2013-01-07 07:06, CB wrote: RT 4.0.8 We have set up RT to be accessible over https: RT_SiteConfig.pm Set($WebPort, 443); However when a ticket is resolved or updated, after

Re: [rt-users] Problem with using ssl over nginx reverse-proxy when submitting ticket updates

2013-01-15 Thread Martin Wheldon
Hi Andy, A very simular issue to this was discussed on the list last week. Have a search for https redirects to http. Best Regards Martin On 2013-01-15 11:24, Andy D'Arcy Jewell wrote: Hi all, I'm trying to run RT 3.8 over ssl via an nginx reverse-proxy, and almost everything works,

Re: [rt-users] Dealing with forwarded tickets from one queue to another

2013-01-16 Thread Martin Wheldon
Hi Sean, Looks like you are looking to create a workflow in RT. Have a look at the following wiki page. http://requesttracker.wikia.com/wiki/WorkFlow You will need to close the old email and autocreate a new ticket in the relevant queue. Hope this helps Martin Wheldon On 2013-01-15 17

Re: [rt-users] rt-mailgate and web based authentication

2013-01-16 Thread Martin Wheldon
Hi Tom, Sounds like you may missing a Location section from your apache config. Something like... Location /REST/1.0/NoAuth Order Allow,Deny Allow from 127.0.0.1 /Location Best Regards Martin Wheldon On 2013-01-16 16:38, Thomas Misilo wrote: Hi, I am switched from using LDAP

Re: [rt-users] problems with RT::Authen::ExternalAuth

2013-01-23 Thread Martin Wheldon
Hi, I beleive what Kevin had in mind was that you specify the user account that you configured to carry out searches in the ldap external auth config using the -D option to ldap search i.e % ldapsearch -D cn= -W -h ldap..net -b dc=x,dc=net -s sub objectclass=* If you are still

Re: [rt-users] problems with RT::Authen::ExternalAuth

2013-01-23 Thread Martin Wheldon
Hi, Is cn=ymarinov specified as the user to bind as in the External Auth configuration? Best Regards Martin On 2013-01-23 10:59, ymarinov wrote: our ldap accepts connections without using username or password however executing the following command, again lists the users in ldap

Re: [rt-users] problems with RT::Authen::ExternalAuth

2013-01-23 Thread Martin Wheldon
Hi, In that case then your config should have the following set: 'user' = '', 'pass' = '', And looking at your comments the attr_match_list should look something like: attr_match_list' = ['cn,mail'], Rather than: attr_match_list' = ['uid,mail'], Best Regards Martin On 2013-01-23 11:24,

Re: [rt-users] problems with RT::Authen::ExternalAuth

2013-01-23 Thread Martin Wheldon
Hi, Sorry but my last post was incorrect regarding the attr_match_list here is an extract from my working config. 'attr_match_list' = ['Name', 'EmailAddress' ], 'attr_map' = { 'Name' = 'mail',

Re: [rt-users] problems with RT::Authen::ExternalAuth

2013-01-23 Thread Martin Wheldon
Hi, Just a couple of things don't know if you just haven't posted information as its sensitive. 1. Do you have a userPassword set for your ldap user In addition I don't know if it is required or not, but try adding 'RealName' = 'cn', to your attr_map config. Regards Martin On 2013-01-23

Re: [rt-users] problems with RT::Authen::ExternalAuth

2013-01-23 Thread Martin Wheldon
Hi, If you can post information from both the ldap logs and the RT logs that would help. Best Regards Martin On 2013-01-23 13:42, ymarinov wrote: adding RealName to the attr maps didn't help, i still get No User in the error logs. i'll try to investigate further which field should i map

Re: [rt-users] REST API and WebExternal Auth

2013-02-06 Thread Martin Wheldon
Hi Tom, It is definatly possible to use the REST API with external auth as we use it to run scheduled reports. I've not used curl, all our scripts are in python. I would guess that you are not providing the credentials correctly, the following wiki page may help.

[rt-users] Adding rights to default lifecycle

2013-02-09 Thread Martin Wheldon
with the relevant code, however having read the documentation for v4.0.x this is also possible by defining a new lifecycle. If defining a new lifecycle is the best solution, where would I find the information on how the default lifecycle is defined? Many thanks in advance. Best Regards -- Martin

Re: [rt-users] Adding rights to default lifecycle

2013-02-10 Thread Martin Wheldon
Hi, To answer part of my own question I see the default life cycle can be found in RT_Config.pm. Looks like my best option may be to copy the default over to RT_SiteConfig.pm and modify it there? Sorry about some of the noise. Best Regards Martin On 2013-02-09 20:05, Martin Wheldon wrote

Re: [rt-users] Date customfields and searching

2013-02-11 Thread Martin Wheldon
Hi Joop, This functionality currently doesn't work in your version of RT. I know that there is a patch to fix this but has yet to make it into a release to the best of my knowlege. This is functionality I would like to see, however I have worked around it by writing a script that runs from

Re: [rt-users] Adding rights to default lifecycle

2013-02-11 Thread Martin Wheldon
Hi, Many thanks everyone for your responces, I'll give it a go at the weekend. Best Regards Martin On 2013-02-10 19:28, Thomas Sibley wrote: On 02/10/2013 12:10 AM, Martin Wheldon wrote: Hi, To answer part of my own question I see the default life cycle can be found in RT_Config.pm

Re: [rt-users] spawn-fcgi crashing, is uWSGI an option?

2015-06-15 Thread Martin Wheldon
Hi Aaron, I'm running Nginx with uWsgi in my lab environment and it seems to we working well. Here are the snippets of config I'm using. server { root /usr/share/nginx/www; index index.html index.htm; # Make site accessible from http://localhost/ server_name

Re: [rt-users] Weird behavior behind a proxy

2015-07-14 Thread Martin Wheldon
Hi Bret, That should be Redirect permanent / https://proxy.damascusgrp.com/ Best Regards Martin On 2015-07-14 18:40, Martin Wheldon wrote: Hi Bret, It looks like you are missing a redirect/rewrite configuration on the proxy to map requests from http to https. Something like

Re: [rt-users] Weird behavior behind a proxy

2015-07-14 Thread Martin Wheldon
Hi Bret, It looks like you are missing a redirect/rewrite configuration on the proxy to map requests from http to https. Something like the following would be required on the proxy, obviously if the client can access the real RT server this won't work VirtualHost *:80 ServerName

Re: [rt-users] which Perl version should one use with RT 4.4 on CentOS 6

2016-03-16 Thread Martin Wheldon
Hi, I would recommend installing a version of perl just for RT that is seperate from the system perl. I tend to use the version that the perl project considers stable. Currently v5.22.1 I believe. Check out perlbrew for a nice easy clean way of installing a independant perl version. Best

[rt-users] Fwd: which Perl version should one use with RT 4.4 on CentOS 6

2016-03-19 Thread Martin Wheldon
Hi Jerome, The following google search came back with a tutorial which pretty much describes the type of perl brew install that I carry out for RT. perlbrew "request tracker" howto Best Regards Martin Original Message Subject: [rt-users] which Perl version should one use

Re: [rt-users] RT worklfow with approvers, chosen from list

2016-03-21 Thread Martin Wheldon
Hi Janus, Details of how to do this can be found in the documentation: https://docs.bestpractical.com/rt/4.4.0/RT/Ticket.html#LoadCustomFieldByIdentifier You need to load the custom field before accessing its value, something like the following should work. Not tested I'm afraid. my $cf =

Re: [rt-users] Custom scrip condition

2016-03-22 Thread Martin Wheldon
Hi Raymond, The following plugin may be what you are looking for. https://metacpan.org/pod/RT::Extension::AdminConditionsAndActions Best Regards Martin On 2016-03-22 13:49, raymond.teunis...@kpn.com wrote: Hi, I'm trying to find a way to add a custom scrip-condition, for when a ticket is

Re: [rt-users] Centos 7 - Forbidden, You don't have, permission to access /rt4 on this server

2016-04-26 Thread Martin Wheldon
Hi, The thing that stands out is that you seem to be trying to access the site using https on port 8000, however you haven't configured apache for https. Could you also post the ./configure that you used with rt to the list too please. Best Regards Martin On 2016-04-26 09:40, Yanni

Re: [rt-users] problems attaching files

2016-04-27 Thread Martin Wheldon
Hi, This is probably a issue with your web server configuration, you don't mention what you are using. Researching the following may help: Apache2 - LimitRequestBody Nginx - client_max_body_size Best Regards Martin On 2016-04-27 00:25, Liam Forbes wrote: We are using RT 4.4.0 and appear

Re: [rt-users] Centos 7 - Forbidden, You don't have, permission to, access /rt4 on this server

2016-04-27 Thread Martin Wheldon
Hi, I don't mean to be rude, but read AND FOLLOW the README file included in the RT tarball. Best Regards Martin On 2016-04-27 10:15, Yanni wrote: Hi I did not use ./configure, I just did "make install" as described in the documentation. To make things simpler for me, I have now deleted

Re: [rt-users] Centos 7 - Forbidden, You don't have, permission to access /rt4 on this server

2016-04-25 Thread Martin Wheldon
Hi, It also says: " # Set DocumentRoot as appropriate for the other content you want to serve DocumentRoot /var/www" So to a path where your other content that you want apache to serve, I'm afraid only you can answer that question. Best Regards Martin On 2016-04-25 10:18, Yanni

Re: [rt-users] Centos 7 - Forbidden, You don't have, permission to, access /rt4 on this server

2016-05-04 Thread Martin Wheldon
Hi Yanni, Have you managed to get RT working? Best Regards Martin On 2016-04-27 10:33, Martin Wheldon wrote: Hi, I don't mean to be rude, but read AND FOLLOW the README file included in the RT tarball. Best Regards Martin On 2016-04-27 10:15, Yanni wrote: Hi I did not use ./configure

Re: [rt-users] Centos 7 - Forbidden, You don't have permission to access /rt4 on this server

2016-04-21 Thread Martin Wheldon
Hi, You need to firstly pick your deployment method from the web deployment documentation. I go for the nginx option, but I would suggest you use Apache and mod_fastcgi as lots of people on this list seem to be using RT in that manner. The following will install mod_fastcgi on your CentOS

Re: [rt-users] writing extensions for an old version

2017-02-13 Thread Martin Wheldon
Hi, If you look in the Makefile.PL you will find somethink like this requires_rt '4.0.0'; modify as required. Can I suggest that you upgrade as v3.8 reached end of life in 2014. Best Regards Martin On 2017-02-13 17:02, Vinicius Fagundes wrote: Hi, I'm starting to learn RT development.

Re: [rt-users] Best web server for RT4?

2016-09-02 Thread Martin Wheldon
Hi, If you decide to retry a source install. You might want to look at using perlbrew to install a stand alone perl and configuring cpanminus as described in the rt_perl documentation below will make life much easier. https://docs.bestpractical.com/rt/4.4.1/rt_perl.html I'm a big fan of

Re: [rt-users] Database again stuck at SQLite?

2016-09-14 Thread Martin Wheldon
Hi Alex, I've not run a Debian packaged install for a long time, but looking at the package dependancies I think the following may help. How did you do the package install? If you ran the following it should just work. $ sudo apt-get install request-tracker4 rt4-db-mysql If however you

Re: [rt-users] Database again stuck at SQLite?

2016-09-14 Thread Martin Wheldon
Hi Alex, No problem, glad you have it working. Martin On 2016-09-14 14:44, Alex Hall wrote: Thank you! It's working now, and I see what you mean about the rt4-db-* package installations. RT is finally running on our new server! On Wed, Sep 14, 2016 at 10:02 AM, Martin Wheldon <martin.w

Re: [rt-users] Mapping users of a particular LDAP database to a specific queue

2016-11-09 Thread Martin Wheldon
Hi Maneesh, We have a requirement of mapping users of a particular LDAP database to a specific queue. Just to clarify your first statement, do you require a particular set of user accounts stored in LDAP to only have access to one or more queues? If that is the case then this can be

Re: [rt-users] Mapping users of a particular user database under OpenAM(SSO) to a specific queue

2016-11-09 Thread Martin Wheldon
Hi Maneesh, I'm not familiar with OpenAM, but you should be able to get this to do the authentication by either SSO cookie or getting the web server to populate the REMOTE_USER variable. The following may help... https://docs.bestpractical.com/rt/4.4.1/RT/Authen/ExternalAuth/DBI/Cookie.html

Re: [rt-users] Mapping users of a particular user database under OpenAM(SSO) to a specific queue

2016-11-09 Thread Martin Wheldon
Hi, A quick google suggests that you may be looking for OpenAM web policy agents "Profile Attribute Fetch Mode" Good luck.. Best Regards Martin On 2016-11-09 16:04, Martin Wheldon wrote: Hi Maneesh, I'm not familiar with OpenAM, but you should be able to get

Re: [rt-users] Searching ticket content?

2016-11-07 Thread Martin Wheldon
Hi Alex, I'm guessing you are looking for full text indexing, further details can be found here: https://docs.bestpractical.com/rt/4.4.1/full_text_indexing.html Best Regards Martin On 2016-11-07 13:57, Alex Hall wrote: Hello list, Some users at work are wondering if they can search ticket

Re: [rt-users] Scrip condition not for Reminders

2016-11-11 Thread Martin Wheldon
Hi Tobi, A ticket object has a type method that will return a string when called: https://docs.bestpractical.com/rt/4.4.1/RT/Ticket.html#Type1 Something like the following should help: if ( $self->TicketObj->Type ne 'reminder ) { $self->TicketObj->SetStatus('open'); } Best Regards

Re: [rt-users] view articles/assets in main menu

2016-11-10 Thread Martin Wheldon
Hi Tomas, You need to assign the ShowAssetsMenu right to the relevant user/group. Obvoiusly I'm making the assumption that the user is a Priviledged user. Best Regards Martin On 2016-11-10 09:46, Stehlík Tomáš wrote: Hello, another simple question - how can I show articles / assets for

Re: [rt-users] RT 4.4.1 on Debian with RT::Authen::ExternalAuth?

2016-10-19 Thread Martin Wheldon
n Wed, 2016-10-19 at 14:09 +, Martin Wheldon wrote: Hi Malcolm, You are missing the LDAP import configuration, which is separate from  the External auth config. The following will help:    https://docs.bestpractical.com/rt/4.4.1/RT/LDAPImport.html Best Regards Martin On 2016-10-19 13:37, Malcol

Re: [rt-users] RT 4.4.1 on Debian with RT::Authen::ExternalAuth?

2016-10-19 Thread Martin Wheldon
Hi Malcolm, You are missing the LDAP import configuration, which is separate from the External auth config. The following will help: https://docs.bestpractical.com/rt/4.4.1/RT/LDAPImport.html Best Regards Martin On 2016-10-19 13:37, Malcolm Galland wrote: I've set up RT, and am testing

[rt-users] Search for Assets with active tickets

2016-10-18 Thread Martin Wheldon
help/pointers in the right direction would be much appreciated. Thanks in advance -- Martin Wheldon Greenhills IT Ltd. Telephone: 01904 238 454 Website: www.greenhills-it.co.uk Greenhills IT Ltd. is a limited company registered in England and Wales. Company Registration No: 06387214 Registered

Re: [rt-users] RT 4.4.1 on Debian with RT::Authen::ExternalAuth?

2016-10-19 Thread Martin Wheldon
Hi Malcolm, Are you able to get any results from the LDAP server when you try the same search using ldapsearch from the commandline on the Debian box? Something like: ldapsearch -D LDAP_ACCOUNT -x -w -ZZ -H ldap://ggdc1.domain.int/ -b ou=Production,dc=domain,dc=int

Re: [rt-users] Enabling full text index, getting "MySQL server has gone away"

2016-11-14 Thread Martin Wheldon
Hi Alex, I think the mysql configuration be "max_allowed_packet" rather than "max_packet_size". Best Regards Martin On 2016-11-14 13:54, Alex Hall wrote: I should also say that I've already tried setting my MySQL max_packet_size. 500M didn't do it, so I upped it to 5000M, restarting the

Re: [rt-users] FTS enabled in SiteConfig, but not being enabled

2016-11-15 Thread Martin Wheldon
Hi Alex, Sounds like you may need to clear the mason cache. Best Regards Martin On 2016-11-15 15:34, Alex Hall wrote: Hi all, I've enabled FTS on the database, and restarted the server just to be sure. I have this line in one of my config files: Set( %FullTextSearch, Enable => 1,

Re: [rt-users] Scrip condition not for Reminders

2016-11-11 Thread Martin Wheldon
Your very welcome :) Martin On 2016-11-11 16:38, Tobias W. wrote: Hi Martin, thank you for your tip. Now works fine! Thank you and Best Regards, Tobi - VON: Martin Wheldon <martin.whel...@greenhills-it.co.uk> GESENDET: Freitag, 11. November 2016 12:31 AN: To

Re: [rt-users] Unable to create tickets after MySQL update?

2016-11-14 Thread Martin Wheldon
Hi Alex, You could try disabling the PriorityAsString as a test, as least it will narrow down your problem space. Best Regards Martin On 2016-11-14 21:15, Alex Hall wrote: Update: still not working. I tried setting sql-mode to an empty string, like it would have been in 5.5, and to all the

Re: [rt-users] Overriding files in lib/RT?

2016-11-01 Thread Martin Wheldon
Hi Alex, You may need to add the following to the end of your Email_Local.pm file: 1; Best Regards Martin On 2016-10-31 20:17, Alex Hall wrote: Hi all, Thanks for the responses, it's partially working. When I use my Email_Local.pm, the server refuses to start, yet I have no errors.

Re: [rt-users] Search Assets by People gives "No assets matching search criteria found."

2016-11-03 Thread Martin Wheldon
Hi Tom, Just tried this on my RT 4.4.1 install and it works fine, this is probably this bug? From the release notes of RT 4.4.1 * Fix searching for people associated with Assets (I#31546) Best Regards Martin On 2016-11-03 00:01, Tom Robinson wrote: Sorry, forgot to mentions I'm using RT4

Re: [rt-users] "Hidden" tickets suddenly appear

2016-10-26 Thread Martin Wheldon
Hi Jeff, If you examine the ticket history of the problem ticket it should tell you what happened for it to be set back to the "new" status. Is it being reopened by a reply to a email from the pervious ticket corespondance perhaps?? Best Regards Martin On 2016-10-25 16:00, Jeff Blaine

Re: [rt-users] Finding queue priority in script?

2016-11-02 Thread Martin Wheldon
Hi Alex, The file below contains a example of how to set the default values for a queue. share/html/Admin/Queues/DefaultValues.html Looks like the SetDefaultValue method for Queues isn't documented or a least I haven't found where, which seems odd as I've always found RT to be very well

Re: [rt-users] Finding queue priority in script?

2016-11-02 Thread Martin Wheldon
Sorry that should be DefaultValue, not SetDefaultValue. Should read the question more closely :( Martin On 2016-11-02 09:10, Martin Wheldon wrote: Hi Alex, The file below contains a example of how to set the default values for a queue. share/html/Admin/Queues/DefaultValues.html Looks like

Re: [rt-users] Connecting RT to IBM iSeries and/or MSSQL databases?

2016-10-10 Thread Martin Wheldon
Hi Alex, Sounds like you may be looking for the external custom fields functionality, please see the link below for details: https://docs.bestpractical.com/rt/4.4.1/extending/external_custom_fields.html Best Regards Martin On 2016-10-10 15:15, Alex Hall wrote: Hello list, Another day,

Re: [rt-users] RT 4.4.1 login form and 2FA

2016-10-17 Thread Martin Wheldon
Hi, I'm not familiar with the DUO 2FA solution, but I think you may be looking for callbacks in the login page. The following should help: https://rt-wiki.bestpractical.com/wiki/CustomizingWithCallbacks I beleive the ones you are interested in are those below: /Elements/Login

Re: [rt-users] RT 4.4.1 login form and 2FA

2016-10-17 Thread Martin Wheldon
Hi, Using the Duo ldap proxy looks like a viable option too. https://duo.com/docs/ldap Best Regards Martin On 2016-10-17 13:37, Matt Zagrabelny wrote: On Mon, Oct 17, 2016 at 7:45 AM, Kem Hartley wrote: RT Community, I'm trying to setup 2FA, specifically Duo, with

Re: [rt-users] RT 4.4.1 LDAP Authentication issue.

2016-12-09 Thread Martin Wheldon
/tls/mycorp_CERTIFICATE_CHAIN.crt" }, 'net_ldap_args'=> [version => 3, debug => 8 ], 'attr_match_list' => [ 'Name' , 'EmailAddress', ], # Import the following properties of the user from LDAP upon # login 'attr_map' => { 'Name' => 'mail', 'EmailAddress' =>

Re: [rt-users] RT 4.4.1 LDAP Authentication issue.

2016-12-09 Thread Martin Wheldon
Hi, You could either use another unique attribute i.e mail or add another uid to each RT user prefixed by a letter. dn: uid=123456,dc=my,dc=domain uid: 123456 uid: x123456 Best Regards Martin On 2016-12-09 12:49, Joop wrote: On 9-12-2016 13:38, Claude EDUMA wrote: Hi Joop, Thank you

Re: [rt-users] RT 4.4.1 LDAP Authentication issue.

2016-12-09 Thread Martin Wheldon
Hi, Sorry, please disregard my last response, the user account has been found. Could you post the RT logs please? Best Regards Martin On 2016-12-09 13:44, Martin Wheldon wrote: Hi, Looks like a ldap acl issue, is your ldap search user able to access the users mail attribute? Best Regards

Re: [rt-users] assets: bulk updating a custom field value fails

2017-01-11 Thread Martin Wheldon
Hi Michael, Line 183 of /opt/rt4/share/html/Asset/Search/Bulk.html seems to be the problem, if you comment it out the bulk update works. # push @tmp_res, ProcessObjectCustomFieldUpdates( Object => $asset, ARGSRef => \%ARGS ); I'm suspect that line 183 shouldn't be here as the

Re: [rt-users] Issue With ExternalAuth

2016-12-05 Thread Martin Wheldon
Hi Claude, Your english is much better than my french :) I've cc'd the RT users list as they may have additional suggestions. The short answer is no I don't believe your problem is caused by TLS bugs. You seem to be mixing up the new RT 4.4 LDAP configuration syntax with the older

Re: [rt-users] Issue With ExternalAuth

2016-12-06 Thread Martin Wheldon
ponse: (0, No User) (/opt/rt4/share/html/Elements/DoAuth:58) [3605] [Tue Dec 6 07:58:02 2016] [error]: FAILED LOGIN for 20006583 from 10.1.179.71 (/opt/rt4/sbin/../lib/RT/Interface/Web.pm:826) Thank you one more time. Regards. 2016-12-05 23:35 GMT+01:00 Martin Wheldon <mart

Re: [rt-users] Issue With ExternalAuth

2016-12-06 Thread Martin Wheldon
/opt/rt4/sbin/../lib/RT/Authen/ExternalAuth.pm:327) 2016-12-06 11:12 GMT+01:00 Martin Wheldon <martin.whel...@greenhills-it.co.uk>: Hi Claude, Seems you already have a user in the RT database with the same email address, but different user name. [3605] [Tue Dec 6 07:58:02 2016] [error]:

Re: [rt-users] Issue With ExternalAuth

2016-12-06 Thread Martin Wheldon
tml/Elements/DoAuth:58) [4109] [Tue Dec 6 10:22:50 2016] [error]: FAILED LOGIN for 20005528 from 10.1.52.222 (/opt/rt4/sbin/../lib/RT/Interface/Web.pm:826) ----- Regards 2016-12-06 12:04 GMT+01:00 Martin Wheldon <martin.whel...@greenhills-it.co.uk>: Hi Claude,

Re: [rt-users] How unprivileged users could see all tickets in their queue?

2017-01-05 Thread Martin Wheldon
On Jan 5, 2017, at 06:08, Martin Wheldon <martin.whel...@greenhills-it.co.uk> wrote: Hi Félix, I've just tried to configure this on a RT 4.4.1 install using a custom role and it seems to work fine. Here is the process I carried out. I've got 2 unprivileged users with a single queue

Re: [rt-users] How unprivileged users could see all tickets in their queue?

2017-01-04 Thread Martin Wheldon
Hi, You can modify the Ticket Owner dropdowns by using the UpdateObjectList callback in Elements/SelectOwner, you would remove all unwanted users from the list of objects passed to this callback. You possibly need to use the Modify callback in Elements/ShowUser too, I suspect there are

Re: [rt-users] Where to put crontool scripts?

2017-01-04 Thread Martin Wheldon
Hi Alex, We drop ours in /opt/rt4/local/bin. Martin On 2017-01-04 16:13, Alex Hall wrote: Hi all, I'm just wondering if there's a conventional place to store scripts that run crontool jobs? I've got one to notify people of old tickets, but I'll be making more, now that this one is working.

Re: [rt-users] How unprivileged users could see all tickets in their queue?

2017-01-05 Thread Martin Wheldon
Hi Félix, I've just tried to configure this on a RT 4.4.1 install using a custom role and it seems to work fine. Here is the process I carried out. I've got 2 unprivileged users with a single queue, each being the owner of multiple tickets in that queue. I created a new custom role, then

Re: [rt-users] How unprivileged users could see all tickets in their queue?

2017-01-04 Thread Martin Wheldon
Hi, If you are looking at modifying menus then the following will help. https://docs.bestpractical.com/rt/4.4.1/writing_extensions.html#Adding-and-Modifying-Menus Best Regards Martin On 2017-01-04 17:31, Alex Hall wrote: I'm honestly not sure which file you want, but my guess is

Re: [rt-users] no alert for invalid mail addresses

2017-01-06 Thread Martin Wheldon
Hi, You might want to checkout the perl module Regex::Common::Email::Address Best Regards Martin On 2017-01-06 13:16, Petr Hanousek wrote: Hello Jeffrey, thank you, I'll try to implement it here. Wonder if someone has done it before or if there is any plugin for this? Or (the best way) if

Re: [rt-users] ***SPAM*** Re: How unprivileged users could see all tickets in their queue

2017-01-06 Thread Martin Wheldon
in my case, the users is a customer, and they never owner of the tickets. So, the users see only the tickets they are requestor. I would like to provide to a set of user, the ablillity to see all ticket requestor in the queue.. Felix. Le 05/01/2017 à 16:00, Martin Wheldon a écrit : Hi, No n

Re: [rt-users] Where are saved searches stored in the db

2017-01-10 Thread Martin Wheldon
Hi Woody, What are you trying to achieve? IMO you are better off using the RT API rather than hacking the database. Best Regards Martin On 2017-01-10 11:53, Woody - Wild Thing Safaris wrote: Hi all, I was expecting to find a database table called "SavedSearches" but there isn't one. I

Re: [rt-users] Where are saved searches stored in the db

2017-01-10 Thread Martin Wheldon
Hi Woody, Check out the following tools: rt-attributes-viewer rt-attributes-editor Both of these read/write attribute information. Best Regards Martin On 2017-01-10 13:51, Woody - Wild Thing Safaris wrote: Thanks Emmanuel, I see the "Content" is encoded, which is why it didn't come up