googl...@kwcpa.com wrote:
  Yet, if I type a 1-line message (no signature,
> etc), and send it, even to myself, it appears in the sent folder, and
> (if i'm the recipient) in my inbox, only as plain text.  No one has
> said that they do this and then upon Viewing Page Source, see type
> HTML.

Correct .... i have done your test.

A. Maintaining: For mail & newsgroup preference my setting is : "Ask me what to do"

A-1. Just typing one line: "This is my text test."
Sending it to me....
The result is:
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-DCC-scarlet.be-Metrics: hel 20001; Body=0
X-UIDL: AFU"!Xoi"!cf6!!QSJ"!

This is my text test.

A-2. Just typing one line: This line is with HTML info.
- centered and with the word HTML in bold and +A
Sending it to me (this time he ask me the sent-format to be used - i say both).....
The result is:
This is a multi-part message in MIME format.
--------------040900020805050504020102
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

This line is with *HTML* info.




--------------040900020805050504020102
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
<div align="center">This line is with <b><big>HTML</big></b> info.<br>
</div>
<pre class="moz-signature" cols="72">
</pre>
</body>
</html>

--------------040900020805050504020102--

A-3. Just typing one line: Send HTML text in HTML-ONLY sending format.
- with the first word HTML in bold and +A
Sending it to me (this time he ask me the sent-format to be used - i say HTML ONLY).....
The result is:
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-DCC-scarlet.be-Metrics: sif 20001; Body=1 Fuz1=1
X-UIDL: ?!6!!j@,"!&7X"!21Z"!

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
Send <b><big>HTML</big></b> text in HTML-ONLY sending format<br>
<pre class="moz-signature" cols="72">
</pre>
</body>
</html>

B. Finally, i changed: For mail & newsgroup preference my setting is : "HTML ONLY"
- then stop/start SM ....same testing....
B-1. Just typing one line: "This is my text test."
Sending it to me....
The result is:
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-DCC-Scarlet-Metrics: rago 1390; Body=0
X-UIDL: 3b3"!`R(#!F`3!!ZlE!!

This is my text test.

B-2.  Just typing one line: This line is with HTML info.
- centered and with the word HTML in bold and +A
Sending it to me....
The result is:
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-DCC-scarlet.be-Metrics: hel 20001; Body=1 Fuz1=1
X-UIDL: )DX"![=A"!NcA"!,@o"!

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
</head>
<body bgcolor="#ffffff" text="#000000">
<div align="center">This line is with <big><b>HTML</b></big> info.</div>
</body>
</html>


CONCLUSIONS:
All is ok, BUT if you don't use any html gadget when composing your mail ... the mail is sent in plain text. In this case, there is no need of a conversion, because there is nothing to convert.
SM 1.1.14 is working perfectly and did not screw up the text sent.
The only thing we can argue, is the explanation about:
For mail & newsgroup preference my setting is : "HTML ONLY"
It is written: "Send the message as formatted text(HTML) ANYWAY..."
This sentence is true only if there is at least ONE html gadget present in the mail.
_______________________________________________
support-seamonkey mailing list
support-seamonkey@lists.mozilla.org
https://lists.mozilla.org/listinfo/support-seamonkey

Reply via email to