Hi Jens,

Am 04.04.2012, 11:17 Uhr, schrieb Jens Vagelpohl <j...@dataflake.org>:

I have fixed it by creating a small buildout configuration at the root of the package that will create a working sphinx-build script under bin/ with all the dependencies set up, and by replacing all faulty module references to "CMFDefault" with "Products.CMFDefault".

At the risk of looking like Baldrick: which configuration are you referring to? CMFDefault's own buildout or the top-level one? I see the CMF buildout has gained the sphinx-quickstart command but I haven't quite worked out how to get this to run using my local files.

fuchsia:CMF charlieclark$ bin/sphinx-build src/Products.CMFDefault/docs tmp
Running Sphinx v1.1.2

Exception occurred:
File "/Users/charlieclark/Sites/CMF/src/Products.CMFDefault/docs/conf.py", line 16, in <module>
    import pkginfo
ImportError: No module named pkginfo

sphinx-build no longer works. Or should I be working from CMFDefault checkout and building from there?

I also cleaned up many Sphinx complaints about bad formatting.

Thanks. I'm still working on fixing up the intra-document references and footnotes which I want to be able to build before checking in.

Charlie Clark
Managing Director
Clark Consulting & Research
German Office
Kronenstr. 27a
D- 40217
Tel: +49-211-600-3657
Mobile: +49-178-782-6226
Zope-CMF maillist  -  Zope-CMF@zope.org

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests

Reply via email to